ezBank 2.5.5 - Herzlich willkommen

Symbol ezBank 2.5.5
Banking-Anwendung zur SEPA-Dateierstellung
 ezSoftware, Erich Schuster - Hauptstrasse 18 - CH-8253 Diessenhofen - www.ezBanking.info

Herzlich willkommen

Mit ezBank 2.5.5 erhalten Sie ein sehr komfortables und dennoch einfach zu bedienendes Programm zur Erstellung der Bankdateien für elektronische Überweisungen und Einziehungen, sowohl im SEPA-Format wie auch noch im bisherigen DTAUS-Format.
Durch die Importmöglichkeit von DTAUS-Dateien bestens geeignet auch zum Umwandeln von DTAUS-Dateien ins neue SEPA-Format. Aber auch zum Bearbeiten der Zahlungsdaten vor erneuter DTAUS-Erstellung.

ezBank 2.5.5 bietet Ihnen alle Funktionen einer modernen Software-Anwendung:

  • Intuitive, hochproduktive Benutzeroberfläche
  • Integration mit MS Word, MS Excel und LibreOffice
  • Dokumentenmanagement mit Scan-Funktion und PDF-Unterstützung
  • Zentrale Kommunikationsplattform (E-Mail, Telefon, SMS, Fax, Brief)
  • CTI-Telefonie über TAPI oder VoIP (SIP-Softphone) sowie Anruferkennung
  • Vielfältige Druckfunktionen (Listen und Berichte)
  • Leistungsstarke Such- und Filterfunktionen, inkl. phonetischer Suche
  • Flexibel konfigurier- und anpassbar mit benutzerdefinierten Feldern

Bildschirmfoto

Weiter zum Kapitel Allgemeine Einführung ...


ezBank 2.5.5 - Allgemeine Einführung

Allgemeine Einführung

ezBank 2.5.5 ist eine sehr flexible und komfortable Anwendung zum Erstellen der SEPA-Dateien oder auch DTAUS-Dateien für den elektronischen Zahlungsverkehr mit der Bank, sowohl für Überweisungen wie auch für Basis-Lastschriften und Firmenlastschriften. Mit intuitiv und damit einfach bedienbarer Oberfläche, bestens geeignet für Büros, kleine Unternehmen (SOHO) wie auch im Privatbereich.
Die Übertragung der Bankdateien an die Bank erfolgt in der Regel direkt über das Online-Banking-Portal Ihrer Bank. Oder auch mittels einer geeigneten Software, z.B. StarMoney oder SFIRM von der Kreissparkasse oder db-direct MC.

Da wir großen Wert auf die Zufriedenheit unserer Kunden legen, können Sie bei Anregungen und Verbesserungsvorschlägen sowie bei Fragen über unsere ständig besetzte Hotline direkt mit den Entwicklern von ezBank 2.5.5 sprechen (siehe Kapitel Kontaktmöglichkeiten).

In diesem Kapitel finden Sie einen Überblick über den Leistungsumfang und die verfügbaren Zusatzmodule sowie allgemeine Informationen zu ezBank 2.5.5.

Beschreibung

Copyright-Vermerk

Systemvoraussetzungen

Erste Schritte

Weiter zum Kapitel Installation ...


ezBank 2.5.5 - Beschreibung

Beschreibung

Komfortabel - Bereits in der Grundversion verwaltet ezBank 2.5.5 beliebig viele Überweisungen und Lastschriften, sehr einfach auch als Daueraufträge mit beliebigem Intervall (monatlich, 2-monatlich, viertel-, halb- oder jährlich). ezBank 2.5.5 bietet Ihnen dabei umfangreiche Filter-, Such- und Export-Möglichkeiten, erlaubt frei definierbare Drucklisten, und erstellt verschiedene Berichte.

Skalierbar - Die Standardversion von ezBank 2.5.5 erlaubt die Eingabe von unbeschränkt vielen Konten, Gegenkonten und Zahlungsaufträgen auf einem Arbeitsplatz.
Netzwerkinstallation: Die Banking-Anwendung zur SEPA-Dateierstellung ezBank 2.5.5 ist aber auch als netzwerkfähige Version erhältlich. Damit können unter einem Netzwerk (z.B. Windows Server, NAS-Server, Linux-Server, Novell NetWare und weitere) bis zu sechs Benutzer gleichzeitig mit ezBank 2.5.5 arbeiten. Mit der SQL-Version unter einem Microsoft SQL-Server auch unbegrenzt viele Benutzer.

::: Merkmale :::


ezBank 2.5.5 - Merkmale

Merkmale

  • Erstellung von SEPA-Dateien, sowohl für Überweisungen wie auch für Basis-Lastschriften und Firmenlastschriften
  • Erstellen von DTAUS-Dateien, für Überweisungen und Lastschriften (Einziehungen und Abbuchungen)
  • Importmöglichkeit von DTAUS-Dateien, bestens geeignet zum Umwandeln von DTAUS-Dateien in SEPA-Dateien oder auch zum Bearbeiten der Zahlungsdaten vor erneuter DTAUS-Erstellung
  • Übertragung der erstellten DTAUS- oder SEPA-Datei an die Bank auch mittels geeigneter DFÜ-Software möglich
  • Getestet mit SFIRM (Kreissparkassen), db-direct MC (Bank 24), StarMoney, und vieles mehr
  • Konten, Gegenkonten und Banken als Stammdaten immer wieder zu verwenden
  • Alle Zahlungsanweisungen können auch als Daueraufträge angelegt werden
  • Kontonummernprüfung zur Prüfung einer eingegebenen Kontonummer gegenüber der angegebenen Bankleitzahl
  • Import-Möglichkeiten von Konten, Gegenkonten und Zahlungsaufträgen aus Access, Excel, dBase, Textdateien
  • Alle Listen mit der Möglichkeit zur Änderung der Spalten und Definition von Farben, mit Filterbar, Mausrad-Unterstützung und vieles mehr
  • Frei definierbare Eingabemasken zu Gegenkonten und Zahlungsaufträge für eigene Felder
  • Intelligente und flexible Such- und Filterfunktionen, auch für Exports und Drucklisten
  • Wahlweise vollautomatische und/oder halbautomatische Datensicherung
  • Intuitiv bedienbare Benutzeroberfläche, mit vielen Einstellungsmöglichkeiten zum individuellen Arbeiten
  • Optional mit Netzwerkfähigkeit für mehrere Benutzer in einem kleinen Netzwerk


ezBank 2.5.5 - Copyright-Vermerk

Copyright-Vermerk

Das Programm ezBank 2.5.5 inklusive der Dokumentation untersteht dem Urheberrecht. Das Copyright liegt ausschließlich beim Autor,
- ezSoftware (Erich Schuster) - Hauptstrasse 18 - CH-8253 Diessenhofen -
Das bedeutet, die Vollversion des Programmes (Lizenz) darf weder an andere Personen weitergegeben, noch auf mehr als einem PC bzw. Netzwerk installiert werden.

Aber...
... Sie dürfen das Installationspaket gerne an andere Interessenten weitergeben, sofern NICHT Ihre persönliche Lizenzdatei (ezBank.lic) mitgegeben wird. Ohne diese persönliche Lizenzdatei ist das Programm eine Testversion, die voll funktionsfähig ist, aber am Anfang einen Hinweis auf die Testversion anzeigt.
Also: geben Sie das Programm ezBank ruhig weiter, aber keinesfalls Ihre persönliche Lizenzdatei 'ezBank.lic'.


ezBank 2.5.5 - Systemvoraussetzungen

Systemvoraussetzungen

Die Systemvoraussetzungen zum Installieren und Benutzen von ezBank sind:
  • PC mit Intel Core Prozessor und 8 GB Hauptspeicher (oder mehr). Empfohlen werden wenigstens 16 GB Hauptspeicher.
  • Windows 7 oder 8 oder höher - auf Mac: Virtual PC, Parallels oder Bootcamp mit entsprechend installiertem Windows. Empfohlen wird Windows 10 oder 11.
  • Festplatte mit mindestens 20 GB freiem Speicherplatz.
  • Grafikkarte und Bildschirm mit einer Auflösung von wenigstens 1024 x 768 (XGA) oder 1280 x 1024 (SXGA) Bildpunkten (Pixel). Empfohlen wird eine Auflösung von 1920 x 1080 (Full-HD) oder 1920 x 1200 (WQXGA) Bildpunkten.
Um alle Möglichkeiten von ezBank zu nutzen wird folgende Hard- und Software empfohlen:
  • Installierter Windows-Drucker, für Korrespondenz und Drucklisten
  • Microsoft Word oder LibreOffice Writer zum Erstellen der täglichen Korrespondenz und Serienbriefe
  • Microsoft Excel zum Erstellen von Excel-basierten Berichten
  • Internetbrowser (Google Chrome, Mozilla Firefox, Opera, Microsoft Edge) zum Anzeigen von HTML-basierten Berichten
  • Druckertreiber CIB pdf brewer zum automatischen Erstellen von PDF-Dokumenten aus Word-Vorlagen
  • StepOver-Unterschrifts-PAD zum Signieren und Unterschreiben von PDF-Dokumenten
  • Dazu die Software eSignatureOffice Standard von der Firma StepOver GmbH zur sicheren handgeschriebenen e-Signatur
  • Adobe Acrobat Reader zum Anzeigen der erstellten PDF-Dateien
  • Druckertreiber FinePrint für eine Druckvorschau
  • CTI-Telefon (TAPI-fähig oder VoIP über ein SIP-Softphone) zum Telefonieren aus ezBank
  • ISDN oder TAPI zum Anzeigen hereinkommender Telefonanrufe
  • Scanner/Digitalkamera (TWAIN-fähig) zum Einscannen/Fotografieren von Dokumenten/Bildern


ezBank 2.5.5 - Erste Schritte

Erste Schritte

Wenn Sie mit der Arbeit mit ezBank 2.5.5 beginnen, empfehlen wir Ihnen, die im folgenden beschriebenen Schritte durchzuführen.

So legen Sie die Basis für die Arbeit mit ezBank 2.5.5:

::: Installation und erster Start :::

Datenübernahme - Falls Sie vor ezBank 2.5.5 mit einem anderen Programm gearbeitet haben, wird die Datenintegration (Übernahme der Daten) in der Regel kostenfrei von ezSoftware (Erich Schuster) durchgeführt, wenn Sie uns die Daten in einem offenen Format (z.B. Excel-Tabelle oder Accessdatenbank) zur Verfügung stellen können. Siehe auch Kapitel Kontaktmöglichkeiten.


ezBank 2.5.5 - Installation und erster Start

Installation und erster Start

Schritt 1: Installation
Zuerst installieren Sie ezBank. Die Installation ist sehr einfach durchzuführen und erfordert keine besonderen Kenntnisse. Nachdem Sie die Installation beendet haben, finden Sie ezBank in dem Menü "Start" auf Ihrem Desktop unter dem Menüpunkt "Programme" eingetragen.
Zu jeder Möglichkeit der Installation gibt es einen entsprechenden Abschnitt in der Dokumentation (siehe Kapitel Installation).

Schritt 2: erster Start "Datenbasis anlegen"
Beim ersten Start von ezBank 2.5.5 wird die Datenbasis (eine Access-Datenbank 'ezBank.mdb') angelegt. Dazu erscheint ein Dialog "Willkommen bei den ersten Schritten" mit der Möglichkeit, die Datenordner zu bestimmen und die Datenbasis neu anzulegen. Damit haben Sie eine vollkommen neue, leere Datenbank. (siehe: Erster Start - Einstellungen).

Schritt 3: Eingabe von Daten
Mit Klick auf "Fertigstellung" sind die ersten Schritte abgeschlossen und Sie können nun bereits die ersten Daten eingeben.

Schritt 3a: Eingabe mindestens eines Kontos
Voraussetzung ist natürlich die Angabe eines Kontos mit Bezeichnung, Kontonummer und BLZ sowie dem Namen des Inhabers.
Dazu haben Sie nach dem ersten Start von ezBank auch sofort die beste Gelegenheit. Aber auch später noch können Sie im Programm selbst noch Konten anlegen oder bestehende Konten ändern oder auch wieder löschen.

Schritt 3b: Eingabe von Zahlungsaufträgen
Nun können Sie bereits die ersten Zahlungsaufträge eingeben.

Anlegen eines Zahlungsauftrages:

  1. Um einen Zahlungsauftrag anzulegen, gehen Sie auf den Hauptmenüpunkt "Zahlungen" und klicken auf den Menüpunkt "Neu".
  2. Es öffnet sich ein Dialog, durch den Sie den Zahlungsauftrag anlegen können, und zwar als Überweisung oder als Lastschrift, beides auch als Dauerauftrag. (siehe Kapitel Zahlungsauftrag eingeben)


ezBank 2.5.5 - Installation

Installation

In diesem Kapitel werden die Installationsmöglichkeiten von ezBank beschrieben. Das ist einmal grundsätzlich der Download vom Internet und die Installation des Programmpakets. Außerdem die Installation in einem Netzwerk (Server und Arbeitsplatz) sowie weitere Informationen zur Installation.

Installation des Programmpakets

Das Installationsverzeichnis

Netzwerkinstallation

Erster Start - Einstellungen

Karteien

Update

Datenumzug auf einen neuen Rechner

Weiter zum Kapitel Einstellungen ...


ezBank 2.5.5 - Installation des Programmpakets

Installation des Programmpakets

Unter "www.ezBanking.info" mit Klick auf "Installieren/Download" laden Sie sich zunächst das Installationspaket "ezBank255.exe" vom Internet auf Ihren Rechner. Dabei hängt es von Ihrem verwendeten Internetbrowser ab, ob der Download sofort startet, oder ob Sie vorher gefragt werden und wählen können, wohin das Installationspaket gespeichert werden soll.

Nach erfolgreichem Download der Datei starten Sie dann dieses Installationspaket, z.B. über den Explorer, und folgen Sie den Anweisungen der Installation. Dabei sind die Voreinstellungen, z.B. für den Installationsordner, in der Regel der empfohlene Weg.

Haben Sie eine Lizenzdatei 'ezBank.lic', dann speichern Sie diese vor dem ersten Start von ezBank einfach auf den Desktop ab. Dann wird beim Starten von ezBank diese Lizenzdatei automatisch vom Desktop geholt und installiert.

Jetzt können Sie ezBank bereits zum ersten Mal starten und die ezBank-Datenbasis anlegen. (siehe Lektion Erster Start - Einstellungen)


ezBank 2.5.5 - Das Installationsverzeichnis

Das Installationsverzeichnis

Empfohlen wird, die Installation von ezBank in den vom Setup-Programm vorgeschlagenen Ordner vorzunehmen, z.B. C:\Program Files (x86)\ezBank.
Keinesfalls sollte die Installation direkt auf den Desktop erfolgen!

Die ezBank-Daten sollten allerdings unbedingt an einem anderen Ort liegen, z.B. auf einer anderen Festplatte oder auf einem Netzwerklaufwerk auf dem Server oder zumindest in einem anderen Ordner, z.B. C:\ezBank. Diese Trennung der Daten vom Programm wird also dringend empfohlen. Aber auch die Daten sollten nicht direkt auf dem Desktop liegen.

Wo ist ezBank installiert?
Wenn Sie nicht mehr wissen, wo sich das Installationsverzeichnis von ezBank befindet, gehen Sie mit dem Mauszeiger dorthin, von wo Sie ezBank gewöhnlich aufrufen. Das kann z.B. ein Symbol (Icon) auf Ihrem Desktop sein oder im Windows-"Start"-Menü unter "Programme" - "ezBank" der entsprechende Programmeintrag. Klicken Sie mit der rechten Maustaste darauf und es erscheint ein Auswahlmenü mit mehreren Einträgen. Mit Klick auf Dateipfad öffnen gelangen Sie direkt über den Windows Explorer in den Installationsordner.

Was und wo ist die Datenbank?
Die Datenbank ist eine Access-Datenbank 'ezBank.mdb'. Diese Datenbasis befindet sich im sogenannten Datenbankordner, der beim ersten Start von Ihnen festgelegt werden konnte, aber auch wieder geändert werden kann.
Als Datenbankordner empfohlen und vorgegeben wird C:\ezBank - der Standard-Datenbankordner von Windows ist allerdings "C:\ProgramData\ezBank", das aus verschiedenen Gründen so aber nicht empfohlen werden kann. Beispielsweise ist dieser Ordner in Windows versteckt und damit zunächst unsichtbar. Sie finden ihn also nicht im Explorer, wenn bei den Windows-Ordneroptionen eingestellt ist, dass versteckte Dateien und Ordner nicht angezeigt werden sollen.
Wo sich Ihre aktuelle Datenbank nun befindet wird in der Standard-Kartei angezeigt: In ezBank im Menü "Datei" - "Öffnen..." beim ersten Eintrag "Standard" in der Spalte "Ordner".
Ändern können Sie den Datenbankordner im Menü "Einstellungen" mit "DB-Ordner wählen...".


ezBank 2.5.5 - Netzwerkinstallation

Netzwerkinstallation

Soll ezBank in einem Netzwerk installiert werden ist zunächst einmal die Netzwerk-Lizenz zwingende Voraussetzung. Eine Einzelplatz-Lizenz läuft nicht auf einem Server.

Für eine Netzwerk-Installation empfehlen wir, das Programmpaket und die Lizenzdatei (ezBank.lic) auf dem Server in einen allgemein freigegebenen Ordner zu kopieren. Das kann z.B. ein Ordner 'Setup' sein. Von diesem Ordner kann dann jeder Arbeitsplatz das Programm installieren und sich die Lizenzdatei holen (kopieren).
Auch bei einem späteren Update kopieren Sie dann jeweils das Update-Installationspaket in diesen Setup-Ordner auf den Server. Dann kann wiederum jeder Arbeitsplatz sehr einfach das Update direkt vom Server installieren.

Installation

Zur Installation in einem Netzwerk beachten Sie bitte die Reihenfolge:

  1. Installieren von ezBank auf dem Server (nicht zwingend notwendig)
  2. Anlegen (oder Kopieren) der ezBank-Datenbasis auf den Server, z.B. durch Starten von ezBank
  3. Installieren der Lizenz (wenn lizenziert) - am besten in den Datenbankordner
  4. Freigeben des Ordners mit der ezBank-Datenbasis auf dem Server
  5. Auf dem Arbeitsplatzrechner den freigegebenen Ordner als Netzlaufwerk verbinden
  6. Installieren von ezBank auf dem Arbeitsplatz
  7. Auswahl des Netzlaufwerks als ezBank-Datenbankordner
  8. Liegt die Lizenzdatei im Datenbankordner, dann ist die Installation der Lizenz auf jedem Arbeitsplatz NICHT nötig!

::: Server-Installation :::

::: Arbeitsplatz-Installation :::

::: Terminalserver-Lösung :::


ezBank 2.5.5 - Server-Installation

Server-Installation

Bevor Sie die Arbeitsplatz-Installation durchführen, sollte die ezBank-Datenbasis auf dem Server vorhanden sein, entweder indem Sie ezBank direkt auf dem Server installieren, oder indem die Datenbasis von einer anderen Installation auf den Server kopiert wurde.

Variante 1 - direkte Installation auf dem Server:
Nachdem Sie die Installation des Installationspakets auf dem Server wie beschrieben durchgeführt haben, legen Sie die ezBank-Datenbasis an, indem Sie ezBank einmal starten. Dafür machen Sie einen Doppelklick auf das ezBank-Icon auf Ihrem Desktop oder wählen vom Windows-"Start"-Menü unter "Programme" - "ezBank" den entsprechenden Programmeintrag aus. Als erstes erscheint das Fenster "Willkommen bei den ersten Schritten". Nachdem Sie mit Datenordner bestimmen... den gewünschten Datenbankordner bestimmt haben wird mit Klick auf die Schaltfläche Datenbasis anlegen... die Datenbank in diesem Ordner erstellt. Wenn die daraufhin ablaufenden Datenbank-Operationen beendet sind, können Sie nach Eingabe der Stammdaten diese ersten Schritte nun mit einem Klick auf die Schaltfläche Fertigstellung nun vollenden und damit das Fenster schließen. Nun wird ezBank gestartet und Sie können bereits am Server damit arbeiten, wenn vorhanden die Lizenz installieren - am besten direkt in den Datenbankordner - oder ezBank gleich wieder beenden. (siehe Lektion Erster Start - Einstellungen)

Variante 2 - Datenbasis auf den Server kopieren:
Dazu muss ezBank auf irgendeinem Rechner installiert werden, entweder ein späterer Arbeitsplatz-Rechner oder ein temporär dazu verwendeter Rechner. Dann legen Sie dort die ezBank-Datenbasis an, indem Sie ezBank einmal starten. Nachdem wie oben beschrieben die Datenbasis im angegebenen Datenbankordner angelegt wurde, können Sie die erstellte Datenbasis auf einen beliebigen Ordner auf den Server kopieren.

Hinweis: Egal mit welcher dieser beiden Varianten die ezBank-Datenbasis auf dem Server im Datenbankordner erstellt wurde, zum Zugriff auf diesen Datenbankordner muss dieser Ordner nun mit Schreibrechten freigegeben werden. Auf den Arbeitsplatzrechnern dann wird dieser freigegebene Ordner jeweils als Netzlaufwerk verbunden und steht somit als Laufwerk zur Verfügung.


ezBank 2.5.5 - Arbeitsplatz-Installation

Arbeitsplatz-Installation

Voraussetzung ist, dass auf dem Server der Datenbankordner mit Schreibrechten freigegeben wurde und auf dem Arbeitsplatzrechner dieser freigegebene Ordner als Netzlaufwerk verbunden ist.

Nachdem Sie die Serverinstallation von ezBank durchgeführt haben, installieren Sie ezBank nach der bereits beschriebenen Installationsanweisung auf einem Arbeitsplatz. Nun starten Sie ezBank, entweder durch einen Doppelklick auf das ezBank-Icon auf Ihrem Desktop oder vom Windows-"Start"-Menü unter "Programme" - "ezBank" mit Klick auf den entsprechenden Programmeintrag. Als erstes erscheint das Fenster "Willkommen bei den ersten Schritten". Nachdem Sie mit Datenordner bestimmen... den auf dem Server existierenden Datenbankordner bestimmt haben ändert sich die Schaltfläche von Datenbasis anlegen... in Datenbank öffnen.... Nach dem Öffnen der Datenbank ist mit einem Klick auf die Schaltfläche Fertigstellung nun die Arbeitsplatz-Installation bereits beendet. Nun wird ezBank gestartet und die angegebene Datenbank auf dem Server geöffnet.

Hinweis: Zu beachten ist, dass bei einer Netzwerk-Installation die Lizenzdatei (ezBank.lic) - sofern eine lizenzierte Version installiert wird - nicht nur auf dem Server, sondern auch auf allen Arbeitsplätzen zur Verfügung stehen muss.
Deshalb wird die Lizenzdatei bei der ersten Installation auch im Datenbankordner abgelegt. Dann hat jeder Arbeitsplatz automatisch Zugriff auf diese Lizenz und benötigt KEINE Lizenz-Installation auf dem Arbeitsplatz mehr.


ezBank 2.5.5 - Terminalserver-Lösung

Terminalserver-Lösung

ezBank läuft auch problemlos auf einem Terminalserver. Voraussetzung dazu ist eine ezBank-Netzwerklizenz.

Eine Terminalserver-Lösung ermöglicht Ihnen die Ausführung eines Programms auf dem Server über ein beliebiges im Intranet stehendes Terminal. Ein Terminal bezeichnet dabei eine Einheit aus Tastatur und Bildschirm, die mit dem Server lediglich Bildschirminhalte und -änderungen sowie Tastatur und Maus-Informationen austauscht.
Eine weitere interne Verarbeitung im PC erfolgt nicht, es werden wie beschrieben nur Bildschirminformationen empfangen und Tasten- und Maus-Informationen an den Server gesendet. Auf diese Weise können beliebige Programme zentral auf einem Server ausgeführt werden.

Ein ähnliches Konzept wäre über eine Remotedesktop-Server-Lösung realisierbar. Hierzu wählt man sich über eine Remote-Software auf den Server und steuert diesen quasi aus der Ferne, als säße man davor.

Beide Lösungen haben den Vorteil der größten Flexibilität und Unabhängigkeit. Der Nachteil liegt in den für den Aufbau dieser Infrastruktur verbundenen höheren Kosten für Terminalserver oder Remotedesktop-Server-Lösung.

Hinweis: Diesen Nachteil können Sie auch kompensieren, indem Sie keine eigene Infrastruktur aufbauen, sondern die Lösung eines externen Windows-Server-Anbieters mit Remotedesktop-Zugängen nutzen.


ezBank 2.5.5 - Erster Start - Einstellungen

Erster Start - Einstellungen

Beim ersten Start von ezBank 2.5.5 öffnet sich das Fenster "Willkommen bei den ersten Schritten – notwendig nur beim ersten Programmstart". Das Fenster besteht aus mehreren Schaltflächen, hinter denen für die Einrichtung von ezBank 2.5.5 notwendige Funktionen stehen. Neben jeder Schaltfläche steht eine kurze Erklärung. Es sind immer die Schaltflächen aktiv, die noch nicht bedient wurden. Die Schaltflächen sollten in der Reihenfolge von oben nach unten bedient werden.

Willkommen bei den ersten Schritten

Folgende Schaltflächen gibt es und so funktionieren sie:

Sprache wählen - select language
Die Anwendung ezBank 2.5.5 hat eine mehrsprachige Oberfläche. Hier können Sie aus den fünf Sprachen Deutsch, Englisch, Französisch, Italienisch und Spanisch die gewünschte Sprache wählen. Dann wird die Oberfläche sowie die Hinweis- und Fehlermeldungen von ezBank 2.5.5 in dieser Sprache angezeigt.

Land bestimmen...
Unabhängig von der gewählten Sprache bestimmen Sie hier Ihr Heimatland, in welchem diese Anwendung läuft. Dadurch legen Sie die Voreinstellungen zu Land und Währung fest, die unter anderem bei Neuanlage einer Person zur Geltung kommen.
Diese Einstellungen können später im Menü "Einstellungen" - "Optionen" im Reiter "Vorgaben" jederzeit wieder geändert werden.

Datenordner festlegen...
Hier können Sie die wichtigsten vorgegebenen Datenordner ändern, z.B. auf festgelegte Netzwerk-Ordner. Das betrifft den lokalen Datenordner, den Datenbankordner, Vorlagen-Basisordner und Dokumente-Basisordner. Dabei sind zwei Möglichkeiten "Windows-Standard" und "unsere Empfehlung" als Vorgabe oder auch ganz individuelle eigene Ordner wählbar.
Auch diese Einstellungen können jederzeit im Nachhinein noch geändert werden. Dazu klicken Sie im Menü "Einstellungen" - "Optionen" auf den Reiter "Ordner". Dort werden alle Ordner aufgelistet und können verändert werden. (Siehe Lektion Ordner-Definitionen im Kapitel Einstellungen)

Datenbasis anlegen...
Nun wird die Datenbasis (die bereits erwähnten MS-Access-Datenbanken) neu angelegt oder geöffnet. Beim ersten Start von ezBank 2.5.5 wird in der Regel eine neue Datenbasis angelegt. Dazu stehen im nächsten Fenster "Datenbasis anlegen..." folgende Möglichkeiten zur Verfügung:
Datenbasis im angegebenen Datenbankordner neu anlegen:
Diese Möglichkeit ist beim ersten Arbeiten mit ezBank 2.5.5 die sinnvollste. Im Datenbankordner, der oben nochmal angezeigt wird, wird eine vollkommen neue, leere Datenbank angelegt.
Datenbasis von einer anderen Quelle kopieren:
Falls Sie schon eine ezBank 2.5.5-Datenbasis haben, können Sie nun diese von einer Quelle in den angegebenen Datenbankordner kopieren.
Einen anderen Datenbankordner wählen:
Falls Sie die Datenbasis in einem anderen Ordner als den angegebenen Datenbankorder haben, können Sie hier nun diesen Ordner als Datenbankordner definieren. Dann wird die Datenbasis in diesem Ordner geöffnet.

Fertigstellung
Mit Klick auf die Fertigstellen-Schaltfläche wird ezBank 2.5.5 nun mit allen vorgenommenen Einstellungen geöffnet. Ab jetzt wird das Fenster "Willkommen bei den ersten Schritten" nie mehr geöffnet werden. Die Einstellungen, die Sie über dieses Fenster vornehmen konnten, können Sie aber auch hinterher im Programm vornehmen. Viel Spaß bei der Arbeit mit ezBank 2.5.5.


ezBank 2.5.5 - Karteien

Karteien

Als 'Kartei' wird der Ordner bezeichnet, welcher die Datenbasis enthält. Mit Hilfe von Karteien können Sie von einander getrennte verschiedene Datenbanken führen. Ein Beispiel dafür ist die Trennung wichtiger Geschäftsdaten von Testdaten.
Welche Kartei Sie gerade geöffnet haben erkennen Sie an der Pfadangabe des Datenbankordners rechts unten auf Ihrem Bildschirm in der Programmstatusleiste.

Hinweis: Die Daten der verschiedenen Karteien sind völlig separat, können nicht zusammen durchsucht oder bearbeitet werden und auch eine Zusammenführung von Daten aus verschiedenen Karteien ist bestenfalls teilweise über die Export- und Importfunktion möglich.
Wenn also zwischen fluktuierenden (schnell ändernden) Daten eine unmittelbare Beziehung besteht, wie z.B. zwischen Interessenten- und Kundendaten, dann bietet es sich unter Umständen an, zur Kategorisierung dieser Daten anstelle der Karteien die Adressarten zu benutzen. Nach Adressarten kann gefiltert werden und die Liste der gefilterten Daten kann vielseitig genutzt werden.

Erstellen einer neuen Kartei

  1. Klicken Sie auf den Menüpunkt "Neu" des Hauptmenüpunkts "Datei". Es öffnet sich der Dialog "Neuen Datenbankordner wählen", mit dessen Hilfe Sie den Ordner, welcher die neue Datenbasis enthalten soll, im System auswählen können. Sie haben auch die Möglichkeit einen neuen Ordner über diesen Dialog anzulegen, um diesen dann als Ordner für die neue Kartei zu nutzen. Bestätigen Sie Ihre Eingaben mit Klick auf die Schaltfläche OK.
  2. Im Dialog "Neue Kartei" gibt es folgende Felder:
    Bezeichnung:
    Hier geben Sie einen Namen für die neue Kartei ein.
    Datenbankordner:
    Hier wird der Ordner angezeigt, den Sie zuvor im Dialog "Neuen Datenbankordner wählen" ausgewählt haben. Sie haben die Möglichkeit, wieder einen anderen Ordner zu wählen, indem Sie auf die kleine "Ordner"-Schaltfläche hinter dem Feld "Datenbankordner" klicken.
    Vorlagen-Basis:
    Den Ordner, den Sie hier als Vorlagen-Basis festlegen, wird für alle Vorlagenordner (Briefe, Excel, Email, Berichte) übernommen werden. Mit der "Ordner"–Schaltfläche hinter dem Feld können Sie den Vorlagen-Basisordner wählen.
    Dokumente-Basis:
    Den Ordner, den Sie hier als Dokumente-Basis festlegen, wird für alle Dokumente-Ordner (Dokumente, Scans, Briefe, Excel, Emails) übernommen werden. Mit der "Ordner"–Schaltfläche hinter dem Feld können Sie den Vorlagen-Basisordner wählen.
    Hintergrundfarbe und Logo-Bilddatei:
    Damit Sie sofort sehen können, auf welcher Datenbank Sie arbeiten, können Sie jeder Datenbank eine Farbe und ein Logo zuordnen. Zum Auswählen der Farbe doppelklicken Sie einfach auf die kleine Farbanzeige hinter "Hintergrundfarbe". Um eine Bilddatei zu wählen, klicken Sie auf die kleine Schaltfläche hinter "Logo-Bilddatei".
    Bestätigen Sie Ihre Eingaben mit Klick auf die Schaltfläche OK im Dialog "Neue Kartei".
  3. Als nächstes öffnet sich das Fenster "Datenbasis anlegen...". Hier wird noch einmal der Datenbankordner angezeigt. Als Option ist automatisch und richtig "Datenbasis im angegebenen Datenbank-Ordner neu anlegen" aktiviert. Wenn Sie nun auf "Weiter" klicken, wird im Fenster "Datenbank-Operationen" angezeigt, dass die neue Kartei angelegt wird.
  4. Nach der Fertigstellung wird mit Schliessen des Fensters "Datenbank-Operationen" die neue Kartei automatisch geöffnet. Erkennen können Sie das an der Pfadangabe des Datenbankordners rechts unten auf Ihrem Bildschirm in der Programmstatusleiste.

Öffnen einer bestehenden Kartei

  1. Klicken Sie auf den Menüpunkt "Öffnen" des Hauptmenüpunkts "Datei". Es öffnet sich der Dialog "Kartei wählen" mit einer Liste aller bereits angelegten Karteien.
  2. Wählen Sie in der Liste diejenige Kartei aus, die Sie öffnen möchten, und bestätigen Sie mit Klick auf die Schaltfläche Öffnen.
  3. Diese Kartei ist nun bis zum Beenden von ezBank geöffnet. Erkennen können Sie das wiederum an der geänderten Pfadangabe des Datenbankordners rechts unten auf Ihrem Bildschirm in der Programmstatusleiste.

Hinweis: Mit der Funktion "DB-Ordner wählen" im Hauptmenüpunkt "Einstellungen" definieren Sie, welche Datenbank beim Starten von ezBank zuerst verwendet, also geöffnet wird. Diese Kartei wird hier als 'Standard' angezeigt.


ezBank 2.5.5 - Update

Update

Warum ist die Installation von Updates wichtig für Ihre Arbeit?
Updates enthalten immer Verbesserungen des Programms, angefangen von Fehlerkorrekturen über kleine Verbesserungen zur Erhöhung des Benutzerkomforts bis hin zu großen Erweiterungen und neuen Funktionalitäten. Oftmals sind Updates die Antwort auf Vorschläge unserer Kunden und beinhalten die Umsetzung dieser Kunden-Anregungen und Wünsche.

Wann ist ein Update kostenlos?
Haben Sie die Software gemietet, also einen laufenden Software-Mietvertrag, oder zu einer gekauften Version einen Software-Servicevertrag für Pflege und Support, dann ist jedes Update kostenlos, auch jeder Wechsel zu einer neuen aktuellen Softwareversion.
Ansonsten, also bei einer gekauften Version OHNE laufenden Software-Servicevertrag, sind nur Updates innerhalb dieser gekauften Version kostenlos. Dabei ändert sich innerhalb der Version nur der Buchstabe der letzten Stelle, z.B. von ezBank 2.5.5a auf ezBank 2.5.5b.

Durchführen eines Online-Updatechecks und Installation eines Updates
Wenn Sie herausfinden möchten, ob es eine neuere Version des Programms gibt als die, die Sie installiert haben, führen Sie einen Online-Updatecheck durch. Klicken Sie dazu im Menü "Hilfe" auf "Online-Updatecheck". Es öffnet sich der Internetbrowser, und gleichzeitig überprüft das System, ob eine aktuellere Version zur Verfügung steht. Dann wird eine Internetseite angezeigt, aus der Sie eine Update-Installation durchführen können. Achten Sie bitte darauf, ob dieses Update für Sie kostenpflichtig ist oder nicht.
Bei der Installation eines Updates bleiben ihre eingegebenen Daten selbstverständlich immer erhalten. Dennoch ist es empfehlenswert, vor der Installation das aktuelle Installationsverzeichnis komplett zu sichern und alle laufenden Anwendungen zu beenden.

Mit Klick auf einen Downloadlink des Updatepakets laden Sie sich zunächst das Installationspaket vom Internet auf Ihren Rechner. Dabei hängt es von Ihrem verwendeten Internetbrowser ab, ob der Download sofort startet, oder ob Sie vorher gefragt werden und wählen können, wohin das Installationspaket gespeichert werden soll.
Nach erfolgreichem Download der Datei starten Sie dann dieses Installationspaket, z.B. über den Explorer, und folgen Sie den Anweisungen der Installation. Dabei sind die Voreinstellungen, z.B. für den Installationsordner, in der Regel der empfohlene Weg.
Nun können Sie ezBank starten und kontrollieren, ob die Installation erfolgreich war. Dazu klicken Sie im Menü "Hilfe" auf den Eintrag "Info". Im Titel des kleinen Info-Fensters sehen Sie die aktuelle Versionsnummer des Programms.

Hinweis: Zu beachten ist unbedingt, dass bei einer Netzwerk-Installation ein Update nicht nur auf dem Server, sondern möglichst zeitgleich auch auf allen Arbeitsplätzen durchgeführt wird!

Umsetzen bestehender Daten zur neuen Version
Haben Sie eine neue ezBank-Version installiert, die auch eine neue Datenbank benötigt, dann wird beim ersten Start der neuen Version automatisch eine Datenumsetzung der bestehenden Daten in das Format der neuen Version durchgeführt, wenn Sie dies bestätigen.

Beim Erstellen der Datenbanken und Tabellen und Umsetzen der bestehenden Daten in das neue Format wird der Fortschritt in einem Fenster angezeigt, welches nach Fertigstellung einfach geschlossen werden kann.


ezBank 2.5.5 - Datenumzug auf einen neuen Rechner

Datenumzug auf einen neuen Rechner

Zum Umzug Ihrer ezBank-Installation auf einen neuen Rechner installieren Sie zuerst die Testversion vom Internet, dann kann alles andere (Lizenz und Daten) vom alten Rechner auf den neuen umgezogen werden:
  1. Zum Umzug dieser Daten müssen Sie Ihre Lizenzdatei (ezBank.lic) kopieren und auf dem neuen Rechner installieren (Hilfe - Lizenz installieren).
  2. Dann die ezBank-Datenbasis (eine Access-Datenbank 'ezBank.mdb') vom Datenbankordner des alten Rechners in den Datenbankordner des neuen Rechners kopieren. Der Datenbankordner ist ein beliebiger Ordner, den Sie bei beim ersten Starten von ezBank selbst bestimmen konnten (siehe Lektion Erster Start - Einstellungen).
    Empfohlen und vorgegeben wird C:\ezBank - der Standard-Datenbankordner von Windows ist allerdings "C:\ProgramData\ezBank", das aus verschiedenen Gründen so aber nicht empfohlen werden kann. Beispielsweise ist dieser Ordner in Windows versteckt und damit zunächst unsichtbar. Sie finden ihn also nicht im Explorer, wenn bei den Windows-Ordneroptionen eingestellt ist, dass versteckte Dateien und Ordner nicht angezeigt werden sollen.
  3. Wenn Sie eigene Vorlagen erstellt haben und diese weiter nutzen möchten, dann kopieren Sie auch die Vorlagedateien vom Vorlageordner des alten Rechners in den Vorlageordner des neuen Rechners.
  4. Und wenn Sie auch Dokumente erstellt haben (z.B. Briefe) dann müssen auch die Dokumente von den jeweiligen Dokumenteordner kopiert werden (siehe Lektion Ordner-Definitionen).

Eigentlich ganz einfach, aber Sie müssen erstens wissen, wo alles ist (wo ist der Datenbankordner, Vorlageordner und Dokumenteordner auf dem alten Rechner: siehe 'Einstellungen' - 'Optionen...' - Reiter 'Ordner'), zweitens wohin das kopiert werden soll (wo ist der Datenbankordner, Vorlageordner und Dokumenteordner auf dem neuen Rechner: wird von Ihnen beliebig festgelegt, siehe 'Einstellungen' - 'Optionen...' - Reiter 'Ordner' auf dem neuen Rechner), und drittens wie Sie Daten kopieren können (über den Explorer z.B.).

Bei Problemen oder Fragen dazu können wir Ihnen gerne per Fernwartung helfen. Das ist dann aber kostenpflichtig und nur per Hotline möglich (siehe Kapitel Kontaktmöglichkeiten).

Kleiner Tipp: Wenn Sie die Hotline nicht anrufen können oder möchten und Sie trotzdem unsere Hilfe per Fernwartung oder Hotline-Telefon wünschen, dann gibt es noch die Möglichkeit, 60 Hotline-Minuten zu kaufen: siehe unseren Online-Bestellschein bei 'Service': HOT01 - 60 Hotline-Minuten (1 Stunde) für 120,00 Euro.

Lizenz auf neuen Rechner übertragen
ezBank bemerkt beim ersten Starten, dass dies jetzt ein neues System ist (Windows-Update, neuer Benutzer, neuer Rechner) und fragt nun nach der Deaktivierung der alten Lizenz, damit das neue System lizenziert werden kann.
Bitte folgen Sie einfach der Meldung und deaktivieren Sie die Lizenz Ihres bisherigen Systems, dann wird diese frei für das neue System.


ezBank 2.5.5 - Einstellungen

Einstellungen

Listeneinstellungen

Optionen

Die Zusatzfelder

Sound-Untermalung

Fehlermeldungen

Die Referenzdaten

Eigenschaften

DB-Ordner wählen

Drucklisten allgemein

Druckerdefinitionen

Standardwerte laden

Weiter zum Kapitel Listenbedienung ...


ezBank 2.5.5 - Listeneinstellungen

Listeneinstellungen

Listeneinstellungen Sie können alle großen Listen (z.B. die Gegenkontenliste) in ezBank inhaltlich und optisch nach Ihren Wünschen gestalten. Alle Änderungen beziehen sich dabei immer auf die gerade geöffnete Liste. Den Listeneinstellungsdialog erreichen Sie über die kleine Schaltfläche unten rechts in jeder Liste. An einer Liste können folgende Dinge verändert werden:

::: Allgemeine Einstellungen :::

::: Zeilenmarkierungen :::

::: Spaltendefinitionen :::

::: Einstellungen exportieren :::


ezBank 2.5.5 - Allgemeine Einstellungen

Allgemeine Einstellungen

Die allgemeinen Listeneinstellungen erreichen Sie im Listeneinstellungsdialog mit der Auswahl "Allgemeine und Farb-Einstellungen", und dort im ersten Reiter "Allgemein".

Hinweis: Diese Listeneinstellungen sowie die Farbeinstellungen können bei den Einstellungen Listeneinstellungen ganz allgemein vorgenommen werden und gelten dann für alle Listen gleich.
Dann werden diese Einstellungen hier nur angezeigt und können nicht verändert werden. Erst wenn das Häkchen bei "Für diese Liste die Standardeinstellungen verwenden" entfernt wird können die Einstellungen hier verändert werden und gelten dann hier abweichend von den Standardeinstellungen.

Listeneinstellungen - Allgemein

Folgende Einstellungen können Sie hier vornehmen:

Für diese Liste die Standardeinstellungen verwenden
Wenn diese Einstellung aktiv ist werden die Standardeinstellungen aus den Optionen verwendet und hier nur angezeigt. Erst wenn das Häkchen entfernt wird können die nachfolgenden Einstellungen hier verändert werden und gelten dann so nur für diese Liste.

Darstellung
Hier können Sie unter anderem die optische Erscheinung der Liste bestimmen, also z.B. ob in modernem flachen Stil, ob mit oder ohne Rahmen, ob die Liste mit Linien oder farbig sein soll.
Außerdem bestimmen Sie hier die Höhe der Zeilen sowie das Aussehen der Markierung der aktiven Zeile.

Filterbar
Mit Hilfe der Filterbar kann in den einzelnen Spalten der Tabelle gesucht werden (siehe Lektion Die Filterbar). Hier können Sie nun bestimmen, ob die Filterbar der Liste immer sofort angezeigt werden soll oder nur bei Anforderung über die Toolbar.

Zellentooltips
Hier können Sie Zellentooltips ein- und ausschalten und deren Ansicht gestalten. Zellentooltips sind an den Mauszeiger gebunden. Sobald der Mauszeiger auf einem Feld in der Tabelle verweilt, wird durch den Zellentooltip der Inhalt des Feldes angezeigt. Dies ist vor allem dann praktisch, wenn Sie den Feldinhalt nicht vollständig lesen können und dazu die entsprechende Spalte nicht größer ziehen möchten.

Mehrfachauswahl erlauben
Die Mehrfachauswahl erlaubt das gleichzeitige Markieren mehrerer Datensätze der Liste, beispielsweise um mehrere Datensätze auf einmal zu löschen oder für Massenupdates. Wenn Sie diese Funktion ausschalten, verhindern Sie, dass in einer Liste mehrere Datensätze markiert werden können.

Datensatz ziehen erlauben
Diese Möglichkeit ist nur gegeben, wenn überhaupt Drag/Drop-Operationen unterstützt werden. Eine Voraussetzung dafür ist das Vorhandensein einer Exportvorlage mit Thema "DragDrop", beispielsweise die mitgelieferte VCard-Vorlage . Diese Exportvorlage wird dann beim Ziehen (Drag) eines Datensatzes aus der Liste verwendet und erstellt daraus eine Exportdatei, die z.B. in eine andere ezSoftware-Anwendung gezogen und dort durch Fallenlassen (Drop) importiert werden kann.

Scroll-Automatik einschalten
Die Scroll-Automatik bewirkt, dass beim Scrollen der Liste immer die aktuellen Datensätze angezeigt werden. Die Liste "läuft" sozusagen beim Runterziehen des Scrollbalkens bzw. beim Betätigen des Scrollrades der Maus mit.

Toolbar
Die Toolbar setzt sich aus maximal 8 Bildchen zusammen, hinter welchen jeweils eine Funktionalität steckt. Alle 8 Icons sind hier in Form von 8 Kontrollkästchen vertreten. Durch Anhaken des jeweiligen Kästchens können Sie bestimmen, welche Bildchen und damit welche Funktionalität Sie unterhalb der entsprechenden Liste angezeigt haben möchten. Standardmäßig setzt sich die Toolbar aus den Bildchen "alles Markieren", "Filterbar", "Filter entfernen", "Druckliste", "Standardbericht" und "Spaltenbreiten" zusammen. Eine detaillierte Beschreibung der einzelnen Funktionalitäten mit dem passenden Bildchen finden sie unter Die Toolbar.


ezBank 2.5.5 - Zeilenmarkierungen

Zeilenmarkierungen

Die Zeilenmarkierungen unterstützen Sie bei der Gliederung Ihrer Daten und sind somit eine nützliche Arbeitshilfe. Für alle Listen liefert ezBank bereits einige Zeilenmarkierungen mit, so werden beispielsweise alle am heutigen Tag geänderten oder neu hinzugefügten Datensätze hervorgehoben. Zeilenmarkierungen definieren Sie im Listeneinstellungsdialog mit Auswahl "Allgemeine und Farb-Einstellungen", und dort im Reiter "Zeilenmarkierungen". Das Aussehen der Zeilenmarkierungen (Farbe und Schriftattribute) können Sie im Reiter "Farben" dieses Dialogs ebenfalls selbst bestimmen.

Erstellen einer Zeilenmarkierung

Zum Definieren einer Zeilenmarkierung ordnen Sie einem Feld über einen Operator einen bestimmten Wert zu und legen die Farbe fest, die bei den Zeilen angezeigt werden soll, bei denen diese Bedingung zutrifft. Als Felder stehen dabei alle Felder der Tabelle zur Verfügung, die der aktuellen Liste zugrunde liegt, nicht nur die in der Liste über die definierten Spalten angezeigten Felder.

Folgende Werte stehen speziell bei Datumsfeldern zur Verfügung:
Wert | Bedeutung | Beispiel (Annahme: heute ist der 15.07.2025)
Heute | Das aktuelle Datum. | Es werden alle Datensätze markiert, die im entsprechenden Datumsfeld genau den heutigen Tag haben.
TagMonat | Der aktuelle Tag und der aktuelle Monat, ohne Rücksicht auf das Jahr. | Es werden alle Datensätze markiert, die im entsprechenden Datumsfeld den 15ten Juli haben, egal in welchem Jahr. Verwendung z.B. für Geburtstage heute.
MonatJahr | Der aktuelle Monat und das aktuelle Jahr, ohne Rücksicht auf den Tag. | Es werden alle Datensätze markiert, die im entsprechenden Datumsfeld den Juli 2025 haben, egal welcher Tag. Verwendung zum Markieren des aktuellen Monats.
Tag | Der aktuelle Tag, ohne Rücksicht auf Monat und Jahr. | Es werden alle Datensätze markiert, die im entsprechenden Datumsfeld den 15ten haben. Wozu das gut sein soll weiss ich nicht, aber der Vollständigkeit halber... :-)
Monat | Der aktuelle Monat, ohne Rücksicht auf Tag und Jahr. | Es werden alle Datensätze markiert, die im entsprechenden Datumsfeld den Juli haben. Verwendung z.B. für Geburtstage in diesem Monat.
Jahr | Das aktuelle Jahr, ohne Rücksicht auf Tag und Monat. | Es werden alle Datensätze markiert, die im entsprechenden Datumsfeld das Jahr 2025 haben. Verwendung zum Markieren des aktuellen Jahres.
(egal) | Alle Datumsfelder mit irgendeinem Datum. | Nur in Verbindung mit dem Operator "!! (enthält)": Es werden alle Datensätze markiert, die im entsprechenden Datumsfeld irgendein Datum eingetragen haben. Entspricht der Einstellung # (nicht gleich) (leer).
Folgende Werte stehen allgemein zur Verfügung:
Wert | Bedeutung
Ja bzw. Nein | Macht nur Sinn bei Ja/Nein Feldern. Wählen Sie beispielsweise den Wert "Ja" zum entsprechenden Ja/Nein Feld, so sind alle Datensätze markiert, die dieses Feld angehakt haben.
(leer) | Funktioniert nur bei Textfeldern und Datumsfeldern. Damit markieren Sie entweder alle Datensätze, die nichts enthalten (Operator "= (gleich)") oder die irgendetwas enthalten (Operator "# (nicht gleich)").
eingegebener Wert | Man muss sich nicht an die vorgegebenen Werte in der Liste halten, sondern kann selbst Werte eingeben. Damit diese allerdings eine gliedernde Zeilenmarkierung hervorrufen, braucht man Kenntnisse in der Programmierung. Da helfen wir gerne weiter. Ein Beispiel für einen nicht vorgegebenen Wert: Es sollen in einer Liste mit Adressen/Personen alle diejenigen mit einer bestimmten PLZ blau markiert sein. Dazu wählen Sie das Feld "PLZ", als Operator "!! (enthält)" und tippen als Wert die PLZ ein, z.B. "71101". Als Farbe wählen Sie dann noch "Blau".

Wenn Sie eine Zeilenmarkierung komplett löschen möchten, so markieren Sie den Feldnamen und betätigen die "Entf"- Taste.

Die Darstellung einer Zeilenmarkierung bestimmen

Bevor Sie die Darstellung der Zeilenmarkierungen ändern sollten Sie wissen, dass die Notation der Farben in HTML-Syntax erfolgt, also Hexadezimal codiert (eine Folge aus Buchstaben und Zahlen). Damit kann jede Farbnuance genau ermittelt werden. Im Dialog für die Darstellung der Zeilenmarkierung werden die Farben auch über diese HTML-Syntax angezeigt.
Wichtig zu wissen ist zudem, das der Dialog auch eine Vorschau bietet, womit die farbliche Gestaltung der Zeilenmarkierung überprüft werden kann. Die Vorschau wird im entsprechenden Kästchen unter der Überschrift "Hintergrund" angezeigt. Hier wird die gewählte Schriftfarbe auf der Hintergrundfarbe dargestellt.

Um die Darstellung der Zeilenmarkierungen zu gestalten wählen Sie im Listeneinstellungsdialog die Auswahl "Allgemeine und Farb-Einstellungen" und klicken dort auf den Reiter "Farben".

  • Die Bezeichnungen der Zeilenmarkierungen sind schon vorgegeben (z.B. "Zeile Highlight", "Zeile Blau" usw.). Unter dieser Bezeichnung finden Sie die entsprechende Markierung in der Drop-Down-Liste im Dialog für die Erstellung einer Zeilenmarkierung (siehe "Das Erstellen einer Zeilenmarkierung"). Auch die Farbe der Filterbar, sowie die verschiedenen Zeilenfarben können Sie hier selbst gestalten.
  • Um die Schriftfarbe zu ändern klicken Sie zweimal mit der linken Maustaste in das Eingabefeld unterhalb der Überschrift "Schriftfarbe". Nun öffnet sich ein Dialog. Dort wählen Sie Ihre Schriftfarbe durch Klick auf eines der Kästchen mit den Grundfarben, oder auf eine der Farben in dem Farbauswahlkasten.
  • Um die Hintergrundfarbe zu ändern klicken Sie zweimal mit der linken Maustaste in das Eingabefeld unterhalb der Überschrift "Hintergrund". Nun öffnet sich ein Dialog. Dort wählen Sie Ihre Hintergrundfarbe durch Klick auf eines der Kästchen mit den Grundfarben, oder auf eine der Farben in dem Farbauswahlkasten.


ezBank 2.5.5 - Spaltendefinitionen

Spaltendefinitionen

Alle Listen in ezBank bieten Ihnen die Möglichkeit selbst zu bestimmen welche Inhalte diese haben sollen, also welche Daten in den Spalten angezeigt werden sollen.
Neben der inhaltlichen Gestaltung der Listen können Sie auch die optische Gestaltung der Spalten selbst bestimmen. Damit haben Sie ein wertvolles Arbeitsmittel, welches Sie bei der Organisation Ihrer Daten unterstützt.
Die Spaltendefinitionen erreichen Sie im Listeneinstellungsdialog mit der Auswahl "Dialog für Spaltendefinitionen". Hier definieren Sie sowohl die inhaltliche wie auch die optische Gestaltung der Liste.

Spalten hinzufügen und löschen

  1. Öffnen Sie den "Dialog für Spaltendefinitionen".
  2. Wählen Sie nun in der leeren Zeile unter "Feldname" das Feld aus, dass Sie als Spalte in der Liste angezeigt haben möchten. Möchten Sie beispielsweise zu allen Adressen die E-Mail angezeigt bekommen, wählen Sie aus der Liste mit den verfügbaren Feldern das Feld "EMAIL".
  3. Wenn Sie nun das Eingabefeld für den Feldnamen wieder verlassen, werden die Felder unter "Titel", "Typ" und "Breite" automatisch ausgefüllt. Wenn Sie es wünschen, ändern Sie diese vorgeschlagenen Einstellungen.
  4. Möchten Sie eine Spalte löschen, so klicken Sie in das entsprechende Feld unter "Feldname", so dass das Feld blau markiert ist. Dann betätigen Sie die "Entf"-Taste.
  5. Um den Dialog für Spaltendefinitionen zu verlassen und um alle Eingaben abzuspeichern, klicken Sie auf die Schaltfläche OK.

Die optische Gestaltung der Spalten

ezBank liefert einige Gestaltungsmöglichkeiten für Spalten mit. Beispielsweise werden in der Personenliste die Zelle mit dem Inhalt Land-PLZ blau eingefärbt, wenn es sich um eine ausländische PLZ handelt. Ein weiteres Beispiel ist, dass Sie durch die Spaltengestaltung alle Personen markieren können, die in diesem Monat Geburtstag haben.

  1. Öffnen Sie den "Dialog für Spaltendefinitionen".
  2. Um eine Spalte zu gestalten, sind die Felder unter "Farbe" und "wenn gleich", für Sie interessant.
  3. Im Feld unter "Farbe" können Sie eine Zelle bzw. den Zelleninhalt einfärben. Dabei bedeutet z.B. "Blau", dass der Zelleninhalt blau eingefärbt wird. "ZelleBlau" bedeutet, dass die Zelle selbst blau eingefärbt wird und "Fett" bedeutet, dass der Zelleninhalt fett dargestellt wird.
  4. Im Feld unter "wenn gleich" wird die Bedingung festgelegt, bei der die Spalte wie angegeben gestaltet wird.
Folgende Bedingungen stehen dabei speziell bei Datumsfeldern zur Verfügung:
Bedingung | Bedeutung | Beispiel (Annahme: heute ist der 15.07.2025)
Heute | Das aktuelle Datum. | Es werden alle Zellen markiert, die im entsprechenden Datumsfeld genau den heutigen Tag haben.
TagMonat | Der aktuelle Tag und der aktuelle Monat, ohne Rücksicht auf das Jahr. | Es werden alle Zellen markiert, die im entsprechenden Datumsfeld den 15ten Juli haben, egal in welchem Jahr. Verwendung z.B. für Geburtstage heute.
MonatJahr | Der aktuelle Monat und das aktuelle Jahr, ohne Rücksicht auf den Tag. | Es werden alle Zellen markiert, die im entsprechenden Datumsfeld den Juli 2025 haben, egal welcher Tag. Verwendung zum Markieren des aktuellen Monats.
Tag | Der aktuelle Tag, ohne Rücksicht auf Monat und Jahr. | Es werden alle Zellen markiert, die im entsprechenden Datumsfeld den 15ten haben. Wozu das gut sein soll weiss ich nicht, aber der Vollständigkeit halber... :-)
Monat | Der aktuelle Monat, ohne Rücksicht auf Tag und Jahr. | Es werden alle Zellen markiert, die im entsprechenden Datumsfeld den Juli haben. Verwendung z.B. für Geburtstage in diesem Monat.
Jahr | Das aktuelle Jahr, ohne Rücksicht auf Tag und Monat. | Es werden alle Zellen markiert, die im entsprechenden Datumsfeld das Jahr 2025 haben. Verwendung zum Markieren des aktuellen Jahres.
Weitere Bedingungen zur Auswahl:
Bedingung | Bedeutung
Ja bzw. Nein | Macht nur Sinn bei Ja/Nein Feldern. Wählen Sie beispielsweise den Wert "Ja" zum entsprechenden Ja/Nein Feld, so sind alle Zellen markiert, die dieses Feld angehakt haben.
(immer) | Damit werden immer alle Zellen, also die komplette Spalte, in der entsprechenden Farbe eingefärbt.
Sie können auch selbst eine Bedingung eingeben. Folgende Operatoren stehen Ihnen dabei zur Verfügung:
Operator | Bedeutung
* | Ein beliebiges Zeichen gefolgt von einem "*" markiert die Zellen, die dieses Zeichen nicht oder mehrmals enthalten. Beispiel: mit "ab*c" wird "ac", "abc" oder auch "abbcxy" markiert.
+ | Ein beliebiges Zeichen gefolgt von einem "+" markiert die Zellen, die dieses Zeichen mindestens einmal enthalten. Beispiel: mit "ab+c" wird "abc" oder auch "abbcxy" markiert, nicht aber "ac".
^ | Ein "^" am Anfang eines Begriffs markiert die Zellen, die mit dem eingegebenen Begriff anfangen. Beispiel: mit "^abc" wird "abc" oder "abcxy" markiert, nicht aber "a", "ab" oder "xabc".
# | Ein "#" vor einem beliebigen Zeichen markiert die Zellen, die nicht mit dem eingegebenen Zeichen anfangen. Beispiel: mit "#a" wird "bc" oder "xabc" markiert, nicht aber "a" oder "abc".
$ | Ein "$" am Ende eines Begriffs markiert die Zellen, die mit dem eingegebenen Begriff enden. Beispiel: mit "abc$" wird "abc" oder "xabc" markiert, nicht aber "abcx".
[] | Eine Liste von Zeichen. Markiert die Zellen, die eines der in der Liste enthaltenen Zeichen enthalten. Beispiel: mit "[ax]" wird "abc", "bcx" oder "abcxyz" markiert, nicht aber "bcyz".


ezBank 2.5.5 - Einstellungen exportieren

Einstellungen exportieren

Listeneinstellungen Mit einem rechten Mausklick auf die kleine Schaltfläche unten rechts in jeder Liste erscheint ein kleines Auswahlfenster mit diesen drei Möglichkeiten:

Listeneinstellungen

Damit können sämtliche Einstellungen einer Liste in eine Datei exportiert werden, um die Einstellungen z.B. auf einen anderen Rechner zu übertragen und dort wieder zu importieren.
Außerdem können Sie mit einem Klick die mitgelieferten Standard-Listeneinstellungen wiederherstellen.

Hinweis: Das betrifft vor allem die Spaltendefinitionen, die in jedem Fall für jede Liste individuell sind! Die Darstellung der Liste sowie die Farbeinstellungen können bei den Einstellungen Listeneinstellungen vorgenommen werden und gelten dann für alle Listen gleich.


ezBank 2.5.5 - Optionen

Optionen

In ezBank haben Sie die Möglichkeit, verschiedenste Programmeinstellungen (Optionen) vorzunehmen, welche hier näher erläutert werden.

::: Einstellungen zur Darstellung :::

::: Farbeinstellungen :::

::: Listeneinstellungen :::

::: Standardwerte und Vorgaben :::

::: Einstellung zur Korrespondenzfunktion :::

::: Telefonie und E-Mail :::

::: Ordner-Definitionen :::

::: Einstellung zum Datenbank-Zugriff :::


ezBank 2.5.5 - Einstellungen zur Darstellung

Einstellungen zur Darstellung

Optionen - Reiter 'Allgemein'

Allgemeine Optionen zur Darstellung

Startfenster
Hier können Sie einstellen, welches Fenster beim Starten von ezBank gleich geöffnet werden soll. Dabei stehen unter anderem folgende Möglichkeiten zur Auswahl:

  • Startmenü: startet mit dem Hauptfenster mit Startmenü OHNE irgend eine Liste
  • Zahlungsaufträge: öffnet beim Starten sofort die Liste mit den Zahlungsaufträgen
  • Gegenkonten: öffnet beim Starten sofort den Gegenkontenliste
  • Kontenliste: öffnet beim Starten sofort die Kontenliste
  • Hauptfenster: entspricht 'Startmenü': startet das Hauptfenster nur mit dem Startmenü

Formulargröße
Hier können Sie die Größe der Fenster (Dialoge und Listen) festlegen. Das ist besonders hilfreich, wenn Sie einen Bildschirm mit sehr hoher Auflösung verwenden, und Ihnen die Schrift in ezBank deshalb sehr klein vorkommt. Erhöhen Sie dann einfach die Formulargröße, bis es Ihnen angenehm ist.

Schriftart und Schriftgröße
Hier kann bei Bedarf eine andere Schriftart und Schriftgröße eingestellt werden. Beispielsweise dann, wenn die verwendete Schriftgröße zu der eingestellten Formulargröße nicht passt. Als Standard voreingestellt ist die Schriftart 'MS Sans Serif' und Schriftgröße '8,25'.

Fensterpositionierung

Der Windows-Standard sieht vor, dass neue Fenster immer etwas verschoben überlappend geöffnet werden. Das hat den Vorteil, dass die Fenster sich gegenseitig möglichst wenig verdecken. Nachteil: Man weiß nie, wo sich ein Fenster öffnen wird. Deshalb gibt es in ezBank weitere alternative Einstellungsmöglichkeiten:

  • alle Fenster immer zentriert positionieren. Nachteil: Fenster können sich gegenseitig verdecken. Trotzdem die empfohlene Einstellung.
  • die Position jedes Fensters merken. Jedes Fenster wird so geöffnet, wie es zuvor geschlossen wurde.
  • alle Fenster immer maximiert anzeigen. Jedes Fenster wird maximiert angezeigt, also über den ganzen Desktop gelegt.
  • nach Windows-Standard überlappend

Fensterdarstellung

  • Listen in modernem flachen Stil
    Hier können Sie das Erscheinungsbild der Listen einstellen (klassisch dreidimensional oder flach). Vorgegeben und empfohlen ist überall das modernere flache Design.
  • Listen immer maximiert anzeigen
    Damit Listen möglichst viele Datensätze anzeigen können, gibt es hier die Möglichkeit (das wird auch empfohlen), Listen immer maximiert anzuzeigen. Wenn dies nicht markiert wird, dann merkt sich ezBank die Position und Größe jeder Liste und öffnet jede Liste so, wie sie zuvor geschlossen wurde.
  • Listen mit Rahmen anzeigen
    Listen werden mit einem Rahmen angezeigt, der hier aber auch ausgeblendet werden kann. Vorgegeben und empfohlen ist die Darstellung mit Rahmen.
  • die Filterbar immer gleich einblenden
    Das betrifft nur die Listen. Diese haben eine Filterbar zum Filtern der Liste, die bei Bedarf eingeblendet werden kann. Soll diese Filterbar beim Öffnen der Liste sofort eingeblendet sein kann dies hier so eingestellt werden.
  • Reiter in modernem flachen Stil
    Viele Dialoge in ezBank bestehen aus sogenannten Reitern, hinter denen sich weitere Eingabemöglichkeiten oder Listen verstecken (so auch dieser Optionen-Dialog). Hier können Sie das Erscheinungsbild dieser Reiter einstellen (klassisch dreidimensional oder flach).
  • Reitermarkierung
    Bei Reitern, hinter denen sich wiederum Dateneingaben in Listenform verbergen (z.B. Termine oder Dokumente), kann durch eine Markierung kenntlich gemacht werden, ob Daten vorhanden sind oder nicht. Für diese Markierung sind hier Einstellungsmöglichkeiten mit verschiedenen Farben vorhanden.

Logdatei

Logdatei zu jedem Programmstart
Bei jedem Programmstart wird eine Logdatei geschrieben, die dann normalerweise beim nächsten Start wieder überschrieben wird. Es wird also immer nur der jeweils aktuelle Programmverlauf protokolliert. Aktivieren Sie diese Einstellung, dann wird für jeden Programmstart eine eigene Logdatei geschrieben, die dann gespeichert wird. Sie haben dann also für jeden Programmverlauf eine Logdatei (Protokoll), die auch später noch angeschaut werden kann.

Konfigurationsdatei zur Speicherung der Einstellungen

Die Einstellungen können optional nicht mehr in der Registry, sondern in einer wählbaren Konfigurationsdatei gespeichert werden.
Vorteile:

  1. diese Datei kann kopiert werden, also können Einstellungen bei Rechnerwechsel mitgenommen werden.
  2. die Konfigurationsdatei lässt sich je Kartei wählen, also gehen dann auch unterschiedliche Einstellungen je Kartei.
  3. die Konfigurationsdatei kann auch auf dem Server liegen, so dass alle Arbeitsplätze dieselben Einstellungen verwenden können.
Hier wird nun festgelegt, welche Konfigurationsdatei hier verwendet werden soll.


ezBank 2.5.5 - Farbeinstellungen

Farbeinstellungen

Hier können Sie einige Farben - Hintergrund-Farbverläufe - für diverse Fenster und Dialoge festlegen. Dabei können Sie für das Startmenü, für Listen, Reiterdialoge und andere Dialoge jeweils unterschiedliche Farbverläufe definieren.

Optionen - Reiter 'Farben'

Desktop-Hintergrund
Die hier eingestellte Farbe wird als Hintergrundfarbe der ganzen Anwendung verwendet, wenn bei der aktuell gewählten Kartei keine eigene Hintergrundfarbe definiert ist.

Farbiges Startmenü
Ist diese Einstellung aktiviert, dann können Sie einen Farbverlauf für das Startmenü definieren. Deaktiviert wird das Startmenü in beige angezeigt. Eine Vorschau zum Ergebnis wird hier im ersten der vier Kästen unten angezeigt.

Farbverläufe andere Fenster
Ist diese Einstellung aktiviert, dann können Sie jeweils einen Farbverlauf für Listen, Reiterdialoge und andere Dialoge definieren. Deaktiviert werden alle Fenster in derselben Farbe angezeigt. Eine Vorschau zum Ergebnis wird hier ab dem zweiten der vier Kästen unten angezeigt.

Listen-Hintergrund
Diese Farbe wird als Hintergrundfarbe einer Liste verwendet, wie beispielsweise der Gegenkontenliste. Eine Vorschau zum Ergebnis wird unten im zweiten Kasten "Listen" in der dargestellten Liste angezeigt.

Rahmen-Hintergrund und Rahmen-Beschriftung
Mit diesen beiden Einstellungen bestimmen Sie die Farben - Beschriftung und Hintergrund - der in Eingabefenstern verwendeten Rahmen zur Gruppierung von Daten. Eine Vorschau zum Ergebnis wird unten in den beiden Kästen "Reiter-Dialoge" und "andere Dialoge" mit den dort enthaltenen Rahmen angezeigt.
Da es sich bei diesem Dialog ebenfalls um einen Reiter-Dialog handelt, wird das Ergebnis hier ebenfalls sofort angezeigt.

Reiter-Dialoge
Die Hintergundfarbe der Reiter können ebenfalls eingefärbt werden oder - wie bisher - ungefärbt bleiben. Die Empfehlung ist die Einfärbung entsprechend des Reiter-Dialogs selbst.
Folgende Einstellungen gibt es:

  • ungefärbt: das entspricht der Tab-Farbe selbst, also grau
  • wie Reiter: das entspricht der Farbe der Reiter-Dialoge
  • wie Rahmen: das entspricht der Farbe des Rahmen-Hintergrunds
  • individuell: mit Doppelklick in diesem Feld kann eine beliebige Farbe gewählt werden
Die Vorschau des Ergebnisses wird hier im Kasten "Reiter-Dialoge" angezeigt.

Farbvorschläge

  • blau: alle Fenster in einem hellen Blau mit dezentem Farbverlauf.
  • grün: alle Fenster in einem hellen Grün mit dezentem Farbverlauf.
  • rot: alle Fenster in einem hellen Rot mit dezentem Farbverlauf.
  • orange: alle Fenster in einem hellen Orange mit dezentem Farbverlauf.
  • pink: alle Fenster in einem hellen Pink mit dezentem Farbverlauf.
  • violett: alle Fenster in einem hellen Violett mit dezentem Farbverlauf.
  • win.blau: alle Fenster in einem Blauton, entspricht dem Windows-Farbschema "Blau".
  • win.oliv: alle Fenster in einem Olivton, entspricht dem Windows-Farbschema "Olivgrün".
  • win.silber: alle Fenster in Silber (hellgrau), entspricht dem Windows-Farbschema "Silber".
  • schwarz: alle Fenster in einem Schwarzton mit Farbverlauf von Grau nach Schwarz.
  • ezSoftw.: alle Fenster mit einem Farbverlauf in ezSoftware-Firmenfarbe.
  • bunt: alle Fenster mit individuellem Farbverlauf, sehr bunt.
  • beige/dezent/hell: alle Fenster in Beige (Windows98-Standard).
  • grau/dezent/hell: alle Fenster in Grau (WindowsXP-Standard).
Hinweis: Mit einem rechten Mausklick auf blau oder win.blau kann ein alternativer Farbvorschlag gewählt werden.

Für individuelle Farbeinstellungen gilt, dass mit einem Doppelklick im entsprechenden Eingabefeld oben oder unten der Standard-Dialog von Windows zur Farbauswahl erscheint, damit Sie die Farbe einfacher wählen können. Die Notation der Farbe erfolgt in HTML-Syntax, also Hexadezimal codiert. Der Farbverlauf der gewählten Farben wird sofort im entsprechenden Kasten dargestellt, womit Sie eine Vorschau auf das Ergebnis haben.


ezBank 2.5.5 - Listeneinstellungen

Listeneinstellungen

Hier werden die allgemein gültigen Listeneinstellungen sowie Farbdefinitionen vorgenommen, die für jede Liste gelten, bei der keine eigenen abweichenden Listeneinstellungen festgelegt wurden.

Optionen - Reiter 'Listen'

Listeneinstellungen

Darstellung
Hier können Sie die optische Erscheinung der Liste bestimmen, im Wesentlichen die Höhe der Zeilen sowie die Einfärbung der Zeilen und Zellen.
Außerdem bestimmen Sie hier, ob Zeilen- oder Spaltenlinien angezeigt werden sollen sowie das Aussehen der Markierung der aktiven Zeile.

Zellentooltips
Hier können Sie Zellentooltips ein- und ausschalten und deren Ansicht gestalten. Zellentooltips sind an den Mauszeiger gebunden. Sobald der Mauszeiger auf einem Feld in der Tabelle verweilt, wird durch den Zellentooltip der Inhalt des Feldes angezeigt. Dies ist vor allem dann praktisch, wenn Sie den Feldinhalt nicht vollständig lesen können und dazu die entsprechende Spalte nicht größer ziehen möchten.

Mehrfachauswahl
Die Mehrfachauswahl erlaubt das gleichzeitige Markieren mehrerer Datensätze der Liste, beispielsweise um mehrere Datensätze auf einmal zu löschen oder für Massenupdates. Wenn Sie diese Funktion ausschalten, verhindern Sie, dass in einer Liste mehrere Datensätze markiert werden können.

Scroll-Automatik
Die Scroll-Automatik bewirkt, dass beim Scrollen der Liste immer die aktuellen Datensätze angezeigt werden. Die Liste "läuft" sozusagen beim Runterziehen des Scrollbalkens bzw. beim Betätigen des Scrollrades der Maus mit.

Toolbar
Die Toolbar setzt sich aus maximal 8 Bildchen zusammen, hinter welchen jeweils eine Funktionalität steckt. Alle 8 Icons sind hier in Form von 8 Kontrollkästchen vertreten. Durch Anhaken des jeweiligen Kästchens können Sie bestimmen, welche Bildchen und damit welche Funktionalität Sie unterhalb der entsprechenden Liste angezeigt haben möchten. Standardmäßig setzt sich die Toolbar aus den Bildchen "alles Markieren", "Filterbar", "Filter entfernen", "Druckliste", "Standardbericht" und "Spaltenbreiten" zusammen. Eine detaillierte Beschreibung der einzelnen Funktionalitäten mit dem passenden Bildchen finden sie unter Die Toolbar.

Zeilenfarben

Filterbar
Hier legen Sie für die Filterbar - das ist die oberste Zeile einer Liste, wenn nicht ausgeblendet - die Schrift- und Hintergrundfarbe fest sowie den Hintergrund der gerade aktiven Zelle.

Zeilenfarben 1. und 2. Zeile
Hier legen Sie für die Zeilen einer Liste die Schrift- und Hintergrundfarbe fest. Empfohlen und vorgegeben ist, die Liste mit sich abwechselnden Zeilenfarben zu gestalten. Deshalb können hier unterschiedliche Farben für die 1. udn 2. Zeile angegeben werden.

markierte Zeilen
Mit dieser Farbdefinition wird die gerade aktive markierte Zeile farblich hervorgehoben und damit besser sichtbar gemacht. Auch wenn Sie mehrere Zeilen markieren werden diese in dieser Farbe abgezeigt.

Zeile Highlight ... Zeile "Merker"
Diese 7 Farbdefinitionen haben zusätzlich zu Schrift- und Hintergrundfarbe noch die beiden Attribute "Fett" und "Kursiv", die jeweils bestimmt werden können.
Verwendet werden können diese Farbdefinitionen dann bei den einzelnen Listen mit den Zeilenmarkierungen. Dabei können Sie für bestimmte Bedingungen eine besondere Farbe festlegen, damit die Zeilen, auf die diese Bedingung zutrifft, farblich entsprechend gekennzeichnet werdeb.


ezBank 2.5.5 - Standardwerte und Vorgaben

Standardwerte und Vorgaben

Optionen - Reiter 'Vorgaben'

Ländereinstellungen
Landeskennzeichen
Geben Sie hier das Kennzeichen Ihres Landes ein, z.B. 'DE' für Deutschland, 'AT' für Österreich, 'CH' für die Schweiz oder etwas beliebig anderes. Dieser Wert wird als Vorgabe beim Anlegen einer neuen Adresse verwendet. Zur Auswahl angezeigt werden alle in der Länderliste aktivierten, also nicht zur Auswahl ausgeblendeten Länder.

Konfession, Nationalität und Sprache
Ähnlich wie beim Landeskennzeichen können Sie hier festlegen, ob und welche Standardwerte für Konfession, Nationalität und Sprache beim Anlegen einer neuen Adresse angewendet werden sollen.

Standardwährung
Geben Sie hier die Standardwährung ein, mit der in ezBank gearbeitet werden soll. Das hat vor allem Auswirkungen auf die Währung, die bei den Summenberechnungen zuerst angezeigt wird. Zur Auswahl angezeigt werden alle Währungen der in der Länderliste aktivierten, also nicht zur Auswahl ausgeblendeten Länder.

USt.Satz in % (VAT)
Hier kann der aktuell gültige Mehrwertsteuersatz eingetragen, die möglicherweise an verschiedenen Stellen in ezBank als Vorgabe verwendet wird.

Verschiedenes
Namen automatisch formatieren
Wenn diese Einstellung aktiviert ist, dann wird bei Eingabe des Namens, Vornamens, Strasse und Ort der erste Buchstabe automatisch in Großbuchstaben umgesetzt. Somit können Sie immer in Kleinbuchstaben eingeben, was die Eingabe beschleunigen kann.

BLZ automatisch formatieren
Wenn diese Einstellung aktiviert ist, dann wird bei Eingabe einer Bankleitzahl diese automatisch in das deutsche Format (123 123 12) umgesetzt. Diese Einstellung sollte natürlich für Österreich oder Schweiz deaktiviert werden.

IBAN automatisch formatieren
Ähnlich wie bei der BLZ kann mit dieser Einstellung eingestellt werden, dass bei Eingabe einer IBAN diese automatisch in das Format (DE 1234 1234 1234 1234 12) umgesetzt wird.

Komfortauswahl bei mehreren Konten
Ist diese Einstellung NICHT aktiviert, dann werden weitere Konten einer Adresse nur über die 'weitere Konten'-Schaltfläche in der Adresse angezeigt. Ansonsten - bei aktivierter Einstellung - können die verschiedenen Konten zu einer Adresse direkt in der Adresse komfortabel über eine Auswahlliste gewählt werden.

Vorgaben für neue Dokumente
Hier können Sie festlegen, welcher Dokumentnamen und Betreff für neue Dokumente der verschiedenen Kategorien vorgegeben werden soll. Dabei stehen als Variablen zur Verfügung: [Suchbegriff], [Name], [Vorname], [Bearbeiter], [Zeitstempel] und [Datum]

  • [Zeitstempel]: das aktuelle Datum und Uhrzeit im Format "JJJJMMTT ssmm", also "JahrMonatTag StundeMinute"
  • [Datum]: das aktuelle Datum im Format "JJJJ-MM-TT", also "Jahr-Monat-Tag"

Zum Scannen den einfachen Scanner-Dialog verwenden
Falls bei Ihrem Scanner dieser einfachere Scanner-Dialog besser funktioniert, dann können Sie diesen hier aktivieren. Ansonsten wird der neue erweiterte Scanner-Dialog verwendet.


ezBank 2.5.5 - Einstellung zur Korrespondenzfunktion

Einstellung zur Korrespondenzfunktion

Optionen - Reiter 'Dokumente'

Allgemeine Einstellungen zur Korrespondenzfunktion
Vorlagen über die Windows-Dateiliste wählen
Möchten Sie die Vorlagedateien zum Erstellen eines Briefs, E-Mails oder Berichts direkt über die Windows-Dateiliste wählen, dann aktivieren Sie diese Eigenschaft (nicht empfohlen). Ansonsten erscheint zur Auswahl einer Vorlagedatei eine Liste mit den definierten Vorlagen.

Vorlagen-Automatik abschalten
Wenn Sie einen Brief oder Bericht über die Korrespondenz-Funktion erstellen, dann benötigen Sie in der Regel immer eine Vorlagedatei. Deshalb öffnet sich beim Klick auf die Korrespondenz-Funktion auch sofort die Auswahlliste mit den Vorlagen bzw. die Dateiliste. Möchten Sie dies nicht, dann können Sie diese Automatik hier abschalten.

Wartezeit in Millisekunden nach Öffnen der Vorlage
Diese Wartezeiten beeinflussen das Verhalten der entsprechenden Anwendung, z.B. Word. In diesem Fall, wie lange nach Öffnen der gewählten Vorlage gewartet wird, bis die Anwendung in der Bearbeitung weiter macht, also das Dokument erstellt.
Die Standardeinstellung ist 100 Millisekunden. Bei Problemen nach Öffnen einer Vorlage kann versucht werden, diese Zeit hier etwas zu verlängern.

Bei Direktdruck vorher die Auswahl eines Druckers erlauben
Damit kann vor dem Drucken ein installierter Drucker gewählt werden. Ansonsten wird ohne Auswahlmöglichkeit eines Druckers sofort auf den in Windows festgelegten Standarddrucker ausgedruckt.
Die Standardeinstellung ist, dass ein Drucker ausgewählt werden kann. Das sollte abgeschaltet werden, falls es damit zu Problemen kommt.

Wartezeit in Millisekunden nach dem Druckbefehl
Diese Wartezeiten beeinflussen das Verhalten der entsprechenden Anwendung, z.B. Word. In diesem Fall, wie lange nach Drucken des fertigen Dokuments gewartet wird, bis die Anwendung in der Bearbeitung weiter macht, also die Anwendung beendet.
Die Standardeinstellung ist 3000 Millisekunden, also 3 Sekunden. Bei Problemen beim Drucken des Dokuments kann versucht werden, diese Zeit hier etwas zu verlängern.

Korrespondenz-Einstellungen zu Word
Als Standard .rtf verwenden
Diese Eigenschaft bezieht sich auf die Korrespondenz-Funktion. Normalerweise wird beim Schreiben von Briefen ein installiertes OpenOffice oder Word vorausgesetzt und verwendet. Haben Sie beides nicht, dann empfiehlt sich die Verwendung von RTF-Dokumenten, welche auch mit vielen anderen Textverarbeitungen bearbeitet werden kann.

MS Word bereits während der Dokumenterstellung sichtbar machen
Damit kann eingestellt werden, dass Word bereits sichtbar geöffnet wird, während die gewählte Vorlage bearbeitet und daraus das Dokument erstellt wird.
Die Standardeinstellung ist, dass Word unsichtbar ist, während die Bearbeitung erfolgt. Das kann eingeschaltet werden, falls es mit der Bearbeitung im Hintergrund zu Problemen kommt.

Wartezeit in Millisekunden vor Öffnen der Wordvorlage
Diese Wartezeiten beeinflussen das Verhalten von Word. In diesem Fall, wie lange Word nach dem Starten wartet, bevor die gewählte Vorlage geöffnet wird.
Die Standardeinstellung ist 100 Millisekunden. Bei Problemen nach Starten von Word und vor Öffnen der Vorlage kann versucht werden, diese Zeit hier etwas zu verlängern.

Das erstellte Worddokument automatisch speichern
Hier wird festgelegt, dass ein erstelltes Worddokument automatisch gespeichert wird, das ist auch unbedingt zu empfehlen und die Standardeinstellung.
Nur wenn es damit Probleme gibt kann diese Einstellung abgeschaltet werden, so dass das erstellte Dokument in Word geöffnet bleibt und nicht sofort automatisch gespeichert ist.

Wartezeit in Millisekunden vor dem Speicherbefehl
Diese Wartezeiten beeinflussen das Verhalten von Word. In diesem Fall, wie lange Word nach dem Erstellen des Dokuments wartet, bevor das Dokument gespeichert wird.
Die Standardeinstellung ist 100 Millisekunden. Bei Problemen beim automatischen Speichern des fertigen Dokuments kann versucht werden, diese Zeit hier etwas zu verlängern.

Wartezeit in Millisekunden vor Beenden von Word
Diese Wartezeiten beeinflussen das Verhalten von Word. In diesem Fall, wie lange Word nach Fertigstellung wartet, bevor Word wieder geschlossen, also beendet wird.
Die Standardeinstellung ist 100 Millisekunden. Bei Problemen am Ende der Bearbveitung und beim Beenden von Word kann versucht werden, diese Zeit hier etwas zu verlängern.

Formatumwandlung
Wenn MS Word installiert ist wird vorzugsweise auch MS Word zur Umwandlung eines Word-Dokuments in ein anderes Format wie PDF und anderes verwendet. Ein großer Vorteil hierbei ist, dass damit auch Umwandlungen in ein anderes Word-Format (doc, docx, dot, dotx) möglich sind wie auch Umwandlungen ind RTF-Format oder als Web-Datei (HTML-Format).
Möchten Sie dennoch lieber den CIB pdf brewer verwenden zur Formatumwandlung eines Word-Dokuments in ein PDF können Sie das hier auswählen und CIB aktivieren.

Standardmotiv für Briefpapier
Hier können Sie ein Motiv festlegen, welches dann bei allen Briefvorlagen mit einer definierten Grafik für den Briefkopf (Positionsrahmen mit Textmarke "Briefpapiermotiv") verwendet wird.
ezBank liefert bereits einige Motive (Grafiken) mit, die frei verwendet werden können. Außerdem natürlich auch Beispielvorlagen, die dieses Briefpapiermotiv verwendet.
Die Arbeit mit Wordvorlagen und Textmarken ist in der Lektion Ändern einer Dokument-Vorlage beschrieben.

So geht das:

  1. Öffnen Sie in Word eine Vorlage zum Bearbeiten, die nun ein Briefpapiermotiv enthalten soll.
  2. Fügen Sie einen Positionsrahmen ein (kein Textfeld) und platzieren es an die Stelle, an die das Briefpapiermotiv hin soll.
  3. Markieren Sie den Positionsrahmen und fügen dazu eine Textmarke "Briefpapiermotiv" hinzu.
  4. Beim Verwenden dieser Word-Vorlage wird nun an die Stelle des Positionsrahmens die gewählte Grafik des Briefpapiermotivs eingefügt.


ezBank 2.5.5 - Telefonie und E-Mail

Telefonie und E-Mail

Optionen - Reiter 'Kommunikation'

Telefonie-Einstellungen
Hier können Sie zum einen festlegen, was mit dem Klick auf das Pfeil-Symbol neben der Telefonnummer geschehen soll:

  1. Anwahl über CTI-Verbindung: damit wird die Telefonnummer über eine Schnittstelle (z.B. TAPI oder VoIP über ein SIP-Softphone) an das Telefon übergeben, so dass direkt von ezBank aus gewählt werden kann.
    Zudem kann hier eine Vorwahl zur Amtholung angegeben werden, wie sie z.B. für Telefonanlagen benötigt wird, um überhaupt ein Freizeichen zu erhalten.
Außerdem können Sie hier den Anrufmonitor abschalten, wenn das nicht gewünscht ist oder falls deshalb Probleme mit Ihrer Telefonanlage auftreten sollten. Der Anrufmonitor überwacht per ISDN oder TAPI hereinkommende Anrufe und zeigt diese in der Statuszeile oder in der Anruferliste an. Voraussetzung dazu ist deshalb, dass der Rechner am ISDN angeschlossen ist, z.B. mit einer ISDN-Karte, oder ein TAPI-fähiges Telefon am Rechner angeschlossen ist.
Haben Sie den Anrufmonitor aktiviert, dann können Sie zudem wählen, ob bei einem hereinkommenden Anruf dieser in der Anruferliste eingetragen werden soll und ob automatisch der betreffende Anrufer gesucht werden soll, sofern er in ezBank eingetragen ist. Dazu dann noch, ob eine gefundene Adresse gleich angezeigt werden soll.

Komfortauswahl bei mehreren Rufnummern
Ist diese Einstellung NICHT aktiviert, dann werden weitere Rufnummern einer Adresse nur über die 'weitere Rufnummern'-Schaltfläche in der Adresse angezeigt. Ansonsten - bei aktivierter Einstellung - können die verschiedenen Rufnummern zu einer Adresse direkt in der Adresse komfortabel über eine Auswahlliste gewählt werden.

E-Mail-Einstellungen
Hier definieren Sie, mit welcher Anwendung eine E-Mail verschickt werden soll:

  • über die interne Korrespondenz-Funktion (voreingestellt und empfohlen).
  • über Standard-MAPI - das E-Mail-Programm, welches bei Ihnen als Standard-MAPI-Programm definiert ist. Wenn nichts anderes angegeben wurde, dann ist dies Outlook Express.
  • über den internen E-Mail-Dialog - das ist ein alternativer E-Mail-Dialog, anders als die Korrespondenz-Funktion ausschließlich zum Versenden von E-Mails.
  • über mailto: - hier wird das Programm gestartet wie aus einer Internet-Seite mit einem Klick auf eine E-Mail-Adresse.
Komfortauswahl bei mehreren E-Mail-Adressen
Ist diese Einstellung NICHT aktiviert, dann werden weitere E-Mail-Adressen einer Adresse nur über die 'weitere E-Mail-Adressen'-Schaltfläche in der Adresse angezeigt. Ansonsten - bei aktivierter Einstellung - können die verschiedenen E-Mail-Adressen zu einer Adresse direkt in der Adresse komfortabel über eine Auswahlliste gewählt werden.


ezBank 2.5.5 - Ordner-Definitionen

Ordner-Definitionen

Hier sehen Sie alle in ezBank verwendeten Ordner-Definitionen, die hier auch geändert werden können.
Hinweis: Sehr wichtig ist in einer Netzwerkumgebung, dass alle Arbeitsplätze dieselben Einstellungen haben, damit alle auf dieselbe Datenbank, Vorlagen und Dokumente zugreifen.

Optionen - Reiter 'Ordner'

Installationsordner
Hier wird angezeigt, in welchem Ordner das Programm ezBank 2.5.5 installiert ist. Der Standard-Installationsordner ist C:\Program Files (x86)\ezBank
Dieser Ordner lässt sich natürlich hier nicht ändern, dazu muss das Programm neu installiert werden.

Ausführen in
In diesem Ordner wird das Programm ausgeführt. Dieser Ordner enthält dann zur Laufzeit benötigte und erstellte lokale Dateien wie z.B. die Logdateien. Auch die Lizenzdatei kann in diesem Ordner abgelegt werden.

Datenbankordner
Der Datenbankordner enthält die Datenbasis (eine Access-Datenbank 'ezBank.mdb').
Hinweis: Liegt die Lizenzdatei ebenfalls im Datenbankordner, dann ist die Installation der Lizenz auf jedem Arbeitsplatz NICHT nötig, da dann jeder Arbeitsplatz auf die Lizenzdatei sofort zugreifen kann.
Mit Klick auf die "Basisordner"–Schaltfläche wird dieser Ordner für alle folgenden Ordner als Basisordner übernommen.
Beispiel: Ist der Ordner C:\ezBank, dann wird der Ordner für die Vorlagen-Basis C:\ezBank\Vorlagen und der Briefvorlagenordner wird C:\ezBank\Vorlagen\Briefe.

Vorlagen-Basis
Dieses Feld soll vor allem die Eingabe der weiteren Vorlageordner erleichtern. Der Ordner, den Sie hier als Vorlagen-Basis festlegen, wird automatisch für alle Vorlagenordner (Briefe, Excel, E-Mail, PDF, Berichte) als Basisordner übernommen.
Beispiel: Ist die Vorlagen-Basis C:\ezBank\Vorlagen, dann wird der Ordner für die Briefvorlagen C:\ezBank\Vorlagen\Briefe.
Damit haben Sie die Möglichkeit, sämtliche Vorlagen zum Beispiel auf einem Server zentral für mehrere Arbeitsplätze zur Verfügung zu stellen.

weitere Vorlagenordner
Die weiteren Vorlagenordner sind also üblicherweise Unterordner des festgelegten Vorlagen-Basisordners und sollten nicht ohne zwingenden Grund individuell geändert werden. Deshalb werden diese Ordner hier hellgrau angezeigt.
Das betrifft die Ordner Briefvorlagen, Excel-Vorlagen, EMail-Vorlagen, PDF-Vorlagen und Berichtvorlagen.

Dokumente-Basis
Dieses Feld soll vor allem die Eingabe der verschiedenen Dokumenteordner erleichtern. Der Ordner, den Sie hier als Dokumente-Basis festlegen, wird automatisch für alle Dokumenteordner (Dokumente, Scans, Briefe, Excel, E-Mails, PDF, Berichte) übernommen.
Beispiel: Ist die Dokumente-Basis C:\ezBank, dann wird der Dokumenteordner C:\ezBank\Dokumente und der Ordner für die Briefe C:\ezBank\Briefe.
Damit haben Sie auch die Möglichkeit, sämtliche Dokumente auf einem Server-Ordner abzulegen, so dass von jedem Arbeitsplatz aus ein Dokument dort abgelegt und jedes Dokument geöffnet werden kann.
Hinweis: Ist bei einer Adresse ein eigener persönlicher Dokumenteordner definiert (siehe Daten-Basisordner), dann wird bei dieser Adresse der eigene Ordner als Dokumenteordner verwendet.

verschiedene Dokumenteordner
Die weiteren Dokumenteordner sind also üblicherweise Unterordner des festgelegten Dokumente-Basisordners und sollten nicht ohne zwingenden Grund individuell geändert werden. Deshalb werden diese Ordner hier hellgrau angezeigt.
Das betrifft die Ordner Dokumente, Scans, Briefe, Excel-Tabellen, E-Mails, PDF und Berichte.

Daten-Basisordner
Zu jeder Adresse können Sie einen eigenen, persönlichen Dokumenteordner definieren. Um die Auswahl dieser eigenen Dokumenteordner zu erleichtern und zu standardisieren können Sie hier zentral den Basis-Ordner dafür festlegen.
Beispiel: Ist der Daten-Basisordner C:\ezBank\Dokumente, dann wird der persönliche Dokumenteordner für 'Max Muster' C:\ezBank\Dokumente\Muster Max.

Exportordner
Dieser Ordner wird für Exports verwendet. Hier werden also die Dateien mit exportierten Daten gespeichert.

Importordner
Dieser Ordner ist der Standard-Ordner zur Auswahl von Dateien (Access-Datenbank oder Textdatei) zum Importieren. Natürlich kann zum Import dann der Ordner auch gewechselt werden.

Funktionen der Symbol-Schaltflächen

Die Ordnerdefinitionen beinhalten verschiedene Symbol-Schaltflächen, deren Funktionen nachfolgend erläutert werden:
Grundstellung aktuell | Grundstellung aktuell | Damit werden die aktuell gespeicherten Ordner wieder zurückgeholt. Auf diese Weise können neue Eingaben wieder rückgängig machen, sofern diese noch nicht gespeichert wurden.
Grundstellung Standard | Grundstellung Standard | Mit dieser Schaltfläche werden die von ezBank festgelegten Standardwerte für alle Ordner gesetzt.
Ordner wählen | Ordner wählen | Damit kann ein beliebiger Ordner gewählt werden, der dann für diese Ordner-Definition festgelegt wird. Mit rechtem Mausklick wird der aktuell gewählte Ordner im Windows-Explorer geöffnet.
Basisordner | Basisordner | Um die Eingabe der weiteren Ordner zu erleichtern, kann der aktuelle Ordner mit einem Klick für alle nachfolgenden Ordner als sogenannter Basisordner verwendet werden.


ezBank 2.5.5 - Einstellung zum Datenbank-Zugriff

Einstellung zum Datenbank-Zugriff

Optionen - Reiter 'DB-Zugriff'

Zugriffsmethode
Diese Einstellungen sind nur wichtig bei einer Access-Datenbank und im Netzwerk-Betrieb, wenn mehrere Personen gleichzeitig auf die Daten zugreifen. In einem Netzwerk wird nämlich immer der Datensatz, der gerade in Arbeit ist, gesperrt, so dass kein anderer darauf zugreifen kann. Wenn also viele Personen in einem Netzwerk gleichzeitig mit den Daten arbeiten, dann werden unter Umständen schnell so viele Datensätze gesperrt, dass nicht mehr gearbeitet werden kann. Andererseits, wenn nicht gesperrt wird, dann können alle problemlos arbeiten. Haben aber zwei Personen den gleichen Datensatz in Bearbeitung, und einer speichert seine Änderungen zurück, dann werden diese vom zweiten überschrieben, wenn der seine Änderungen speichert.
Mit anderen Worten, Sie haben hier quasi die Entscheidung zu treffen 'Sicherheit' gegen 'Komfort'.

Sicherer Zugriff
Hier werden wie beschrieben die Datensätze sofort beim Zugriff gesperrt, mit der Konsequenz, dass diese dann nicht mehr für andere zugreifbar sind. Für große Netzwerke mit vielen Arbeitsplätzen unter Umständen ein Problem.

Nicht sperren
Hier werden die Datensätze nicht sofort gesperrt, so dass auch bei großen Netzwerken keine gegenseitige Beeinflussung stattfindet und jeder reibungslos arbeiten kann. Allerdings auf Kosten des Risikos, dass bei doppeltem Zugriff nicht gewarnt wird, und Änderungen verloren gehen können, wenn zwei Personen denselben Datensatz gleichzeitig bearbeiten.

Hinweis: Bei einer SQL-Datenbank ist diese Einstellung nicht zu treffen, weil bei einer SQL-Datenbank automatisch mit maximaler Sicherheit und maximalem Komfort auf die einzelnen Datensätze zugegriffen wird.

Daten der Reiter
Voreingestellt ist, dass die Daten sämtlicher Reiter eines Datensatzes sofort beim Öffnen des Datensatzes eingelesen werden. Damit stehen diese sofort bim Anklicken eines Reiters zur Verfügung, und es wird auch sofort beim Öffnen des Datensatzes angezeigt, ob in einem Reiter Daten vorhanden sind oder nicht.
Da das Einlesen sämtlicher Daten aber Zeit benötigt kann hier eingestellt werden, dass die Daten in den Reitern erst beim Anklicken des entsprechenden Reiters eingelesen werden. Also nicht sofort beim Öffnen des Datensatzes.


ezBank 2.5.5 - Die Zusatzfelder

Die Zusatzfelder

Falls Sie weitere Eingabefelder für die Gegenkonten oder Zahlungsaufträge wünschen, bietet Ihnen ezBank 2.5.5 eine komfortable Möglichkeit, bis zu 16 weitere Eingabefelder anzulegen, die dann für jedes Gegenkonto bzw. jeden Zahlungsauftrag zur Verfügung stehen.

Die Eingabefelder

Geben Sie beliebige Feldnamen ein. Das Eingabeformat kann leergelassen werden, dann können beliebige Eingaben in diesem Zusatzfeld getätigt werden. Oder Sie wählen ein bestimmtes Format für die Eingaben, beispielsweise um nur Zahlen zuzulassen. Dabei haben Sie folgende Möglichkeiten:
Text | erlaubt alle Eingaben
Zahl | erlaubt nur Ganzzahlen
Betrag | erlaubt Währungseingaben (Zahlen mit 2 Nachkommastellen und Tausender-Trennpunkten)
Datum | ermöglicht die Eingabe eines Datums
Ja/Nein | ermöglicht eine Auswahl Ja oder Nein über ein Kontrollkästchen (Häkchen)
Liste | ermöglicht die Auswahl vordefinierter Werte aus einer Auswahlliste
Lernliste | ermöglicht die Auswahl vordefinierter Werte aus einer selbstlernenden Auswahllisten
Pflichtfeld | ermöglicht die Definition von Feldern, die zwingend eingegeben werden müssen
Mit der Eingabe eines Semikolons (;) kann nach der Definition des Feldformats noch eine genauere Beschreibung zum Eingabeformat angegeben werden. Folgende Angaben sind dabei möglich:
Angabe der Länge | Text | z.B. Text;10 = 10-stelliges Eingabefeld
 | Zahl | z.B. Zahl;3 = 3-stellige Zahl
 | Betrag | z.B. Betrag;12 = insgesamt 12 Stellen (1.000.000,00)
Angabe eines erklärenden Textes | nur bei Ja/Nein | z.B. Ja/Nein;bitte hier klicken
Angabe des Listennamens | Liste | z.B. Liste;Hobby
 | Lernliste | z.B. Lernliste;Hobby
Angabe als Pflichtfeld | alle Formate | z.B. Betrag;Pflichtfeld oder Datum;Pflichtfeld

Um eine Liste oder Lernliste mit vordefinierten Werten zu füllen öffnen Sie mit der Taste F5 in diesem Eingabeformat-Feld die zu diesem Feld gehörende Referenztabelle. Hier haben Sie dann die Möglichkeit, neue Werte einzugeben oder bereits eingegebene Werte aus der Referenzliste zu ändern oder zu löschen.
Durch die Angabe eines Listennamens haben Sie die Möglichkeit, beliebig viele unterschiedliche Referenzlisten zu definieren und zu pflegen. Damit können Sie unterschiedlichen Zusatzfeldern verschiedene Listen, oder auch mehreren Zusatzfeldern über den gleichen Namen jeweils dieselbe Auswahlliste zuordnen.


ezBank 2.5.5 - Sound-Untermalung

Sound-Untermalung

Die Anwendung ezBank 2.5.5 kann bei verschiedenen Aktionen oder Ereignissen mit einem einstellbaren Sound unterlegt sein.
Dabei sind bereits Sound-Effekte vorbelegt, die aber individuell geändert oder komplett abgeschaltet werden können.

Sound-Einstellungen

Sie können mit einem Klick auf die Schaltfläche Testen den bei der in der Liste markierten Aktion eingestellten Sound abspielen.

Entfernen Sie das Häkchen bei Sound aktivieren sind alle Sound-Effekte in ezBank 2.5.5 komplett abgeschaltet

Mit Klick auf die Schaltfläche Ändern können Sie der markierten Aktion eine andere Sounddatei zuordnen und so den Sound-Effekt dieser Aktion ändern.

Tipp: Haben Sie eine Aktion oder Ereignis entdeckt, die Sie gerne mit einem Sound-Effekt hinterlegt hätten? Melden Sie sich sehr gerne, ich freue mich über solche Anregungen und berücksichtige das gerne in einem nächsten Update.


ezBank 2.5.5 - Fehlermeldungen

Fehlermeldungen

Bei den Fehler- und Warnmeldungen kann eingestellt werden, ob sie überhaupt angezeigt werden sollen oder gar nicht oder nach einer einstellbaren Zeit automatisch wieder geschlossen werden sollen.
Bei Warnungsabfragen kann zudem eine automatische Antwort 'Ja' oder 'Nein' eingestellt werden. Auch diese automatische Antwort kann sofort erfolgen, also ohne Anzeige der Frage, oder nach einer bestimmten Zeit, während der die Frage angezeigt wird.
Zudem kann jede Fehler- und Warnmeldung mit einem einstellbaren Sound ausgestattet werden.

Einstellungen zu den Meldungen

Meldungen

Mit einem Doppelklick in der Liste auf die markierte Meldung oder mit einem Klick auf Details/Ändern wird das Einstellungsfenster zu dieser Meldung geöffnet.

Einstellungen zur Informationsmeldung

Hier können Sie zunächst eine Sounddatei wählen, die bei Anzeige dieser Meldung abgespielt werden soll.
Außerdem wird hier der Typ eingestellt, ob es sich um eine Informationsmeldung oder eine Warnungsmeldung oder sogar eine kritische Warnmeldung handelt.
Mit den beiden Kontrollkästchen können Sie zudem einstellen, ob die Meldung versteckt, also gar nicht angezeigt, oder ob sie nach einer bestimmten Anzahl von Sekunden automatisch geschlossen werden soll. Das entspricht einem automatischen Klick auf OK.

Mit Klick auf die Schaltfläche Vorschau wird die Meldung zur Kontrolle mit den aktuellen Einstellungen angezeigt. Genau so wird die Meldung an entsprechender Stelle in der laufenden Anwendung aussehen.
Hier das Beispiel einer Informationsmeldung nach erfolgreich durchgeführter Datensicherung:

Informationsmeldung

Ist die Meldung als Warnungsmeldung eingestellt wird das mit einem gelben Ausrufezeichen anstelle des blauen "i" deutlich gemacht.
Im Gegensatz zu einer Informationsmeldung bedarf es bei einer Warnungsmeldung in der Regel einer Aktion des Anwenders. Die müssen also noch etwas tun, damit ein gewünschtes Ergebnis erzielt wird.
Hier das Beispiel einer Warnungsmeldung bei noch fehlenden Angaben beim Anlegen eines Datensicherungsauftrags:

Warnungsmeldung

Die dritte Möglichkeit ist eine kritische Warnmeldung, die mit einem roten "X" gekennzeichnet ist.
Bei einer kritischen Warnmeldung kann eine Aktion oder Funktion nicht ausgeführt werden, weil ein Fehler aufgetreten ist, dessen Ursache zuerst behoben werden muss.
Hier das Beispiel einer kritischen Warnmeldung beim Versuch der Anmeldung eines der Anwendung ezBank 2.5.5 unbekannten Benutzers:

Kritische Warnmeldung

Abfragen

Dieselbe Art von Einstellungen gibt es bei den Warnungsabfragen. Auch hier kann eine Sounddatei gewählt und eingestellt werden, ob diese überhaupt angezeigt werden soll oder nicht oder nach einer einstellbaren Zeit automatisch wieder geschlossen werden soll.

Einstellungen zur Warnungsabfrage

Auch hier gibt es drei Typen einer Warnungsabfrage: erstens mit Standardantwort 'Ja' oder zweitens mit Standardantwort 'Nein' oder als kritische Warnungsabfrage, die immer die Standardantwort 'Nein' beinhaltet.
In der Regel wird eine unkritische Abfrage, die eine gewünschte Aktion auslöst, mit der Stadardantwort 'Ja' vorbelegt. Im Gegensatz dazu wird eine kritische oder sogar destruktive Abfrage, wie beispielsweise eine Löschabfrage, vorzugsweise mit 'Nein' vorbelegt.
Ebenfalls wie bei den Meldungen können Sie mit den beiden Kontrollkästchen eine Automatik einstellen. Dazu wählen Sie dann noch die automatische Antwort 'Ja' oder 'Nein', die nach Ablauf der eingestellten Zeit oder eben sofort, erfolgen soll. Das entspricht einem automatischen Klick auf Ja oder Nein.

Hier das Beispiel der Abfrage beim Starten einer Datensicherung, ob diese nun durchgeführt werden soll, eingestellt als kritische Warnungsabfrage mit automatischer Antwort 'Ja' nach 10 Sekunden.

Einstellungen zur Warnungsabfrage

Mit Klick auf die Schaltfläche Vorschau wird die Warnungsabfrage zur Kontrolle mit den aktuellen Einstellungen angezeigt. Genau so wird die Warnungsabfrage an entsprechender Stelle in der laufenden Anwendung aussehen:

Kritische Warnungsabfrage

Wenn die Abfrage ohne Klick auf eine Schaltfläche stehen bleibt wird diese mit der voreingestellten Antwort beendet, hier also mit 'Ja'. Die Datensicherung wird also nach 10 Sekunden automatisch durchgeführt.
Während dieser 10 Sekunden besteht aber auch die Möglichkeit, mit 'Nein' zu antworten. Dann wird die Datensicherung eben doch nicht durchgeführt.
Zudem kann die Automatik mit Klick auf Stop beendet werden. Dann haben Sie wieder Zeit zu überlegen, was Sie tun möchten und entscheiden irgendwann mit 'Ja' oder 'Nein'.


ezBank 2.5.5 - Die Referenzdaten

Die Referenzdaten

Referenzdaten dienen meistens als Vorgaben zu verschiedenen Eingabefeldern, um die Eingabe zu vereinfachen, z.B. Banken und Orte; Anreden, Notizen und anderes.
In manchen Fällen verbirgt sich hinter einem bestimmten Referenz-Datensatz zusätzlich zur reinen Information noch eine bestimmte Funktionalität (Beispiel Anreden).

::: Länderliste :::

::: Bankenverzeichnis :::

::: Ortsverzeichnis :::

::: Anreden :::

::: Sonstige Listen :::


ezBank 2.5.5 - Länderliste

Länderliste

ezBank 2.5.5 liefert bereits eine komplette Länderliste mit. Diese Länderliste wird an drei Stellen verwendet:
  1. Einstellungen - Optionen - Vorgaben - Landeskennzeichen
    Da in ezBank beliebige Landeskennzeichen unterstützt werden, wird bei Neuanlage einer Adresse das bei den Vorgaben definierte Kennzeichen für das Land verwendet. Dort wird als Vorschlag zur Eingabe eine Auswahlliste mit allen Kennzeichen aus der Länderliste angezeigt. (siehe dazu auch Standardwerte und Vorgaben)
  2. Eingabe einer ausländischen Adresse
    Geben Sie eine ausländische Adresse ein, dann können Sie einfach das Landeskennzeichen in der Adresse überschreiben. Alternativ erhalten Sie eine Länder-Auswahlliste zur Auswahl des betreffenden Landes mit Doppelklick auf den Bezeichner 'Land PLZ Ort' vor den Eingabefeldern Land-PLZ Ort.
  3. Korrespondenz-Funktion (neue Anschriften-Regeln der Post)
    Dazu gibt es eine neue Variable (Platzhalter oder Textmarke) 'LANDNAME'. Platzieren Sie diese Variable an der gewünschten Stelle im Adressfeld eines Briefes, dann wird dort der Name des Landes des Briefempfängers eingetragen. Die Besonderheit: der Landname wird nur dann eingetragen, wenn das Land NICHT dem eigenen Land entspricht, also nur bei ausländischen Empfängern.

Land
Geben Sie hier das (genormte) Kennzeichen des Landes ein, z.B. 'DE' für Deutschland, 'AT' für Österreich, 'CH' für die Schweiz oder etwas beliebig anderes. Achtung: Das Landeskennzeichen kann hier nicht mehr geändert werden. Bei einem Fehler muss das eingegebene Land gelöscht und ein neues Land eingegeben werden.

Bezeichnung
Hier geben Sie zum Land die entsprechende Bezeichnung ein, also den Namen des Landes, wie z.B. 'Deutschland', 'Österreich' oder 'Schweiz'.

PLZ Länge
Hier können Sie die Länge der PLZ eines Ortes diesen Landes definieren, also z.B. 5 für Deutschland, 4 für Österreich und Schweiz und 8 für Portugal und England. Damit stehen dann bei Adressen die angegebene Anzahl an Zeichen zur Eingabe der Postleitzahl zur Verfügung.

Währung
Geben Sie hier die Landeswährung des eingegebenen Landes ein. Bei den Optionen zur Eingabe Ihrer Standeswährung stehen alle hier eingegebenen Währungen zur Auswahl zur Verfügung.

zur Auswahl ausblenden
Wenn Sie mit einem bestimmten Land eher keine Korrespondenz haben (oder bisher nie hatten), dann benötigen Sie diese Länder zur Auswahl bei einer Adresseingabe nicht. Dennoch brauchen und sollten Sie diese Länder hier nicht löschen. Sie können nicht benötigte Länder hier einfach ausblenden, dann werden sie in den Landes-Auswahllisten einfach nicht angezeigt.


ezBank 2.5.5 - Bankenverzeichnis

Bankenverzeichnis

ezBank 2.5.5 liefert bereits ein deutsches Bankenverzeichnis mit, welches bei der Eingabe einer BLZ helfen kann, um die korrekte Bank auszuwählen.

Die Bankdaten werden übrigens immer über die Deutsche Bundesbank aktualisiert und bei jedem Programm-Update mitgeliefert. Aus technischen Gründen werden diese aber nicht automatisch erneuert, das können Sie aber jederzeit selbst tun:

So geht das:
Menü "Einstellungen" - "Referenzdaten" - "Bankenverzeichnis", dann rechte Mausklick und 'Importieren' wählen und 'Import aus den mitgelieferten Standarddaten'.

So können Bankdaten auch aus einer anderen Access-Datenbank geladen werden. Damit haben Sie unter anderem die Möglichkeit, aus der im Internet auf unserer Download-Seite zur Verfügung gestellten Referenzdatenbank mit Orts- und Bankenverzeichnis für Österreich und Schweiz diese Banken in ezBank zu Importieren.
Holen Sie sich dazu einfach die zip-Datei https://www.ezSoftware.info/files/Referenzdaten.zip und entpacken Sie die zip-Datei nach dem Download, z.B. mit WinZip. Dann kopieren Sie die Datenbank "Referenzdaten.mdb" in den Import-Ordner von ezBank. Nun können Sie im Bankenverzeichnis mit rechter Mausklick aus dem kleinen PopUp-Menü alle bestehenden Banken löschen (wenn Sie dies möchten) und Banken aus einer beliebigen Access-Datenbank mit Banken (z.B. aus der "Referenzdaten.mdb") importieren.


ezBank 2.5.5 - Ortsverzeichnis

Ortsverzeichnis

ezBank 2.5.5 liefert bereits ein komplettes deutsches Ortsverzeichnis mit, welches hier aber vervollständigt werden kann. Bei Eingabe einer Postleitzahl in einer Adresse wird der Ort dann automatisch aus dieser Tabelle gesucht und in die Anschrift eingetragen.

Sie können das Ortsverzeichnis auch vollständig aktualisieren und beispielsweise eigene Orte aus einer anderen Access-Datenbank laden. Damit haben Sie unter anderem die Möglichkeit, aus der im Internet auf unserer Download-Seite zur Verfügung gestellten Referenzdatenbank mit Orts- und Bankenverzeichnis für Österreich und Schweiz diese Orte in ezBank zu Importieren.
Holen Sie sich dazu einfach die zip-Datei https://www.ezSoftware.info/files/Referenzdaten.zip und entpacken Sie die zip-Datei nach dem Download, z.B. mit WinZip. Dann kopieren Sie die Datenbank "Referenzdaten.mdb" in den Import-Ordner von ezBank. Nun können Sie im Ortsverzeichnis mit rechter Mausklick aus dem kleinen PopUp-Menü alle bestehenden Orte löschen (wenn Sie dies möchten) und Orte aus einer beliebigen Access-Datenbank mit Orten (z.B. aus der "Referenzdaten.mdb") importieren.


ezBank 2.5.5 - Anreden

Anreden

Hier können Sie beliebige Anreden definieren, die dann bei Eingabe eines Gegenkontos zur Auswahl über eine Pull-Down-Auswahlliste zur Verfügung stehen.

Hinweis: Sie haben übrigens auch direkt aus den Eingabemasken einen Schnellzugriff auf die Referenztabellen, indem Sie einfach auf den entsprechenden Bezeichner vor dem Eingabefeld doppelklicken. Einen derart aktiven Bezeichner erkennen Sie daran, dass sich der Begriff blau einfärbt und unterstrichen wird, sobald Sie mit dem Mauszeiger drüberfahren.

Schnellzugriff

Beispiel: Ein Doppelklick auf den Bezeichner "Anrede" öffnet sofort die Referenztabelle zur Eingabe Ihrer Anreden.

Besondere Funktionen

Korrespondenz über Word oder E-Mail:
Sicherlich mit der wichtigste Verwendungszweck der Anreden ist als Briefanrede für die Korrespondenz über Word oder E-Mail. Dabei wird die Anrede automatisch mit Namen und Vornamen des Brief-Empfängers gefüllt. Dazu wird an die entsprechende Stelle ein Platzhalter für den Namen $Name$ oder den Vornamen $Vorname$ gesetzt.
Diese Briefanrede steht dann als Variable BANREDE zur Verfügung.


ezBank 2.5.5 - Sonstige Listen

Sonstige Listen

Diese Referenzlisten haben keine zusätzliche Funktionalität, sondern dienen ausschließlich als Vorgaben zu den entsprechenden Eingabefeldern, um die Eingabe zu vereinfachen und auch zu vereinheitlichen.

Das gilt für folgende Referenzdaten:

  • Verwendungszwecke
  • Notizvorlagen für Konten, Gegenkonten und Zahlungen
  • Berufe


ezBank 2.5.5 - Eigenschaften

Eigenschaften

Zusätzlich zu den Optionen gibt es noch verschiedene Programm-Eigenschaften, die geändert werden können. Im Gegensatz zu den Optionen beschreiben die Eigenschaften ausschließlich Einstellungen, die entweder aktiviert oder deaktiviert sein können.

Bei Windows-Start öffnen
Damit kann eingestellt werden, dass ezBank sofort beim Starten von Windows geöffnet wird - also gleich nach dem Einschalten des Rechners.

Kartei-Auswahl bei Start
Sind verschiedene Karteien definiert, dann kann hier eingestellt werden, dass beim Starten von ezBank die Karteien gelistet werden und eine bestimmte zum Öffnen ausgewählt werden kann.

Mit Kennwort starten
Beim Aktivieren dieser Einstellung kann ein Kennwort festgelegt werden. Beim Starten von ezBank wird dieses Kennwort erfragt, um die Benutzung der Anwendung durch nicht autorisierte Personen zu verhindern.

Symbolleiste anzeigen
Mit dieser Eigenschaft lässt sich die Symbolleiste oben direkt unterhalb des Menüs anzeigen oder ausblenden.

Vor Beenden warnen
Normalerweise muss vor dem Beenden der Anwendung dies bestätigt werden. Diese Bestätigungs-Abfrage vor dem Beenden kann ein- oder ausgeschaltet werden.

Automatische Datensicherung
Beim Aktivieren dieser Einstellung kann einer der vorhandenen Datensicherungsaufträge zur automatischen Ausführung beim Beenden von ezBank gewählt werden. Siehe dazu auch das Kapitel Datensicherung.


ezBank 2.5.5 - DB-Ordner wählen

DB-Ordner wählen

Hier können Sie einen beliebigen Ordner festlegen, der dann ab dem nächsten Start von ezBank 2.5.5 als sogenannter "Startordner" verwendet wird. Der Startordner beinhaltet die ezBank-Datenbasis.
Damit haben Sie also auch im Nachhinein noch die Möglichkeit, die ezBank-Daten vom Programm-Ordner zu trennen, falls dies nicht nach der Installation bei den ersten Schritten erfolgt ist (siehe auch Lektion Erster Start - Einstellungen).

Datenbankordner:
Hier wird der Ordner definiert, in dem die ezBank-Datenbank gespeichert werden soll. Mit der "Ordner"–Schaltfläche hinter dem Feld können Sie den Datenbankordner wählen.

JET-Engine (Access):
Mit der Standard-Programmlizenz können Sie in jedem Fall immer über die sogenannte JET-Engine auf die automatisch erstellte Access-Datenbank zugreifen. Dazu ist kein installiertes Access notwendig. Sie benötigen also keine Access-Lizenz.
Diese Anwendung ezBank 2.5.5 verfügt über keine SQL-Version, deshalb ist der Punkt "Microsoft SQL-Server" deaktiviert.

Damit die Dokumente und Vorlagen der Datenbank zugeordnet werden, können Sie hier auch einen Vorlagen-Basis-Ordner und einen Dokumente-Basis-Ordner festlegen.
Vorlagen-Basisordner:
Den Ordner, den Sie hier als Vorlagen-Basis festlegen, wird für alle Vorlagenordner (Briefe, Excel, E-Mails, Berichte) übernommen werden. Mit der "Ordner"–Schaltfläche hinter dem Feld können Sie den Vorlagen-Basisordner wählen.
Dokumente-Basisordner:
Den Ordner, den Sie hier als Dokumente-Basis festlegen, wird für alle Dokumenteordner (Dokumente, Scans, Briefe, Excel-Tabellen, E-Mails) übernommen werden. Mit der "Ordner"–Schaltfläche hinter dem Feld können Sie den Dokumente-Basisordner wählen.

Hintergrundfarbe und Logo-Bilddatei
Damit Sie sofort sehen können, auf welcher Datenbank Sie arbeiten, können Sie jeder Kartei (Datenbank) eine Farbe und ein Logo zuordnen. Zum Auswählen der Farbe doppelklicken Sie einfach auf die kleine Farbanzeige hinter "Hintergrundfarbe". Um eine Bilddatei zu wählen, klicken sie auf die kleine bunte Schaltfläche hinter "Logo-Bilddatei".

Hinweis: Der Startordner wird in der Karteiliste als 'Standard' eingetragen und kann dort weder gelöscht noch geändert werden.

Hinweis: Sie können weitere Datenbanken anlegen und verwalten. Mehr dazu siehe in der Lektion Karteien.


ezBank 2.5.5 - Drucklisten allgemein

Drucklisten allgemein

Mit Hilfe dieser Einstellung "Drucklisten" können Sie das allgemeine Aussehen (Layout) der gedruckten Listen bestimmen. Diese Einstellungen gelten für alle Drucklisten, für die keine Druckerdefinition als individuelles Layout zugeordnet wurde.

Mehr zu Drucklisten allgemein finden Sie im Kapitel Drucklisten.

Die Eingabefelder

Drucker: Hier wählen Sie aus der Liste aller installierten Drucker, auf welchem Drucker die Drucklisten gedruckt werden sollen.

Ohne Druckerdialog sofort drucken: Bevor eine Druckliste gedruckt wird, erscheint ein Dialog zur Auswahl des Druckers. Wenn Sie dieses Feld wählen, also ein Häkchen setzen, dann werden die Drucklisten direkt auf dem hier angegebenen Drucker ausgegeben, ohne dass zuvor der Druckerdialog zur Abfrage erscheint.

Schriftart: Hier können Sie die Schriftart wählen, die für die Drucklisten verwendet werden soll.

Schriftgrößen: Hier können Sie die Schriftgrößen für Titel, Überschrift und Datenzeilen wählen. Außerdem, ob die entsprechende Zeile normal, oder fett oder unterstrichen gedruckt werden soll.

Zeilen pro Seite: Hier geben Sie an, wieviele Zeilen je Seite gedruckt werden sollen. Das wird natürlich weniger, wenn Sie zum Beispiel eine größere Schriftgröße für Datenzeilen wählen.

Rand links: Hier bestimmen Sie den linken Rand, der eingehalten werden soll.

Rand oben: Hier bestimmen Sie den Rand oben, bevor die Druckliste anfängt.

Abstand: Hier bestimmen Sie den Abstand zwischen der Überschrift und den Datenzeilen.

Papierformat: Hier können Sie angeben, ob die Liste im Hochformat oder (bei sehr breiten Drucklisten) im Querformat gedruckt werden soll.


ezBank 2.5.5 - Druckerdefinitionen

Druckerdefinitionen

Hier können beliebig viele Druckerdefinitionen angelegt werden. Eine Druckerdefinition beschreibt die Schriftart, Schriftgröße, das Papierformat und mit welchem Drucker gedruckt wird. Eine solche Definition kann dann einer Druckliste zugeordnet werden, womit das Aussehen (Layout) dieser Druckliste festgelegt wird.
Haben Sie keine Druckerdefinitionen angelegt, oder für Drucklisten ohne eine zugeordnete Druckerdefinition, gilt die "Allgemeine Drucklisten-Einstellung" (siehe Lektion Drucklisten allgemein).


ezBank 2.5.5 - Standardwerte laden

Standardwerte laden

Hiermit können wieder die mit dem Produkt ausgelieferten Daten für Datensicherungen, Exportdefinitionen, Filter, Drucklisten, Berichte, Vorlagedateien und andere Referenzdaten geladen werden.

Wozu? Bei einem Software-Update liefern wir unter Umständen aktualisierte oder auch neue Versionen von Datensicherungen, Exportdefinitionen, Filterdefinitionen, Drucklisten, Berichten und Dokument-Vorlagedateien mit. Diese werden aber NICHT automatisch in die aktuelle Datenbank eingebunden, sind also zunächst nicht sichtbar.
Hiermit können Sie aber jederzeit wieder die mitgelieferten Datensicherungen, Exportdefinitionen, Filterdefinitionen, Drucklisten, Berichte und Dokument-Vorlagedateien laden.

Hinweis: Damit werden etwaige eigene Änderungen an den gewählten Einstellungen wieder überschrieben!


ezBank 2.5.5 - Listenbedienung

Listenbedienung

Dieses Kapitel beschreibt nicht nur ezBank-spezifische Bedienungsmöglichkeiten der dargestellten Listen, sondern auch die allgemein in Windows-Programmen üblichen, die aber nicht immer bekannt sind.

Die Filterbar

Sortieren

Suchen/Springen

Listenfenster

Menü 'Bearbeiten'

Die Toolbar

Einzelfeld-Massenänderung

Weiter zum Kapitel Arbeiten mit ezBank ...


ezBank 2.5.5 - Die Filterbar

Die Filterbar

Mit der Filter-Schaltfläche der Toolbar (siehe Lektion Die Toolbar) lässt sich die Filterbar (die Filtereingabe-Möglichkeit direkt unterhalb der Titelzeile der Tabelle) ein- und wieder ausblenden. Je nach dem, nach welchem Filterkriterium (Feld) Sie suchen möchten, klicken Sie in die Filtereingabe unterhalb des entsprechenden Spaltentitels. Suchen Sie also beispielsweise nach einem bestimmten Nachnamen, so klicken Sie in die Filtereingabe unterhalb des Spaltentitels "Nachname". Dort können Sie nun Ihr Suchkriterium eingeben.

Folgende Möglichkeiten stehen dabei zur Verfügung:
Eingabe | Beispiel | Ergebnis
*Josef* | Im Feld 'Name' | Alle Personen mit "Josef" irgendwo in der Spalte. Die Sternchen können auch weggelassen werden.
Müller | Im Feld 'Name' | Alle Personen mit Namen "Müller" irgendwo in der Spalte. Entspricht den Sternchen.
Mayer* | Im Feld 'Name' | Alle Personen mit Namen "Mayer" am Beginn der Spalte.
=Josef | Im Feld 'Name' | Alle Personen mit exakt diesem Namen "Josef".
*bach | Im Feld 'Ort' | Alle Personen in einem Ort mit "bach" am Ende der Spalte.
[] | Im Feld 'Ort' | Alle Personen OHNE Angabe eines Ortes. "[]" bedeutet also ein leeres Feld.
[] | In einem Betragsfeld | Alle Daten mit Betrag = '0'. Das entspricht bei Beträgen der Angabe von '0'.
=1.250,80 | In einem Betragsfeld | Alle Daten mit exakt dem eingegebenen Betrag.
>=1000 | In einem Betragsfeld | Alle Daten mit dem eingegebenen Betrag oder höher.
>60 | Im Feld 'Alter' | Alle Personen, die älter als 60 sind. ">" bedeutet also "größer als".
<60 | Im Feld 'Alter' | Alle Personen, die jünger sind als 60. "<" bedeutet also "kleiner als".

Mit der Eingabe-Taste oder mit Klick in den Spaltentitel wird die Suchanfrage ausgeführt und die der Suchanfrage entsprechenden Datensätze erscheinen in der Liste.
Sie können dabei mehrere Suchanfragen miteinander verknüpfen, weil alle Anfragen automatisch als "Und"-Abfragen interpretiert werden. Das bedeutet beispielsweise, dass Sie nach Personen mit dem Namen "Müller" in "München" suchen können. Dazu geben Sie einfach in der Filterbar der Spalte "Name" den Namen "Müller" und in die Filterbar der Spalte "Ort" die Stadt "München" ein und bestätigen Ihre Eingaben mit der Eingabe-Taste. Nun erscheint in der Liste das Ergebnis dieser Suchanfrage. Sie können nun durch weitere Abfragen dieses Ergebnis noch weiter eingrenzen.

Mit Klick auf die Filter-entfernen-Schaltfläche wird der Filter wieder entfernt und damit die Liste wieder mit allen Datensätzen angezeigt.

Hinweis: Anspruchsvollere Suchanfragen können auch über die Filter-Funktion des Menüs "Bearbeiten" (bzw. das Drop-Down-Menü der rechten Maustaste, bzw. dem Filter-Icon) durchgeführt werden. Siehe dazu Lektion Filtern.


ezBank 2.5.5 - Sortieren

Sortieren

Der Inhalt einer jeden Spalte einer Liste kann sortiert werden. Dabei werden Wörter alphabetisch und Zahlen numerisch sortiert. Zum Sortieren fahren Sie mit dem Mauszeiger in die Titelzeile der Spalte, deren Inhalt Sie sortieren wollen. Wenn sich der Mauszeiger zu einem nach unten gerichteten Pfeil verändert hat, klicken Sie einmal in die Titelzeile. Die Sortierung des Spalteninhalts wird umgekehrt, wenn Sie ein zweites Mal in die Titelzeile klicken.
Die Sortierung der Spalte wird übrigens auch nach dem Beenden der Anwendung beibehalten.


ezBank 2.5.5 - Suchen/Springen

Suchen/Springen

Um bestimmte Datensätze in der Liste zu finden, gibt es eine Suchfunktion. Wenn Sie beispielsweise eine Person mit dem Namen "Müller" suchen, sortieren Sie zuerst die Spalte "Name" in der entsprechenden Liste (siehe Lektion Sortieren). Die Suchanfrage bezieht sich nämlich immer auf die zuletzt sortierte Spalte. Um die Suchanfrage durchzuführen, müssen Sie einfach nur beginnen den Namen zu tippen. In der linken unteren Ecke der Statuszeile sehen Sie, was Sie gerade eingeben. Das Ergebnis der Suchanfrage wird über den Datensatzzeiger ausgegeben. In diesem Beispiel springt der Datensatzzeiger sofort nach dem Eingeben des Buchstabens "M" auf den ersten Datensatz, mit einem "M" in der Spalte "Name". Bei Eingabe weiterer Buchstaben wird die Suche entsprechend konkretisiert.


ezBank 2.5.5 - Listenfenster

Listenfenster

Grundsätzlich ist zu sagen, dass sich ezBank merkt, welche Position und Größe die Fenster hatten, nachdem das letzte mal mit diesen gearbeitet wurde. Ebenso merkt sich ezBank die Breite der einzelnen Spalten und die aktuelle Sortierung.

::: Listen auf maximale Größe stellen :::

::: Zwei Listen zugleich anzeigen lassen :::

::: Zwischen mehreren geöffneten Fenstern springen :::

::: Das Listen-Layout verändern :::


ezBank 2.5.5 - Listen auf maximale Größe stellen

Listen auf maximale Größe stellen

Um Listen auf maximale Größe zu stellen, wird nicht empfohlen, die kleine "Maximieren"-Schaltfläche in der rechten oberen Ecke der Titelzeile des Listen-Fensters zu betätigen. Auf diese Weise werden nämlich alle Dialoge, die man hinterher aufruft, ebenfalls in maximaler Größe geöffnet. Das sieht nicht besonders gut aus und ist nicht unbedingt gewünscht.

Eine bessere Lösung ist, zur Einstellung nur eine Liste zu öffnen und dann das Listen-Fenster nach dem Öffnen über den Hauptmenüpunkt "Fenster" mit Klick auf den Menüpunkt "Untereinander" zu maximieren. Dann wird nur dieses eine Listen-Fenster automatisch auf maximale Größe gezogen, ohne dass andere Dialog-Fenster davon betroffen werden.
So können Sie jede Liste einmal aufrufen, maximieren, wieder schließen. Dann werden alle Listen zukünftig beim Öffnen sofort maximiert angezeigt.


ezBank 2.5.5 - Zwei Listen zugleich anzeigen lassen

Zwei Listen zugleich anzeigen lassen

Dazu gehen Sie nach dem Öffnen der Listen auf den Hauptmenüpunkt "Fenster" und klicken auf den Menüpunkt "Untereinander". Die zwei Listen-Fenster werden dann gleichzeitig angezeigt, ohne dass die Datensätze unvollständig angezeigt werden.
Alternativ wählen Sie "Nebeneinander", dann werden die beiden Listen nebeneinander angezeigt.


ezBank 2.5.5 - Zwischen mehreren geöffneten Fenstern springen

Zwischen mehreren geöffneten Fenstern springen

Wenn Sie mehrere Fenster geöffnet haben, können Sie mit gedrückter Strg-Taste und der F6-Taste zwischen den Fenstern springen.


ezBank 2.5.5 - Das Listen-Layout verändern

Das Listen-Layout verändern

Das Layout lässt sich mit Hilfe der Maus sehr leicht ändern:
Um die Spaltenbreite zu ändern, fahren Sie mit dem Mauszeiger in der Titelzeile der Liste über die Trennungslinie zwischen zwei Zellen. Wenn sich der Mauszeiger in einen Doppelpfeil verändert hat, halten Sie die linke Maustaste gedrückt und ziehen die Trennungslinie nach rechts oder links in die gewünschte Position.
Die Zeilenhöhe lässt sich NICHT direkt ändern. Dies hängt von der verwendeten Schriftgröße ab und ändert sich automatisch bei einer entsprechenden Einstellung der allgemeinen Formulargröße. (siehe Lektion Optionen)

Welche Felder überhaupt angezeigt werden sollen und die Reihenfolge der Spalten definieren Sie über die Funktion "Spalten-Definitionen", die Sie links unterhalb einer jeden Liste finden können. Mehr dazu lesen Sie bitte in der Lektion Listeneinstellungen nach.


ezBank 2.5.5 - Menü 'Bearbeiten'

Menü 'Bearbeiten'

Mit einem Klick mit der rechten Maustaste in einer Liste (z.B. der Gegenkontenliste) öffnet sich ein sogenanntes Kontextmenü, welches verschiedene Möglichkeiten zum Bearbeiten der Liste anzeigt. Das sind immer dieselben Möglichkeiten wie im "Bearbeiten"-Hauptmenü angezeigt. Sie können also wahlweise beide Auswahlmöglichkeiten nutzen.

::: Ausschneiden :::

::: Kopieren :::

::: Einfügen :::

::: Filtern :::

::: Markieren :::

::: Merken :::

::: Drucken :::

::: Berichte :::

::: Exportieren :::


ezBank 2.5.5 - Ausschneiden

Ausschneiden

Mit Ausschneiden oder der Tastenkombination Strg+X können Sie einen Datensatz aus der Liste löschen. Diese Funktion bezieht sich immer auf den gerade aktuell markierten Datensatz bzw. den markierten Datensätzen (Mehrfachlöschung!) und entspricht damit exakt der Schaltfläche Löschen in der Liste.
Hinweis: Ein so gelöschter Datensatz wird auch aus der Datenbank entfernt und kann NICHT wiederhergestellt werden!


ezBank 2.5.5 - Kopieren

Kopieren

Mit Kopieren oder der Tastenkombination Strg+C können Sie den aktuell markierten Datensatz kopieren. Diese Funktion bezieht sich immer auf den EINEN Datensatz mit der Datensatzmarkierung (Pfeil/Dreieck links vor der Zeile).
Wahlweise kann ein so kopierter Datensatz sofort wieder hier eingefügt werden, dann haben Sie in dieser Liste eine exakte Kopie des Datensatzes.
Oder Sie fügen den kopierten Datensatz hier NICHT ein, dann bleibt die Kopie in der Zwischenablage und kann von dort mit Einfügen wieder eingefügt werden. Damit können Sie einen Datensatz z.B. in eine andere Kartei kopieren.


ezBank 2.5.5 - Einfügen

Einfügen

Mit Einfügen oder der Tastenkombination Strg+V wird ein zuvor in die Zwischenablage kopierter Datensatz hier wieder eingefügt.
Wurde noch kein Datensatz in die Zwischenablage kopiert, dann öffnet sich hier einfach ein Fenster zur Eingabe eines neuen Datensatzes. Dies entspricht damit genau der Schaltfläche Neueingabe in der Liste.


ezBank 2.5.5 - Filtern

Filtern

An der geöffneten Liste können Sie eine Filterabfrage durchführen, um die Gesamtliste auf die Gruppe von Datensätze einzugrenzen, die Sie interessieren. Siehe dazu auch die Lektion Filtermöglichkeiten.
Den Menüpunkt "Filtern" finden Sie unter dem Hauptmenüpunkt "Bearbeiten", und wenn Sie mit der rechten Maustaste in die Liste klicken. Ob die Liste, die Sie gerade sehen, das Ergebnis einer Filterabfrage oder die Komplettliste ist, wird in der rechten unteren Ecke der Statusleiste angezeigt.
Der Filter wird nach Schließen des Listen-Fensters wieder entfernt, so dass beim nächsten Öffnen der Liste immer der komplette Inhalt zu sehen ist.


ezBank 2.5.5 - Markieren

Markieren

ezBank bietet über den Menüpunkt "Markieren" die zwei Möglichkeiten an:
  • "Alle Datensätze markieren"
  • "Alle Markierungen entfernen"
Dazu gehen Sie entweder auf den Hauptmenüpunkt "Bearbeiten" oder klicken mit der rechten Maustaste in eine Liste, dann öffnet sich dasselbe Menü, das sich auch unter dem Hauptmenüpunkt "Bearbeiten" befindet.

Weitere Möglichkeiten zum Markieren

  • Alles markieren = Strg-Taste gedrückt halten und in die linke obere Ecke der Liste klicken
  • Einzeln markieren = Strg-Taste gedrückt halten und auf Datensätze klicken
  • Einen Block markieren = einen Datensatz durch Klick markieren, Umschalt-Taste gedrückt halten und auf den untersten/bzw. obersten Datensatz im gewünschten Block klicken


ezBank 2.5.5 - Merken

Merken

Diese Funktion ist eine Sonderfunktion und steht nicht in allen Listen zur Verfügung. Wenn diese Funktion zur Verfügung steht, dann kann mit Merken oder der Tastenkombination Strg+M der gerade markierte Datensatz in einer Merkliste gemerkt werden, für eine spätere Bearbeitung beispielsweise.
Mehr zum Thema "Merklisten" finden Sie im Kapitel Merklisten.


ezBank 2.5.5 - Drucken

Drucken

Über das Menü "Bearbeiten" - "Drucken" oder aus dem Kontextmenü mit Mausklick rechts können Sie die angezeigte Liste komplett oder teilweise drucken. Dabei wird die Liste genau so ausgedruckt, wie Sie sie gerade auf dem Bildschirm sehen. Deshalb können Sie folgende Veränderungen durchführen, bevor Sie den Druckvorgang starten:
  • Wenn Sie nicht die gesamte Liste drucken wollen, können Sie eine Filterabfrage durchführen (siehe Lektionen Filtern und Filtermöglichkeiten).
  • Sie können die Sortier-Funktion nutzen, um die Datensätze in einer bestimmten Sortierfolge zu drucken (siehe Lektion Sortieren).
  • Mit der Maus lassen sich die Spaltenbreiten leicht verändern.
  • Wenn Sie eine Spalte nicht mit ausdrucken möchten, minimieren Sie die Spaltenbreite, so dass sie nicht angezeigt wird.

Druckfunktion der Toolbar
Eine weitere Möglichkeit zum Drucken von Listen finden Sie als optionale Schaltfläche der Toolbar (siehe Lektion Die Toolbar). Dabei wird ebenfalls eine Liste wahlweise mit allen oder nur allen markierten Datensätzen ausgedruckt. Dabei entspricht allerdings auch die optische Darstellung der Druckliste weitgehend derer der Bildschirmliste.

Mehr zu Drucklisten allgemein finden Sie in der Lektion Drucklisten.


ezBank 2.5.5 - Berichte

Berichte

Diese Funktion bezieht sich immer auf den gerade aktuell markierten Datensatz und ermöglicht es Ihnen, zu diesem Datensatz einen Bericht mit bestimmten Daten darzustellen. Über den Hauptmenüpunkt "Bearbeiten", oder mit Klick der rechten Maustaste in die Liste, finden Sie den Menüpunkt "Berichte". Es öffnet sich das Fenster "Bericht wählen", in dem Sie dann aus der dargestellten Liste mit den Berichtsmöglichkeiten eine auswählen. Nach Klick auf die Schaltfläche OK wird der gewählte Bericht automatisch erstellt und angezeigt.

Mehr zum Thema "Berichte" finden Sie im Kapitel Berichte.


ezBank 2.5.5 - Exportieren

Exportieren

In jeder Liste haben Sie die Möglichkeit, Datensätze zu exportieren, das heißt, in ein anderes Format zur Bearbeitung in einem anderen Programm zu überführen.

Hinweis: Bitte beachten Sie, dass nur die Datensätze exportiert werden, welche zuvor markiert wurden.

Sie können also die Datensätze zuerst durch Filtern (siehe Lektionen Filtern und Filtermöglichkeiten) auf eine für Sie interessante Gruppe einschränken (z.B. alle Personen, die im aktuellen Monat Geburtstag haben), und dann einzelne oder auch alle Datensätze für den Export markieren (siehe Lektion Markieren).
Diese Möglichkeit der Auswahl und Export können Sie beispielsweise dazu verwenden einen Serienbrief zu schreiben.

Mehr zum Thema "Exportieren" finden Sie im Kapitel Datenexport.


ezBank 2.5.5 - Die Toolbar

Die Toolbar

Alle großen Listen in ezBank führen in der unteren Schaltflächen-Leiste eine sogenannte Toolbar mit. Über die Toolbar lassen sich bestimmte Funktionalitäten der Listenbedienung betätigen. Die Standard-Einstellung der Toolbar umfasst sechs Funktionalitäten:
alles Markieren | alles Markieren | Hiermit können alle Datensätze in einer Liste markiert bzw. die Markierung deaktiviert werden.
Filterbar | Filterbar | Hiermit kann die Filterbar (die Filtereingabe-Möglichkeit direkt unterhalb der Titelzeile der Tabelle) eingeblendet bzw. ausgeblendet werden. (siehe Lektion Die Filterbar)
Filter entfernen | Filter entfernen | Diese Funktion entfernt einen angewandten Filter, so dass die Liste mit den Suchergebnissen ausgeblendet wird und die Liste mit allen Datensätzen wiederhergestellt ist. Dabei ist es egal, ob die Suche über die Suchfunktion der Filterbar durchgeführt wurde oder über die Filterfunktion des Menüs "Bearbeiten". (siehe Lektion Filtern)
Druckliste | Druckliste | Hiermit wird eine Liste mit allen Datensätzen oder allen markierten Datensätzen gedruckt. Dabei entspricht die optische Darstellung der Druckliste derer der Bildschirmliste.
Standard-Bericht | Standard-Bericht | Diese Funktion erstellt einen listenartigen Standard-Bericht im HTML-Format aus allen Datensätzen bzw. allen markierten Datensätzen.
Spaltenbreiten | Spaltenbreiten | Betätigt man diese Funktion, so werden die Spalten der Tabelle in ihrer Breite am breitesten Feldinhalt ausgerichtet. Wichtig dabei: es werden nur alle gerade sichtbaren Zeilen der Liste berücksichtigt.

Darüber hinaus bietet die Toolbar noch zwei weitere Funktionalitäten, die sich über den Einstellungsdialog zur Liste mit anzeigen lassen. Aufgerufen wird der Einstellungsdialog zur Liste über die kleine Schaltfläche unten rechts in der Liste. Siehe dazu die Lektion Listeneinstellungen. Die dort vorgenommenen Einstellungen gelten jeweils für die Toolbar in der gerade geöffneten Liste.
Zeilenfarben | Zeilenfarben | Hiermit kann die Farbgebung der Liste aktiviert bzw. deaktiviert werden. Dies bezieht sich allerdings nur auf die Zeilenfarben, nicht auf Farb-Einstellungen einzelner Spalten.
Grundeinstellung | Grundeinstellung | ACHTUNG: Betätigt man diese Funktion gehen alle selbst vorgenommenen Einstellungen auf Standard zurück. Diese Funktion ist besonders dann von Nutzen, wenn eine Korrektur der Einstellungen zu viel Aufwand wäre.


ezBank 2.5.5 - Einzelfeld-Massenänderung

Einzelfeld-Massenänderung

Diese Funktion ist eine sehr mächtige und deshalb auch gefährliche Besonderheit in ezBank 2.5.5, die deshalb sehr vorsichtig und möglichst erst nach einer aktuellen Datensicherung verwendet werden sollte.
Hiermit können Sie über beliebig viele Datensätze der geöffneten Liste (z.B. der Gegenkontenliste) einem Feld einen neuen Inhalt zuweisen. Dabei wird bei ALLEN markierten Datensätzen das gewählte Feld mit einem neuen Inhalt gefüllt oder auch gelöscht.

Hinweis: Eine so durchgeführte Massenänderung ist NICHT mehr rückgängig zu machen!

Durchführen der Massenänderung

  1. Markieren Sie in der geöffneten Liste die Datensätze, die Sie zu ändern wünschen. Nehmen Sie dazu auch die Funktionen Sortieren, Filtern und Markieren zu Hilfe.
  2. Mit Klick auf die Schaltfläche Details/Ändern öffnet sich der oben dargestellte Dialog zum Durchführen der Massenänderung.
  3. Wählen Sie aus der Auswahlliste das gewünschte zu ändernde Feld.
  4. Im Kasten 'Neuer Feldinhalt' wählen Sie eine der drei Möglichkeiten zur Eingabe eines beliebigen Inhaltes, zur Auswahl eines Feldes als Quelle, oder zum Löschen des Feldinhalts.
  5. Je nach gewählter Möglichkeit geben Sie nun entweder einen neuen Feldinhalt ein, oder wählen ein Feld als Quelle für den neuen Inhalt.
  6. Mit Klick auf die Schaltfläche OK wird für jeden markierten Datensatz das gewählte zu ändernde Feld mit dem neuen Feldinhalt überschrieben.

::: Spezielle Funktionen :::


ezBank 2.5.5 - Spezielle Funktionen

Spezielle Funktionen

Eine weitere Möglichkeit besteht darin, den Inhalt des gewählten Feldes mittels einer Funktion zu ändern, welche aufgrund definierter Regeln oder Berechnungen den neuen Feldinhalt bestimmt. Aufgerufen wird eine solche Funktion, indem als Inhalt der Funktionsname mit einem führenden Gleichheitszeichen eingetragen wird, beispielsweise '=KLEIN' oder '=BERECHNE,Addiere,FELD01,FELD02'.
Hinweis: Bitte unbedingt auf das führende Gleichheitszeichen achten, da der eingegebene Inhalt sonst genau so in das angegebene Feld eingetragen wird!

Folgende Funktionen stehen zur Verfügung:
Funktion | Bedeutung | Beispiel
APLHANUM | Lässt nur alphabetische und numerische Zeichen stehen, entfernt also alle Sonderzeichen und Leerzeichen. | Feld: 'VERSICHERUNGSNR' - Neuer Feldinhalt: '=APLHANUM' - Entfernt bei den Versicherungs-Nummern alle Sonderzeichen und Leerzeichen.
NUMMER | Lässt ausschliesslich numerische Zeichen, also Zahlen stehen und entfernt alle anderen Zeichen vom angegebenen Feld. | Feld: 'TELEFON' - Neuer Feldinhalt: '=NUMMER' - Entfernt bei allen Telefonnummern sämtliche Zeichen, die keine Zahlen sind.
KLEIN | Den Inhalt komplett in Kleinbuchstaben umsetzen. | Feld: 'EMAIL' - Neuer Feldinhalt: '=KLEIN' - Setzt alle E-Mail-Adressen in Kleinbuchstaben um.
GROSS | Den Inhalt komplett in Grossbuchstaben umsetzen. | Feld: 'LAND' - Neuer Feldinhalt: '=GROSS' - Setzt alle Länderkennzeichen in Grossbuchstaben um.
ENTFERNE,zeichen | Entfernt vom angegebenen Feld sämtliche enthaltenen hier angegebene Zeichen. | Feld: 'TELEFON' - Neuer Feldinhalt: '=ENTFERNE,()' - Entfernt bei allen Telefonnummern die möglicherweise enthaltenen Klammern.
ENTFERNE, links/rechts,anzahl | Entfernt vom angegebenen Feld die angegebene Anzahl Zeichen links oder rechts. | Feld: 'PLZ' - Neuer Feldinhalt: '=ENTFERNE,links,2' - Entfernt bei allen markierten Datensätzen vom Feld PLZ die linken zwei Stellen, z.B. wenn dort jeweils das Land mit angegeben war.
ENTFERNE, links/rechts,stelle,position | Entfernt vom angegebenen Feld das Zeichen an der angegebenen Position von links bzw. rechts zählend. | Feld: 'LINK' - Neuer Feldinhalt: '=ENTFERNE,links,stelle,5' - Angenommen, Sie haben fehlerhafte Daten importiert und jetzt bei allen angegebenen Web-Adressen am Anfang "www.." statt korrekt "www.", dann entfernen Sie hiermit das fünfte Zeichen (den überflüssigen Punkt) aus der Web-Adresse.
ERSETZE, feld,string1,string2 | Füllt den Inhalt mit dem angegebenen Feld und ersetzt dabei einen enthaltenen String1 mit String2. | Feld: 'EMAIL' - Neuer Feldinhalt: '=ERSETZE,EMAIL,-AT-,@' - Setzt alle E-Mail-Adressen, die anstelle des @-Zeichens ein '-AT-' enthalten in eine korrekte E-Mail-Adresse mit @-Zeichen um.
BLZ | Den Inhalt als Bankleitzahl formatieren (deutsches Format 123 123 12). | Feld: 'BLZ' - Neuer Feldinhalt: '=BLZ' - Setzt alle Bankleitzahlen in das deutsche Format um. Achtung: Nur wenn bei den Optionen unter Vorgaben so gewählt.
NAME | Den Inhalt als Namen formatieren (erster Buchstabe groß). | Feld: 'VORNAME' - Neuer Feldinhalt: '=NAME' - Setzt bei allen Vornamen den ersten Buchstaben in einen Grossbuchstaben um.
BERECHNE, funktion,wert1,wert2 | Das Feld mit dem Ergebnis der Funktionsberechnung füllen. Zur Verfügung stehende Funktionen: Addiere, Multipliziere, Prozent, Brutto, Netto | Feld: 'FELD01' - Neuer Feldinhalt: '=BERECHNE,Addiere,BETRAG,10' - Füllt das Zusatzfeld FELD01 mit der Summe aus BETRAG plus 10. Feld: 'FELD02' - Neuer Feldinhalt: '=BERECHNE,Multipliziere,BETRAG,2' - Füllt das Zusatzfeld FELD02 mit dem Produkt aus BETRAG und 2, also 2 mal BETRAG. Feld: 'FELD03' - Neuer Feldinhalt: '=BERECHNE,Netto,BETRAG,16' - Füllt das Zusatzfeld FELD03 mit dem Nettobetrag aus BETRAG mit 16 Prozent Mehrwertsteuer. Feld: 'FELD04' - Neuer Feldinhalt: '=BERECHNE,Prozent,FELD03,16' - Füllt das Zusatzfeld FELD04 mit dem Ergebnis aus 16 Prozent aus dem Zusatzfeld FELD03. Feld: 'FELD05' - Neuer Feldinhalt: '=BERECHNE,Brutto,FELD04,16' - Füllt das Zusatzfeld FELD05 mit dem Bruttobetrag aus FELD04 mit 16 Prozent Mehrwertsteuer. Ergibt logischerweise wieder den BETRAG.


ezBank 2.5.5 - Arbeiten mit ezBank

Arbeiten mit ezBank

Um Zahlungsaufträge zu erfassen benötigen Sie zuerst ein Konto, von dem die Überweisungen abgebucht bzw. wohin Lastschriften eingezahlt werden sollen. Zur Vereinfachung immer wiederkehrender Überweisungen bzw. Lastschriften an den selben Empfänger bzw. Zahlungspflichtigen können Sie sogenannte Gegenkonten anlegen, die dann beim Erfassen eines Zahlungsauftrages zur Auswahl zur Verfügung stehen.

Voraussetzung - Konto eingeben

Gegenkonto eingeben

Zahlungsauftrag eingeben

Die Zahlungsliste

Bankdatei erstellen (SEPA oder DTAUS)

Importieren von Daten

Merklisten

Eigene Listen

CTI-Telefonie über TAPI oder VoIP

DWA - Wirtschaftsauskunft

Tastaturbedienung - Übersicht der 'Hotkeys'

Weiter zum Kapitel Dokumente/Briefe/E-Mails ...


ezBank 2.5.5 - Voraussetzung - Konto eingeben

Voraussetzung - Konto eingeben

Zumindest ein Konto wird als Voraussetzung zum Erstellen einer SEPA- oder DTAUS-Datei benötigt. Sie können mit ezBank 2.5.5 aber auch beliebig viele Konten verwalten, z.B. ein Privatkonto und ein Geschäftskonto, und dazu Zahlungsaufträge erfassen.
Eingegeben, geändert oder gelöscht wird ein Konto über die Kontenliste, welches aus dem Startmenü, aus dem Hauptmenü "Zahlungen" unter "Konten" - "Liste" bzw. mit der Tastenkombination 'Strg+K', oder aus der darunterliegenden Toolbar mit dem entsprechenden Symbol aufgerufen werden kann.

::: Felder und Funktionen :::

::: Reiter :::


ezBank 2.5.5 - Felder und Funktionen

Felder und Funktionen

Die Pflichtfelder
Beim Anlegen eines neuen Kontos müssen die Bezeichnung mit Kontonummer und BLZ sowie der Name des Inhabers in jedem Fall ausgefüllt werden. Als Bezeichnung geben Sie z.B. "Privatkonto" oder "Geschäftskonto" oder ähnliches ein, wahlweise auch mit dem Namen des Kontoinhabers oder der Kontonummer.
Bei SEPA-Lastschriften wird noch die Gläubiger-Identifikationsnummer zwingend benötigt. Diese wird bei der Deutschen Bundesbank beantragt.

Funktionen / Besonderheiten

Kontonummernprüfung:
Ist die Kontonummer und BLZ eingegeben, dann wird geprüft, ob diese Kontonummer für die eingegebene BLZ gültig ist. Wenn festgestellt wird, dass die Kontonummer laut Prüfverfahren ungültig ist, dann wird dies an einem roten X in der Symbol-Schaltfläche neben der BLZ angezeigt. Eine gültige Kontonummer wird durch ein grünes Häkchen angezeigt.

Gläubiger-Id:
Hier muss die für SEPA-Einziehungen benötigte Gläubiger-Id eingetragen werden, wenn auch Einziehungen durchgeführt werden sollen. Mit einem Klick auf die Schaltfläche hinter diesem Eingabefeld wird zur Beantragung der Gläubiger-Identifikationsnummer auf die entsprechende Internetseite der Deutschen Bundesbank gesprungen.

Bankdatei:
Mit Mausklick auf die kleine Schaltfläche hinter dem Eingabefeld "Bankdatei" öffnet sich ein Dialog zur Auswahl eines Ordners und Dateinamens für die SEPA- oder DTAUS-Datei. Vorgegeben ist SEPA.xml im Ordner C:\ezBank\ zum Transfer über das Internet zur Bank. Das kann hier aber geändert werden, z.B. in DTAUS1 zum Erstellen einer DTAUS-Datei.


ezBank 2.5.5 - Reiter

Reiter

Konto (Details)
Hier finden Sie die allgemeinen (wichtigsten) Daten zum Konto wie Bezeichnung, Kontonummer und BLZ sowie die Anschrift und weitere Kontaktmöglichkeiten wie Telefonnummern und EMail-Adresse.

Memo
Hier können Sie einen beliebigen Fließtext eingeben, um z.B. irgendwelche Informationen zum Konto oder besondere Notizen zu hinterlegen.
Hinweis: Der Text wird automatisch am Zeilenende umgebrochen. Eine neue Zeile erzwingen können Sie mit der Tastenkombination 'Umschalt'+'Eingabe'.

Zahlungen
Dieser Reiter bietet eine alternative Möglichkeit zur Eingabe von Zahlungsaufträgen zum betreffenden Konto.

History
Hier sehen Sie die bereits erledigten Zahlungsaufträge dieses Kontos, die auch wieder reaktiviert oder gelöscht werden können.

Dokumente
Hier ist es Ihnen möglich, dem Konto Dokumente jeglichen Typs zuzuordnen und diese direkt von ezBank 2.5.5 aus aufrufen und anzeigen zu lassen. Zudem können Sie hier direkt Word-Dokumente zum Konto erstellen, um zum Beispiel einen Brief an die Filiale zu schreiben.
Eine genaue Beschreibung zur Dokumentfunktion und alle Möglichkeiten dazu finden Sie im Kapitel Die Dokumentfunktion (Reiter 'Dokumente').


ezBank 2.5.5 - Gegenkonto eingeben

Gegenkonto eingeben

Zur Vereinfachung immer wiederkehrender Überweisungen bzw. Lastschriften an den selben Empfänger bzw. Zahlungspflichtigen können Sie sogenannte Gegenkonten anlegen, die dann beim Erfassen eines Zahlungsauftrages zur Auswahl zur Verfügung stehen.
Eingegeben, geändert oder gelöscht wird ein Gegenkonto über die Gegenkontenliste, welches aus dem Startmenü, aus dem Hauptmenü "Zahlungen" unter "Gegenkonten" - "Liste" bzw. mit der Tastenkombination 'Strg+G', oder aus der darunterliegenden Toolbar mit dem entsprechenden Symbol aufgerufen werden kann.

::: Felder und Funktionen :::

::: Reiter :::


ezBank 2.5.5 - Felder und Funktionen

Felder und Funktionen

Das Pflichtfeld "Suchbegriff"
Beim Anlegen eines neuen Gegenkontos muss das Eingabefeld "Suchbegriff" in jedem Fall ausgefüllt werden. Das Feld wird allerdings automatisch mit den Daten aus den Eingabefeldern "Name" und "Vorname" gefüllt. Es wird also empfohlen, nicht den Suchbegriff selbst einzugeben, sondern dies ezBank 2.5.5 zu überlassen, einfach durch die Eingabe von Namen und Vornamen.

Weitere Pflichtfelder
Des weiteren muss beim Anlegen eines neuen Gegenkontos die Kontonummer und BLZ angegeben werden, ansonsten wäre eine Verwendung für Zahlungsaufträge nicht möglich.
Bei SEPA-Lastschriften zwingend erforderlich ist noch die Mandatsreferenz sowie das Unterschriftsdatum des Mandats.

Empfohlene Eingaben
Empfohlen wird allerdings wenigstens die Eingabe der folgenden Felder:

  • Name und Vorname
  • Strasse oder Postfach
  • Land, PLZ, Wohnort
  • Anrede und Briefanrede (für Serienbriefe)
  • Eine weitere Kontaktmöglichkeit, wie "Telefon-Nr" oder "E-Mail-Adresse"

Funktionen / Besonderheiten

Kontonummernprüfung:
Ist die Kontonummer und BLZ eingegeben, dann wird geprüft, ob diese Kontonummer für die eingegebene BLZ gültig ist. Wenn festgestellt wird, dass die Kontonummer laut Prüfverfahren ungültig ist, dann wird dies an einem roten X in der Symbol-Schaltfläche neben der BLZ angezeigt. Eine gültige Kontonummer wird durch ein grünes Häkchen angezeigt.

SEPA-Lastschriftmandat:
Mit einem Klick auf die kleine Schaltfläche rechts neben dem Feld für das Unterschriftsdatum kann sehr einfach ein Formular zum SEPA-Lastschriftmandat ausgefüllt und ausgedruckt werden.
Dabei werden bereits einige vorgefertigte Wordvorlagen mitgeliefert:

  • Einzugsermächtigung und SEPA-Lastschriftmandat.dot
  • Mitteilung zur Umstellung auf SEPA.dot
  • SEPA-Firmenlastschrift-Mandat Dauerauftrag.dot
  • SEPA-Firmenlastschrift-Mandat Einmallastschrift.dot
  • SEPA-Lastschriftmandat Dauerauftrag.dot
  • SEPA-Lastschriftmandat Einmallastschrift.dot


ezBank 2.5.5 - Reiter

Reiter

Gegenkonto (Details)
Hier finden Sie die allgemeinen (wichtigsten) Daten zum Gegenkonto wie Kontonummer, BLZ und Kontoinhaber sowie die Anschrift und weitere Kontaktmöglichkeiten wie Telefonnummern und EMail-Adresse.

Weitere Details (Vorgaben und Zusatzfelder)
Hier können Sie Vorgaben für neue Zahlungsaufträge zu diesem Gegenkonto eingeben. Damit können Kundennummer, Betrag und Verwendungszweck eines neuen Zahlungsauftrags bereits vorgefüllt werden.
Falls Ihnen weitere Eingabefelder für die Gegenkonten fehlen, bietet Ihnen ezBank 2.5.5 eine komfortable Möglichkeit selbst Eingabefelder anzulegen. Diese Funktion finden Sie im Hauptmenüpunkt "Einstellungen" unter "Zusatzfelder Gegenkonten" (siehe Lektion Die Zusatzfelder im Kapitel Einstellungen).

Memo
Hier können Sie einen beliebigen Fließtext eingeben, um z.B. irgendwelche Informationen zum Gegenkonto oder besondere Notizen zu hinterlegen.
Hinweis: Der Text wird automatisch am Zeilenende umgebrochen. Eine neue Zeile erzwingen können Sie mit der Tastenkombination 'Umschalt'+'Eingabe'.

Zahlungen
Dieser Reiter bietet eine alternative Möglichkeit zur Eingabe von Zahlungsaufträgen zum betreffenden Gegenkonto.

History
Hier sehen Sie die bereits erledigten Zahlungsaufträge dieses Gegenkontos, die auch wieder reaktiviert oder gelöscht werden können.

Dokumente
Hier ist es Ihnen möglich, dem Gegenkonto Dokumente jeglichen Typs zuzuordnen und diese direkt von ezBank 2.5.5 aus aufrufen und anzeigen zu lassen. Zudem können Sie hier direkt Word-Dokumente zum Gegenkonto erstellen, um zum Beispiel einen Brief an die Person zu schreiben.
Eine genaue Beschreibung zur Dokumentfunktion und alle Möglichkeiten dazu finden Sie im Kapitel Die Dokumentfunktion (Reiter 'Dokumente').


ezBank 2.5.5 - Zahlungsauftrag eingeben

Zahlungsauftrag eingeben

ezBank 2.5.5 bietet Ihnen mehrere Möglichkeiten für das Eingeben oder Ändern von Zahlungsaufträgen: einmal über das Hauptmenü "Zahlungen" mit "Neu" oder aus dem Startmenü bzw. der Toolbar, zum andern direkt über die Liste der Zahlungen. Zur Arbeitsunterstützung werden Ihnen für das Eingeben bzw. Ändern von Zahlungsaufträgen verschiedene Hilfsmittel angeboten, die im folgenden beschrieben sind.

Details zur Zahlung ...

::: Felder und Funktionen :::

::: Reiter :::


ezBank 2.5.5 - Felder und Funktionen

Felder und Funktionen

Die Pflichtfelder
Beim Anlegen eines neuen Zahlungsauftrags müssen der Empfänger mit Kontonummer und BLZ sowie der Betrag und das Auftraggeber-Konto in jedem Fall ausgefüllt werden.
Empfohlen wird allerdings unbedingt auch die Eingabe eines Verwendungszwecks.

Funktionen / Besonderheiten

SEPA:
Mit einem Häkchen im Feld 'SEPA' bestimmen Sie, ob dieser Zahlungsauftrag ein SEPA-Zahlungsauftrag ist oder wie bisher DTAUS. Dementsprechend ändert sich dann das Formular in der Farbe wie auch die Eingabefelder.

Kontonummernprüfung:
Ist die Kontonummer und BLZ eingegeben, dann wird geprüft, ob diese Kontonummer für die eingegebene BLZ gültig ist. Wenn festgestellt wird, dass die Kontonummer laut Prüfverfahren ungültig ist, dann wird dies an einem roten X in der Symbol-Schaltfläche neben der BLZ angezeigt. Eine gültige Kontonummer wird durch ein grünes Häkchen angezeigt.

Dauerauftrag:
Einen Zahlungsauftrag als Dauerauftrag einrichten können Sie sehr einfach unter dem Reiter "Weitere Details".


ezBank 2.5.5 - Reiter

Reiter

Zahlung (Details)
Hier geben Sie alle notwendigen Daten zur Erfassung eines Zahlungsauftrages ein, wie Sie es von den üblichen Überweisungsträgern der Banken her kennen.

Weitere Details (Dauerauftrag und Zusatzfelder)
Hier können Sie aus dem Zahlungsauftrag einen Dauerauftrag machen.
Falls Ihnen weitere Eingabefelder für die Zahlungsaufträge fehlen, bietet Ihnen ezBank 2.5.5 eine komfortable Möglichkeit selbst Eingabefelder anzulegen. Diese Funktion finden Sie im Hauptmenüpunkt "Einstellungen" unter "Zusatzfelder Zahlungen" (siehe Lektion Die Zusatzfelder im Kapitel Einstellungen).

Memo
Hier können Sie einen beliebigen Fließtext eingeben, um z.B. irgendwelche Informationen zum Zahlungsauftrag oder besondere Notizen zu hinterlegen.

Dokumente
Hier ist es Ihnen möglich, dem Zahlungsauftrag Dokumente jeglichen Typs zuzuordnen und diese direkt von ezBank 2.5.5 aus aufrufen und anzeigen zu lassen.


ezBank 2.5.5 - Die Zahlungsliste

Die Zahlungsliste

Hier werden die Zahlungsaufträge in einer übersichtlichen Liste aufgelistet. Aus dieser Liste können neue Zahlungsaufträge angelegt, Zahlungsdaten geändert und Zahlungsaufträge wieder gelöscht werden.

Liste der Zahlungen

Geben Sie einfach einen Buchstaben ein, dann wird automatisch zum ersten Zahlungsauftrag gesprungen, dessen Suchbegriff mit diesem Buchstaben beginnt. Bei Eingabe weiterer Buchstaben wird entsprechend weiter gesucht.

Eine allgemeine Beschreibung zur Bedienung von Listen in ezBank finden Sie im Kapitel Listenbedienung.


ezBank 2.5.5 - Bankdatei erstellen (SEPA oder DTAUS)

Bankdatei erstellen (SEPA oder DTAUS)

Nachdem Sie alle gewünschten Stammdaten (Ihre eigenen Konten, die Gegenkonten, die Banken und Orte) erfasst haben, können Sie mit der Eingabe der Zahlungsanweisungen beginnen.

Und sobald alle Zahlungen eingegeben sind, können Sie mit der Erstellung der SEPA- oder DTAUS-Datei für die Bank beginnen. Für diese SEPA- oder DTAUS-Datei liefert Ihnen das Programm ezBank drei wichtige Dinge:

  1. eine Datei mit den Daten der von Ihnen erfassten und ausgewählten Zahlungen (Überweisungen bzw. Einziehungen) in einem für Ihre Bank lesbaren Format (SEPA- bzw. DTAUS-Datei).
  2. einen Kontoauszug als Exceltabelle mit den verarbeiteten Zahlungsaufträgen als Beleg für Ihre Unterlagen.
  3. einen Begleitzettel zur SEPA- bzw. DTAUS-Datei.
Das alles erfolgt automatisch bei der Erstellung der SEPA- bzw. DTAUS-Datei. Sie müssen nur die gewünschten Zahlungen auswählen (markieren) und dann die Erstellung der SEPA- bzw. DTAUS-Datei starten. Das geschieht mit 'SEPA-Datei' oder F7 bzw. mit 'DTAUS-Datei' oder F8 unter dem Menü 'Zahlungen'.

::: Auswahl von Konto und Auftragsart :::

::: Auswahl der Zahlungsaufträge :::


ezBank 2.5.5 - Auswahl von Konto und Auftragsart

Auswahl von Konto und Auftragsart

Haben Sie mehr als ein eigenes Konto angelegt, dann müssen Sie zuerst das Konto wählen, für welches nun die SEPA- oder DTAUS-Datei erstellt werden soll.

Bankverbindung auswählen

Haben Sie nur ein Konto bzw. nach Auswahl des gewünschten Kontos erscheint ein Dialog zur Auswahl der Auftragsart:

SEPA-Datei für ...

Hier wählen Sie, ob die SEPA- bzw. DTAUS-Datei für Überweisungen oder Einziehungen erstellt werden soll. Außerdem können Sie hier ein späteres Ausführungsdatum festlegen.


ezBank 2.5.5 - Auswahl der Zahlungsaufträge

Auswahl der Zahlungsaufträge

Nach Auswahl des Kontos und der Auftragsart erscheint die Liste mit den fälligen Zahlungsaufträgen für das gewählte Konto mit der entsprechenden Auftragsart. Dazu ein kleiner Dialog mit Auswahlmöglichkeiten:

SEPA-Datei erstellen

Nach Bestätigung der Auswahl wird die SEPA- bzw. DTAUS-Datei erstellt, gleichzeitig der Kontoauszug als Exceltabelle erstellt und in Excel angezeigt, und der Begleitzettel erstellt und in einer Druckvorschau zum Drucken angezeigt.


ezBank 2.5.5 - Importieren von Daten

Importieren von Daten

Sie können bestehende Konten, Gegenkonten und Zahlungsaufträge aus einer anderen Access-Datenbank, Excel-Tabelle, dBase-Datenbank oder einer Textdatei (mit Semikolon getrennt) nach ezBank importieren. Der Import aus Access, Excel und dBase erlaubt dabei eine beliebige Feld-Zuordnung, beim Import aus einer Textdatei müssen in der Textdatei die Felder angegeben werden.

::: Datenimport aus Access, Excel oder dBase :::

::: Datenimport aus einer Textdatei :::


ezBank 2.5.5 - Datenimport aus Access, Excel oder dBase

Datenimport aus Access, Excel oder dBase

Beim Importieren von Konten, Gegenkonten oder Zahlungsaufträge aus Access, Excel oder dBase wählen Sie zuerst die gewünschte Import-Datenbank und dann die darin enthaltene Tabelle mit den zu importierenden Datensätzen. Dabei werden die in der Tabelle zur Verfügung stehenden Felder in der linken Felderliste angezeigt.
In der rechten Felderliste sehen Sie bereits die Zieltabelle ('KONTEN', 'GEGENKONTEN' oder 'ZAHLUNGEN') mit den entsprechenden Feldern der jeweiligen Tabelle.

Als Beispiel werden eine Access-Datenbank 'Testadressen.mdb', eine Excel-Tabelle 'Testadressen.xls' und eine dBase-Datenbank 'ADRESSEN.DBF' mitgeliefert.

Import aus Access

Das Wichtigste nun ist die Zuordnung der einzelnen Felder aus Ihrer Import-Tabelle zu jeweils einem Feld der Ziel-Tabelle ('KONTEN', 'GEGENKONTEN' oder 'ZAHLUNGEN'). Damit legen Sie zum einen fest, welche Felder überhaupt, und in welche Felder der Ziel-Tabelle Ihre Daten importiert werden.
Diese Zuordnung geht sehr einfach durch Markieren der beiden Felder und Klick auf die Schaltfläche > oder einem Doppelklick auf eines der beiden Felder. Zur Vereinfachung wird beim Markieren eines Feldes der Import-Tabelle sofort auch ein Feld mit diesem Namen in der Ziel-Tabelle markiert, sofern es ein solches Feld dort gibt.
Möchten Sie eine Zuordnung rückgängig machen, dann genügt ein Doppelklick auf den entsprechenden Eintrag in der Liste mit den Feld-Zuordnungen oder Markieren des Eintrags und Klick auf die Schaltfläche < .

Mit Klick auf die Schaltfläche OK wird der Import dann durchgeführt.


ezBank 2.5.5 - Datenimport aus einer Textdatei

Datenimport aus einer Textdatei

Zum Import aus einer Textdatei gibt es zwei Möglichkeiten:
  1. Der Import eines einzelnen Datensatzes:
    Dabei stehen die Felder mit Feldnamen und Inhalt untereinander in der Textdatei, jeweils in einer eigenen Zeile, Feldnamen und Inhalt durch Doppelpunkt getrennt. Als Beispiel dazu wird eine Datei 'schuster.txt' mitgeliefert, geeignet zum Import als Konto oder als Gegenkonto.

  2. Der Import mehrerer Datensätze:
    Dabei stehen in der ersten Zeile die Feldnamen mit Semikolon ';' getrennt, angeführt mit der Kennzeichnung 'FELDER:'. In allen weiteren Zeilen stehen dann die Daten, die einzelnen Felder wieder mit Semikolon getrennt, und natürlich in der Reihenfolge wie in der ersten Zeile angegeben. Als Beispiel dazu wird eine Datei 'Testadressen.txt' mitgeliefert, ebenfalls geeignet zum Import als Konto oder als Gegenkonto.


ezBank 2.5.5 - Merklisten

Merklisten

Merklisten sind Listen, die man selbst aus den eingegebenen Zahlungen willkürlich zusammenstellen kann. Dies bedeutet, dass Sie bestimmte Zahlungen einer oder mehreren Merklisten zuordnen können. Dabei bleiben die Zahlungen natürlich in der Zahlungsübersicht stehen. Die Merklisten zeigen diese lediglich nur an. Auf diese Weise können Sie ungestört und unabhängig von ihrem Datenbestand in Ihren Merklisten arbeiten.

Merklisten sind vor allem für eine zeitlich begrenzte Existenz konzipiert und können bestimmte Arbeitsabläufe unterstützen. So können Sie sich zum Beispiel alle Zahlungen merken, die Sie noch in der aktuellen Woche bearbeiten möchten. Haben Sie eine Zahlung erledigt löschen Sie die Adresse einfach wieder aus der Merkliste. Mit der letzten Zahlung, die Sie aus der Merkliste löschen, hört die Merkliste automatisch auf zu existieren.

Merklisten finden Sie unter dem Hauptmenüpunkt "Zahlungen". Von dort aus können Sie Ihre bereits erstellten Merklisten aufrufen und abarbeiten.

::: Zahlungen einer Merkliste zuordnen :::


ezBank 2.5.5 - Zahlungen einer Merkliste zuordnen

Zahlungen einer Merkliste zuordnen

Um Zahlungen einer neuen oder bereits bestehenden Merkliste zuzuordnen gehen Sie wie folgt vor:

Zahlungen einer bereits bestehenden Merkliste zuordnen

  1. Öffnen Sie die Zahlungsübersicht und markieren eine oder mehrere Zahlungen, die Sie sich merken möchten.
  2. Klicken Sie dann auf den Hauptmenüpunkt "Bearbeiten" oder mit der RECHTEN Maustaste in die Liste hinein. Es öffnen sich in beiden Fällen ein Menü, in dem Sie die Funktion "Merken" wählen können.
  3. Klicken Sie auf die Funktion "Merken". Es öffnet sich das Fenster "Merklisten".
  4. Mit einem Doppelklick auf eine bereits bestehende Merkliste oder markieren der Merkliste und Klick auf die Schaltfläche Hinzufügen werden die markierten Zahlungen zu dieser bestehenden Merkliste hinzugefügt.
  5. Die aktualisierte Merkliste wird nun angezeigt.

Zahlungen einer neuen Merkliste zuordnen

  1. Öffnen Sie die Zahlungsübersicht und markieren eine oder mehrere Zahlungen, die Sie sich merken möchten.
  2. Klicken Sie dann auf den Hauptmenüpunkt "Bearbeiten" oder mit der RECHTEN Maustaste in die Liste hinein. Es öffnen sich in beiden Fällen ein Menü, in dem Sie die Funktion "Merken" wählen können.
  3. Klicken Sie auf die Funktion "Merken". Es öffnet sich das Fenster "Merklisten".
  4. Klicken Sie nun auf die Schaltfläche Neue Liste. Es öffnet sich das Fenster "Neue Merkliste". In das Eingabefeld des Fenster "Neue Merkliste" können Sie nun eine passende Bezeichnung für die neue Merkliste eingeben. Bestätigen Sie dann Ihre Eingabe mit Klick auf die Schaltfläche OK.
  5. Die neue Merkliste wird nun angezeigt. Später können Sie diese über den Hauptmenüpunkt "Zahlungen" - "Merklisten" jederzeit wieder aufrufen.


ezBank 2.5.5 - Eigene Listen

Eigene Listen

"Eigene Listen" sind Listen, die Sie aus den in ezBank 2.5.5 enthaltenen Tabellen und den darin verfügbaren Feldern selbst zusammenstellen können. Dies bedeutet beispielsweise, dass Sie eine eigene Zahlungsübersicht mit allen für Ihre Arbeit relevanten Zahlungsdaten definieren können.

"Eigene Listen" ist eine Funktion, die über SQL-Abfragen bedient wird. Für das Erzeugen einfacher SQL-Abfragen steht eine unterstützende Eingabemaske zur Verfügung. Falls Sie sich jedoch in SQL-Abfragen auskennen, können Sie die Abfrage direkt in das SQL-Feld der Eingabemaske schreiben.

Eigene Listen werden automatisch gepflegt. Sobald Sie also eine neue Zahlung anlegen bzw. ändern, und diese den Bedingungen einer bestimmten eigenen Liste entspricht, so wird diese automatisch in diese eigene Liste übernommen. Falls Sie also beispielsweise eine eigene Liste angelegt haben, die alle Rücklastschriften anzeigt, so werden Zahlungen automatisch zu dieser Liste hinzugefügt wenn die Zahlungsnotiz den Begriff "Rücklastschrift" enthält bzw. werden aus dieser Liste wieder entfernt, wenn die Zahlungsnotiz diesen Begriff NICHT mehr enthält.

Die eigenen Listen finden Sie nach ihrer Erstellung unter dem Hauptmenüpunkt "Zahlungen" in der Funktion "Eigene Listen".

::: Eine eigene Liste erstellen :::


ezBank 2.5.5 - Eine eigene Liste erstellen

Eine eigene Liste erstellen

Das Erstellen einer eigenen Liste wird hier an einem Beispiel erklärt:
Es soll eine Zahlungsübersicht nur mit Rücklastschriften erstellt werden. Rücklastschriften sind dadurch gekennzeichnet, dass in der Kurznotiz einer Zahlung der Begriff "Rücklastschrift" eingetragen wird. Dabei sollen folgende Felder angezeigt werden: Kontonummer und Name des Gegenkontos, Fälligkeitsdatum, Betrag und Verwendungszweck.

So geht das:

  1. Die eigenen Listen finden Sie im Hauptmenü "Zahlungen" im Menüpunkt "Eigene Listen" als Untermenüpunkt "Alle Listendefinitionen". Es öffnet sich das Fenster "Listendefinitionen".
  2. Im Fenster "Listendefinitionen" klicken Sie auf die Schaltfläche Neu. Sie kopieren nicht und es öffnet sich das Fenster "Neue Listendefinition".
  3. Im Fenster "Neue Listendefinition" geben Sie in das Feld "Bezeichnung" eine passende Bezeichnung ein. Für unser Beispiel würde die einfache Bezeichnung "Rücklastschriften" gut passen.
  4. Dann wählen Sie im Feld "Haupttabelle" die Tabelle "ZAHLUNGEN" aus. Es ist sinnvoll die Zahlungen nach dem Gegenkonto zu sortieren. Deshalb wählen Sie "NAME2" in das Feld "sortieren nach".
  5. Nun wählen Sie die gewünschten Felder der Liste aus. Dazu markieren Sie das entsprechende Feld im Feld "Felder - verfügbar" und transferieren es per Klick auf die Schaltfläche '>' in das Feld "Gewählte Felder". Für unsere Beispielliste sind das die Felder "KONTO2" und "NAME2" (für Kontonummer und Name des Gegenkontos), "FAELLIG" (für das Fälligkeitsdatum), "BETRAG" (für den Betrag), sowie "VERWENDUNG1" (für die erste Zeile des Verwendungszwecks).
  6. Jetzt wird die Filterabfrage gesetzt. Es sollen ja nur Rücklastschriften angezeigt werden. Dies erreichen Sie, indem Sie in das Feld "Filterbedingung" folgende Filterabfrage schreiben: NOTIZ LIKE "Rücklastschrift". Mehr dazu finden Sie unter "Filtermöglichkeiten"
  7. Nun können Sie überprüfen, ob die Liste richtig definiert wurde. Klicken Sie dazu auf die Schaltfläche Prüfen. Wenn alles stimmt, bestätigen Sie Ihre Eingaben mit Klick auf die Schaltfläche OK des Fensters "Listendefinitionen".
Hinweis: Zum Bearbeiten eines Datensatzes aus einer eigenen Liste wird der Schlüssel dazu benötigt. Dann wählen Sie zusätzlich zu den gewünschten Feldern das Schlüsselfeld aus. Das ist das Feld "GKEY" bei Gegenkonten und "ZKEY" bei Zahlungen.


ezBank 2.5.5 - CTI-Telefonie über TAPI oder VoIP

CTI-Telefonie über TAPI oder VoIP

Über eine CTI-Verbindung kann direkt aus ezBank 2.5.5 heraus telefoniert werden. Damit wird die Telefonnummer direkt an das Telefon übergeben, so dass direkt von ezBank aus eine Telefonnummer gewählt werden kann. Zum direkten Telefonieren klicken Sie dann einfach nur auf die Pfeil-Schaltfläche Pfeil hinter dem Feld "Telefon-Nr." bzw. "Mobil/Auto".

Die Voraussetzung für die Anwahl über eine CTI-Verbindung ist entweder eine TAPI-Schnittstelle mit einem TAPI-fähigen Telefon oder Telefonanlage (Beispiel: Gigaset oder Auerswald).
Oder VoIP über einen VoIP-Anbieter und ein SIP-Softphone zur Verbindung mit dem Computer.

Zu TAPI: Die beste Kontrolle, ob die Anwahl über TAPI funktioniert, ist die Windows Wählhilfe. Funktioniert diese, dann klappt auch die Anwahl über TAPI. Die Einstellungen können Sie über Menü "Einstellungen" - "Optionen" vornehmen. Dazu klicken Sie im Fenster "Optionen" auf den Reiter "Kommunikation". Um den richtigen TAPI-Treiber zu wählen klicken Sie einfach auf "Einstellungen" - "TAPI-Eigenschaften".

Technische Erläuterung

Zuerst einmal etwas Hintergundwissen, eine kleine technische Erläuterung: wie funktioniert die Telefonie über VoIP im Vergleich zu TAPI und dem herkömmlichen Festnetz:
Im Prinzip wird immer dasselbe benötigt:

  1. einen Telefonanbieter, der die Rufnummer zur Verfügung stellt und die Abrechnungen macht
  2. eine Verbindung von einem Router oder Endgerät zu diesem Anbieter
  3. das Endgerät zum Telefonieren

Beim Festnetz ist das bekanntermaßen so:

  1. der Anbieter ist zum Beispiel die Telekom oder Vodafone oder Swisscom
  2. der Telefonanschluss muss freigeschaltet sein
  3. ein normales Telefon oder auch Telefonanlage wird angeschlossen

Mit CTI (computerunterstützte Telefonie) kommt noch ein 4. Punkt dazu, die Verbindung zum Computer.

Bei TAPI sieht das so aus:

  1. der Anbieter ist unverändert zum Beispiel die Telekom oder Vodafone oder Swisscom
  2. der Telefonanschluss muss freigeschaltet sein
  3. ein TAPI-fähiges Telefon (z.B. Gigaset mit QuickSync) oder auch eine Telefonanlage (z.B. Auerswald) wird angeschlossen
  4. die Verbindung zum Computer läuft über die TAPI-Schnittstelle, dann kann am Computer telefoniert werden

Bei VoIP sieht das nun ein bisschen anders aus:

  1. der Anbieter der VoIP-Telefonie kann der Festnetz-Anbieter sein (muss man erfragen) oder ein eigener VoIP-Anbieter, wie z.B. https://www.sipgate.de/ oder https://www.easybell.de/voip-anbieter/ oder https://www.netvoip.ch/ oder https://www.phonestar.ch/ oder https://www.sipcall.ch/
  2. Voice over IP basiert auf dem sogenannten SIP-Protokoll (Session Initiation Protocol), über das Anrufe aufgebaut und verwaltet werden. Man benötigt also einen SIP-Anbieter wie gerade beschrieben: der Festnetz-Anbieter oder ein spezialisierter VoIP-Anbieter.
  3. das Gerät zum Telefonieren kann nun ein Headset sein oder ein Notebook mit Mikrofon und Lautsprecher oder auch ein Handy
  4. die Verbindung zum Computer läuft über ein sogenanntes SoftPhone wie PhonerLite oder Zoiper, dann kann am Computer telefoniert werden


ezBank 2.5.5 - DWA - Wirtschaftsauskunft

DWA - Wirtschaftsauskunft

Die Firma DWA Wirtschaftsauskunft GmbH verkauft Wirtschaftsinformationen über Gewerbetreibende und Privatpersonen, welche die Firmen Dun & Bradstreet Deutschland GmbH, Bürgel Wirtschaftsinformationen GmbH & Co. KG, und SolvenTec GmbH, erstellen.

ezBank 2.5.5 bietet eine Schnittstelle zum DWA-Internetportal. Die Preise des DWA-Service finden Sie auf der Internetseite von DWA. Um auf jene zu gelangen, klicken Sie im Fenster "DWA-Anmeldung" auf das DWA-Logo links oben. Auf der Internetseite können Sie sich dann als ezBank 2.5.5-Kunde registrieren lassen. Sie erhalten dann eine Kundennummer, Benutzername und Passwort. Damit können Sie sich in Zukunft von ezBank 2.5.5 aus für einen DWA-Service anmelden.


ezBank 2.5.5 - Tastaturbedienung - Übersicht der 'Hotkeys'

Tastaturbedienung - Übersicht der 'Hotkeys'

In diesem Kapitel finden Sie eine Tabelle mit den sogenannten 'Hotkeys' zur Tastaturbedienung von ezBank.

Hotkey | entsprechender Menübefehl | Bedeutung
Strg+N | Datei - Neu | Legt eine neue Kartei (ezBank-Datenbasis) an
Strg+O | Datei - Öffnen | Öffnet eine bestehende Kartei
Strg+P | Datei - Drucken | Öffnet zum Drucken eine Auswahlliste mit allen definierten Drucklisten
F3 | Datei - Programm beenden | Schliesst alle offenen Fenster und beendet die Anwendung ezBank Besonderheit: Bei Einstellungen - Eigenschaften kann festgelegt werden, ob vor dem tatsächlichen Beenden von ezBank eine Bestätigungsabfrage erscheint oder nicht.
Strg+X | Bearbeiten - Ausschneiden | Im Eingabefeld: schneidet den markierten Feldinhalt in die Zwischenablage (windowsüblich) In einer Liste: löscht den markierten Datensatz (entspricht der Schaltfläche 'Löschen')
Strg+C | Bearbeiten - Kopieren | Im Eingabefeld: kopiert den markierten Feldinhalt in die Zwischenablage (windowsüblich) In einer Liste: kopiert den markierten Datensatz in die ezBank-Zwischenablage und erlaubt eine Kopie
Strg+V | Bearbeiten - Einfügen | Im Eingabefeld: fügt den Feldinhalt aus der Zwischenablage in das Feld ein (windowsüblich) In einer Liste: erlaubt das Einfügen eines in die ezBank-Zwischenablage kopierten Datensatzes (wenn vorhanden) bzw. fügt einen neuen Datensatz ein (entspricht dann der Schaltfläche 'Neueingabe')
Strg+F | Bearbeiten - Filtern | Nur in einer Liste aktiv: Öffnet die Filterliste zum Setzen eines Filters in der Liste
Strg+M | Bearbeiten - Merken | Sonderfunktion - nicht in jeder Liste aktiv: Ermöglicht das Merken der markierten Datensätze in einer Merkliste zum späteren Abarbeiten
F4 | Zahlungen - Neu | Legt eine neue Zahlung an
Strg+Z | Zahlungen - offene Überweisungen | Zeigt alle offenen Überweisungen in einer komfortablen Liste an
Strg+L | Zahlungen - offene Lastschriften | Zeigt alle offenen Lastschriften in einer komfortablen Liste an
F7 | Zahlungen - SEPA-Datei | Erstellt eine SEPA-Datei für eine auswählbare Bankverbindung und Auftragsart (Überweisungen oder Basis- oder Firmen-Lastschriften)
F8 | Zahlungen - DTAUS-Datei | Erstellt die DTAUS-Datei für eine auswählbare Bankverbindung und Auftragsart
Strg+K | Zahlungen - Konten - Liste | Zeigt alle eingegebenen Konten in einer komfortablen Liste an
Strg+G | Zahlungen - Gegenkonten - Liste | Zeigt alle eingegebenen Gegenkonten in einer komfortablen Liste an
F12 | Fenster - Startmenü anzeigen | Öffnet das Startmenü bzw. holt es immer in den Vordergrund
UmschaltStrg+F6 | Fenster - Vorwärts | Geht zum nächsten geöffneten Fenster und holt es in den Vordergrund
Strg+F6 | Fenster - Rückwärts | Geht zum vorherigen geöffneten Fenster und holt es wieder in den Vordergrund
F1 | Hilfe - Hilfethemen | Öffnet die Online-Hilfe zu ezBank
Strg+A | - | Markiert alle Datensätze der aktuell geöffneten Liste (windowsüblich)
F5 | - | Aktualisiert die Anzeige der aktuell geöffneten Liste (windowsüblich)
Strg+F4 oder Esc | - | Schliesst das gerade aktive Fenster (windowsüblich)
+/- | - | Nur in Datumsfeldern: Zählt das Datum jeweils um einen Tag hoch bzw. runter.
Strg+/Strg- | - | Nur in Datumsfeldern: Zählt das Datum jeweils um einen Monat hoch bzw. runter.
# | - | Nur in Datumsfeldern: Füllt das Datumsfeld mit dem aktuellen Datum.


ezBank 2.5.5 - Dokumente/Briefe/E-Mails

Dokumente/Briefe/E-Mails

ezBank 2.5.5 ermöglicht es Ihnen, zu den wichtigsten ezBank-Datentypen (z.B. Gegenkonten, Konten, Zahlungsaufträge), beliebige Dateien, Word-Dokumente und Bilder zu hinterlegen. Auch die Terminverwaltung ist mit der Dokumentfunktion ausgestattet. Dabei können Sie bereits bestehende Dokumente (beliebige Dateien) aus einer Liste wählen oder auch aus dem Explorer per Drag/Drop zuordnen.
Zudem können Sie ein neues Dokument direkt über Word oder einer RTF-fähigen Textverarbeitung aus einer der mitgelieferten Vorlagen erstellen oder auch mit einem Scanner oder Digitalkamera direkt in ezBank einscannen.

Die Dokumentfunktion (Reiter 'Dokumente')

Ändern einer Dokument-Vorlage

Serienbriefe über den Export

Serienbriefe über eine RTF-Textverarbeitung

E-Mail versenden

Weiter zum Kapitel Filtern/Drucken/Berichte ...


ezBank 2.5.5 - Die Dokumentfunktion (Reiter 'Dokumente')

Die Dokumentfunktion (Reiter 'Dokumente')

Über die Dokumentfunktion haben Sie die Möglichkeit, zu den wichtigsten ezBank-Datentypen (z.B. Gegenkonten, Konten, Zahlungsaufträge), beliebige Dateien, Word-Dokumente und Bilder zu hinterlegen. Dabei können Sie bereits bestehende Dokumente (beliebige Dateien) aus einer Liste wählen oder auch aus dem Explorer per Drag/Drop zuordnen.
Zudem können Sie ein neues Dokument direkt über Word oder einer RTF-fähigen Textverarbeitung aus einer der mitgelieferten Vorlagen erstellen oder auch mit einem Scanner oder Digitalkamera direkt in ezBank einscannen.

Die Dokumentfunktion finden Sie jeweils als Reiter "Dokumente" im Fenster "Eigenschaften" eines jeden ezBank-Datentyps (z.B. Gegenkonten, Konten, Zahlungsaufträge). Zu jedem Datensatz können Sie eine eigene Dokumentenliste anlegen und pflegen.

Folgende Möglichkeiten bietet ihnen ezBank in der Dokumentfunktion, abhängig davon, ob ein neues Dokument erstellt bzw. zugeordnet werden soll (die Schaltfläche Neueingabe), oder ob Sie ein bereits bestehendes Dokument aus der Dokumentenliste ausgewählt haben (die Schaltfläche Details/Ändern).

Neues Dokument

::: Ein bereits bestehendes Dokument auswählen und zuordnen :::

::: Ein bestehendes Dokument per Drag/Drop zuordnen :::

::: Scannen eines Dokuments :::

::: Ein neues Dokument (Word/RTF) aus einer Vorlage erstellen :::

::: Das aktuelle Dokument mit der Standard-Anwendung öffnen :::

::: Übernehmen der Dokumente in den Dokumente-Reiter :::


ezBank 2.5.5 - Ein bereits bestehendes Dokument auswählen und zuordnen

Ein bereits bestehendes Dokument auswählen und zuordnen

Mit einem Klick auf die Schaltfläche Dateien zuordnen... öffnet sich das Fenster "Dokument wählen" mit allen Verzeichnissen/Ordnern, die hier nach der gewünschten Datei durchsucht werden können. Der bei "Einstellungen" - "Optionen" im Reiter "Ordner" festgelegte Dokumente-Ordner - siehe Lektion Ordner-Definitionen im Kapitel Einstellungen - wird dabei zuerst angezeigt, kann hier aber jederzeit geändert werden.
Haben Sie das Dokument gefunden, welches in der Dokumentenliste zum aktuell markierten Datensatz eingetragen werden soll, dann markieren Sie die Datei mit der Maus und bestätigen die Datei mit Klick auf die Schaltfläche Öffnen im Fenster "Dokument wählen".

Sie können nun auch weitere Dokumente auswählen und zuordnen. Alle so gewählten Dokumente werden zuerst in die Dateiliste des Fensters "Neues Dokument" eingetragen. Erst beim abschließenden Bestätigen der kompletten Liste mit OK werden alle in der Dateiliste befindlichen Dokumente dann auch in den Dokumente-Reiter übernommen.

Alternativ dazu können Sie Dokumente auch einfach per Drag/Drop zuordnen, indem Sie die gewünschten Dateien im Explorer markieren und einfach in die Dateiliste oder irgendwo im Fenster "Neues Dokument" ziehen und loslassen.


ezBank 2.5.5 - Ein bestehendes Dokument per Drag/Drop zuordnen

Ein bestehendes Dokument per Drag/Drop zuordnen

Es gibt mehrere Möglichkeiten, bereits bestehende Dateien schnell und komfortabel mittels Drag/Drop in die Dokumentenliste eines Dokumente-Reiters einzutragen.
  • Eine oder mehrere Dateien in die Dateiliste oder irgendwo im Fenster "Neues Dokument" ziehen und loslassen. Das entspricht exakt dem Zuordnen der Dokumente über die Schaltfläche Dateien zuordnen.... Die Dokumente werden also zuerst nur in die Dateiliste des Fensters "Neues Dokument" eingetragen und erst beim abschließenden Bestätigen mit OK werden alle in der Dateiliste befindlichen Dokumente in den Dokumente-Reiter übernommen.
  • Eine einzelne Datei auf die Schaltfläche Neueingabe unterhalb der Dokumentenliste des Dokumente-Reiters ziehen und loslassen. Dabei öffnet sich dann der Dialog "Neues Dokument" mit dieser Datei in der Dateiliste. Nun kann das Fenster "Neues Dokument" mit allen Möglichkeiten ganz normal verwendet werden.
  • Mehrere Dateien auf die Schaltfläche Neueingabe unterhalb der Dokumentenliste des Dokumente-Reiters ziehen und loslassen. Dabei werden dann alle Dateien auf einmal sofort in die Dokumentenliste eingetragen, OHNE dass zuvor der Dialog "Neues Dokument" erscheint. Dies ist also der schnellste Weg, allerdings ohne die weiteren Möglichkeiten des Dialogs "Neues Dokument" (Zuordnen von Kategorie, Beschreibung usw).

So geht das:

  1. Öffnen Sie in ezBank diejenige Dokumentenliste, in der Sie die Dokumente eingetragen haben möchten. Die Dokumentenlisten finden Sie als Reiter "Dokumente" im Fenster "Eigenschaften" eines Datensatzes. Je nachdem, welche der Möglichkeiten Sie nutzen möchten bleiben Sie im Dokumente-Reiter oder öffnen den Dialog "Neues Dokument".
  2. Starten Sie das Programm auf Ihrem Rechner, das Dateien anzeigt und die Drag/Drop-Funktion ebenfalls unterstützt. Das kann zum Beispiel der bei Windows mitgelieferte Windows Explorer sein.
  3. Öffnen Sie das Verzeichnis, in dem sich das Dokument oder die Dokumente befinden, die Sie in ezBank zugeordnet haben möchten. Markieren Sie die gewünschten Dateien, klicken Sie dann ohne loszulassen mit der linken Maustaste auf die Markierung und ziehen Sie die Dateien am Mauszeiger auf die Programm-Schaltfläche von ezBank in der Taskleiste (Leiste, in der auch die Uhrzeit angezeigt wird). Halten Sie dabei die linke Maustaste stets gedrückt. Nun wird ezBank automatisch maximiert und wieder im Vordergrund angezeigt.
  4. Je nachdem, welche der Möglichkeiten Sie nutzen, ziehen Sie die Markierung mit den Dateinamen irgendwo auf das Fenster "Neues Dokument" oder auf die Schaltfläche Neueingabe unterhalb der Dokumentenliste. Dort können Sie die linke Maustaste loslassen und die Dateien werden zugeordnet.


ezBank 2.5.5 - Scannen eines Dokuments

Scannen eines Dokuments

So geht das:
  1. Zum Scannen eines Dokuments klicken Sie auf die Schaltfläche Dokumente scannen.... Es öffnet sich das Fenster "Scannen von Dokumenten".
  2. Wählen Sie bei 'Gerät' den gewünschten Scanner oder Digitalkamera. Dabei werden abhängig vom Gerät die möglichen Einstellungen in die Auswahllisten und die anderen Kontrollfelder eingetragen.
  3. Überprüfen Sie nun, ob die Einstellungen zu Bildformat, Auflösung, Farbe und Einzugsverfahren Ihren Vorstellungen entsprechen. Sie können vor dem Scannen die Einstellungen ändern.
  4. Lösen Sie den Scan-Vorgang durch Klicken auf die Schaltfläche Scannen aus. Haben Sie "Scanner-Dialog" aktiviert, dann wird zum Scannen die zu Ihrem Scanner gehörende Anwendung gestartet und verwendet. Hier können Sie gegebenenfalls weitere Einstellungen zum Scan-Vorgang vornehmen.
Sie können nun weitere Dokumente einscannen oder auch andere bereits bestehende Dokument zuordnen. Alle Dokumente werden zuerst in die Dateiliste des Fensters "Neues Dokument" eingetragen. Erst beim abschließenden Bestätigen der kompletten Liste mit OK werden alle in der Dateiliste befindlichen Dokumente dann auch in den Dokumente-Reiter übernommen.


ezBank 2.5.5 - Ein neues Dokument (Word/RTF) aus einer Vorlage erstellen

Ein neues Dokument (Word/RTF) aus einer Vorlage erstellen

ezBank liefert bereits einige hilfreiche Vorlagen, mit denen das Erstellen von Dokumenten über Word oder eine beliebige RTF-Textverarbeitung unterstützt wird. Je nachdem in welcher Rubrik Sie sich befinden, werden die entsprechenden Vorlagen angezeigt.

So geht das:

  1. Bevor Sie eine Vorlage benutzen sollten Sie alle geöffneten Worddateien schließen, also am besten Word komplett beenden.
  2. Klicken Sie im Fenster "Neues Dokument" auf die Schaltfläche mit dem Word-Symbol Word-Dokument erstellen.... Es öffnet sich das Fenster "Dokumentvorlage auswählen". In diesem Fenster stehen verschiedene Vorlagen zur Auswahl.
  3. Sie können als Dateityp zwischen "RTF-Textdatei (*.rtf)" und "Microsoft Word Vorlage (*.dot)" wählen. Je nach Wahl werden Ihnen die Word-Dokumentvorlagen oder alle RTF-Textdateien zur Auswahl angezeigt.
  4. Markieren Sie die gewünschte Vorlage in der Liste und klicken Sie auf die Schaltfläche Öffnen. Es öffnet sich das Fenster, mit dessen Hilfe Sie das Dokument abspeichern können.
  5. Wählen Sie das Speicherziel aus und verändern Sie ggf. den Dateinamen. Klicken Sie auf die Schaltfläche Speichern. Nun wird MS Word bzw. bei RTF die gewählte RTF-Textverarbeitung gestartet und die Variablen in der Vorlage automatisch ersetzt. Nun können Sie das so vorbereitete Dokument in der Textverarbeitung bearbeiten und ausdrucken.
  6. Durch Feld "Kategorie" können Sie das Dokument kategorisieren. Mit Hilfe der Kategorie können Sie dann Ihre Dokumente sortieren oder filtern.
  7. Durch das Feld "Typ" können Sie Ihr Dokument typisieren (durch die Angabe eines Dokumenttyps, z.B. Word-Datei). Typisieren Sie Ihr Dokument, wird diese nicht nur in der entsprechenden Dokumentenliste des Datensatzes angezeigt, sondern auch in der Korrespondenz-Liste.
  8. In ezBank ist noch das Fenster "Neues Dokument" geöffnet, eine Gelegenheit, um noch eine Bemerkung zum Dokument einzugeben. Den Dateinamen ändern Sie bitte jetzt nicht mehr. Bestätigen Sie Ihre Eingabe mit der Schaltfläche OK, um das zuvor erstellte Dokument mit der Bemerkung als Eintrag in der Dokumentenliste aufzunehmen.
Hinweis zu RTF: Sie haben die Möglichkeit, eine beliebige Textverarbeitung einzusetzen, die in der Lage ist, mit RTF-Textdateien umzugehen. Alternativ können Sie aber auch die mitgelieferte kleine RTF-Textverarbeitung einsetzen. Markieren Sie dazu bei 'Einstellungen' - 'Eigenschaften' die Auswahl 'RTF-Textverarbeitung bei .rtf' und schon wird beim Öffnen von RTF-Textdateien immer die eingebaute mitgelieferte kleine RTF-Textverarbeitung verwendet.


ezBank 2.5.5 - Das aktuelle Dokument mit der Standard-Anwendung öffnen

Das aktuelle Dokument mit der Standard-Anwendung öffnen

Mit einem Doppelklick auf einen Dateinamen in der Dateiliste oder einem Klick auf die kleine Symbol-Schaltfläche rechts neben der Dateiliste öffnet das in der Dateiliste aktuell markierte Dokument mit der Standard-Anwendung, die mit dieser Datei verknüpft ist.
Diese Funktion wird ebenfalls benutzt, wenn Sie direkt auf ein Dokument im Dokumente-Reiter einen Doppelklick machen, oder die Schaltfläche Starten unterhalb der Liste anklicken. Es ist also nicht notwendig, nur zum Aufrufen des Dokuments in das Dokument-Fenster zu gehen.

Hinweis: Welche Anwendung (Programm) zum Öffnen eines Dokuments verwendet wird hängt von Ihrem System ab:
In Windows wird jede Datei-Endung (z.B. .doc oder .html) mit einem bestimmten Programm verknüpft, welches dann verwendet wird, wenn eine solche Datei angezeigt, bearbeitet oder geöffnet werden soll. Das können Sie leicht selbst feststellen, indem Sie im Explorer auf eine bestimmte Datei doppelklicken: auf einer doc-Datei öffnet sich z.B. Microsoft Word, oder aber eine beliebige andere Textverarbeitung. Doppelklicken Sie auf eine html-Datei, dann sollte ein Web-Browser starten, z.B. der Internet-Explorer oder Netscape oder Opera, je nach Einstellung in Ihrem System.

So erstellen bzw. korrigieren Sie eine solche Verknüpfung:

  1. Öffnen Sie den Windows-Explorer.
  2. Gehen Sie in einen Ordner mit einer Datei mit der gewünschten Datei-Endung, z.B. eine html-Datei.
  3. Markieren Sie eine Datei durch einen einzelnen Mausklick auf diese.
  4. Halten Sie die Umschalttaste gedrückt und klicken Sie nun mit der RECHTEN Maustaste auf den markierten Dateinamen.
  5. Klicken Sie in dem erschienenen Menü auf den Eintrag 'Öffnen mit...'.
  6. Wählen Sie nun das Programm, mit dem eine Datei mit dieser Datei-Endung geöffnet werden soll, z.B. den Internet-Explorer (iexplore).
  7. Zur dauerhaften Verknüpfung setzen Sie das Häkchen bei: 'Diesen Dateityp immer mit diesem Programm öffnen'.
  8. Klicken Sie zur Bestätigung auf die Schaltfläche OK.
  9. Fertig. Ab jetzt startet beim Öffnen eines Dokuments mit dieser Datei-Endung immer das gewählte Programm.


ezBank 2.5.5 - Übernehmen der Dokumente in den Dokumente-Reiter

Übernehmen der Dokumente in den Dokumente-Reiter

Nun sind die gewünschten Dokumente, die im Dokumente-Reiter in die Dokumentenliste eingetragen werden sollen, in der Dateiliste des Dialogs "Neues Dokument" zu finden, egal ob manuell zugeordnet, ob per Drag/Drop eingefügt, ob eingescannt oder per Word erstellt. Erst mit einem abschließenden Klick auf die Schaltfläche OK des Fensters "Neues Dokument" werden alle in der Dateiliste befindlichen Dokumente in den Dokumente-Reiter übernommen. Dabei gibt es noch folgende Möglichkeiten:

Ein Dokument der Dateiliste öffnen
Mit einem Doppelklick auf einen Dateinamen in der Dateiliste oder einem Klick auf die kleine Symbol-Schaltfläche rechts neben der Dateiliste öffnet das in der Dateiliste aktuell markierte Dokument mit der Standard-Anwendung, die mit dieser Datei verknüpft ist.

Ein Dokument aus der Dateiliste löschen
Soll ein einzelnes Dokument doch nicht in die Dokumentenliste des Dokumente-Reiters eingetragen werden, dann kann diese Datei wieder aus der Dateiliste entfernt werden. Dazu klicken Sie entweder auf die kleine Schaltfläche mit dem roten X oder drücken die Löschtaste 'Entf'.

Dokumente in den Dokumente-Ordner kopieren
Wenn eine der gewählten Dateien NICHT bereits im festgelegten Dokumente-Ordner liegt, dann können Sie optional über ein Häkchen bei "in Dokumente-Ordner kopieren" festlegen, dass das Original-Dokument in den Dokumente-Ordner kopiert wird. Dabei wird das Original-Dokument entsprechend eindeutig umbenannt, so dass auch mehrere Dokumente mit selben Namen zugeordnet werden können. Über ein zweites Häkchen bei "und Original-Dokument löschen" wird zudem das Original-Dokument nach dem Kopieren gelöscht, so dass das Dokument quasi in den Dokumente-Ordner verschoben (und dabei umbenannt) werden kann.

Kategorien
Zur Kategorisierung der Dokumente kann das Feld "Kategorie" verwendet werden. Automatisch kategorisiert werden empfangene E-Mails, bei denen als Kategorie "E-Mail Empfang" eingetragen wird und die damit im Posteingang zu finden sind. Eigene Kategorien können leicht selbst definiert werden: Ein Doppelklick auf den Bezeichner "Kategorie" vor dem Eingabefeld öffnet die Referenztabelle zur Eingabe Ihrer eigenen Kategorien.

Eigenschaften der Dokumente
Zusätzlich zur Kategorie können zu den Dokumenten noch ein Dateityp sowie Kurznotiz und eine Bemerkung eingetragen werden. Zu beachten ist, dass sich sämtliche Dokument-Eigenschaften auf ALLE momentan in der Dateiliste befindlichen Dokumente auswirkt. Beim Übernehmen der einzelnen Dateien aus der Dateiliste in den Dokumente-Reiter erhalten also alle Dokumente die gleichen Eigenschaften. Natürlich können diese nachträglich noch für die einzelnen Dateien geändert werden.

Fertigstellen
Mit einem abschließenden Klick auf die Schaltfläche OK des Fensters "Neues Dokument" wird die Auswahl bestätigt und für jedes in der Dateiliste befindlichen Dokumente eine Verknüpfung mit dem Dokument - entweder als Original-Dokument oder als Kopie - in der Dokumentenliste des Dokumente-Reiters eingetragen und damit die Dokumente dem Datensatz zugeordnet.


ezBank 2.5.5 - Ändern einer Dokument-Vorlage

Ändern einer Dokument-Vorlage

Die mit ezBank gelieferten Vorlagen können Sie problemlos ändern und somit an Ihren Bedarf anpassen, zum Beispiel mit Ihrem Briefkopf oder anderes. Die Anpassung erfolgt natürlich über die von Ihnen verwendete Textverarbeitung (von ezBank unterstützt sind alle Versionen von Word für Windows).
  1. Bevor Sie eine Vorlage ändern schließen Sie am besten alle offenen Worddateien.
  2. Öffnen Sie eine der Dokumentenlisten von ezBank. Die Dokumentenlisten finden Sie jeweils als Reiter "Dokumente" im Fenster "Eigenschaften" eines jeden ezBank-Datentyps (z.B. Gegenkonten, Konten, Zahlungsaufträge). Auch zu jedem Termin oder History-Eintrag können Sie eine Dokumentenliste führen.
  3. Klicken Sie auf die Schaltfläche Neueingabe unterhalb der Dokumentenliste. Es öffnet sich das Fenster "Neues Dokument".
  4. Klicken Sie auf die kleine Schaltfläche mit dem Word-Symbol ("Ein neues Dokument (Word) nach einer Vorlage erstellen"). Es öffnet sich das Fenster "Dokumentvorlage auswählen".
  5. Suchen Sie im Order "Vorlagen" die Vorlage, die Sie ändern möchten.
  6. Es wird empfohlen, eine Kopie der Vorlage zu erstellen, die Sie ändern möchten. Diese können Sie dann ändern. Auf diese Weise bleibt Ihnen das Original zu Ihrer Sicherheit erhalten. Zum Kopieren klicken Sie mit der rechten Maustaste auf den Dateinamen der Vorlage, der im Fenster "Dokumentvorlage wählen" angezeigt wird. Es öffnet sich ein Pull-Down-Menü. In diesem Menü klicken Sie mit der linken Maustaste auf den Menüpunkt "Kopieren". Klicken Sie dann wieder mit der rechten Maustaste irgendwo auf die weiße Fläche neben den Dateinamen. Es öffnet sich wieder das gleiche Pull-Down-Menü wie zuvor. Klicken Sie nun mit der linken Maustaste auf den Menüpunkt "Einfügen". Eine Kopie der Datei ist nun erstellt worden und über das Fenster verfügbar.
  7. Zum Öffnen der Vorlage (bzw. Ihrer Kopie) klicken Sie mit der rechten Maustaste auf den Dateinamen der Vorlage. Es öffnet sich das Pull-Down-Menü. In diesem Menü klicken Sie mit der linken Maustaste auf den Menüpunkt "Öffnen". Jetzt startet das Programm MS Word und öffnet die Vorlage.
  8. Die Vorlage enthält Variablen (Platzhalter), die Sie Ihren Bedarf nach verwenden können. Eine Variable steht in eckigen Klammern "< >" und ist aus dem Tabellennamen und einem Feldnamen zusammengesetzt (z.B.: <GEGENKONTENSTRASSE>).


ezBank 2.5.5 - Serienbriefe über den Export

Serienbriefe über den Export

Serienbriefe können aus ezBank über den Export der ausgewählten Empfängerdaten in eine Datei, welche dann in Word oder eine beliebige andere Textverarbeitung, welche Serienbriefe erstellen kann, verwendet werden kann.

Zu einem Serienbrief gehört immer der eigentliche Brief (mit Brieftext und verschiedenen Platzhaltern für die pro Empfänger unterschiedlichen Daten wie Anschrift und Anrede), sowie eine Datei mit einer Liste der Empfängerdaten (die Serienbriefdatei):
Der eigentliche Brief wird in der entsprechenden Textverarbeitung, z.B. Word erstellt. Die Serienbriefdatei mit den unterschiedlichen Daten pro Empfänger wird von ezBank über die Export-Funktion erzeugt. Diese Serienbriefdatei wird dann in der Textverarbeitung mit dem Brief verknüpft. Dann läßt sich in der Textverarbeitung für jeden in der Serienbriefdatei enthaltenen Empfänger ein eigener Brief generieren und ausdrucken.

Als Beispiel hier die Vorgehensweise zum Erstellen eines Serienbriefes unter Verwendung von Word 2000 für Windows und ezBank:

::: Beispiel mit Word 2000 :::


ezBank 2.5.5 - Beispiel mit Word 2000

Beispiel mit Word 2000

  1. Starten Sie ezBank und öffnen Sie die Liste, in der sich die gewünschten Empfängeradressen befinden, z.B. die Gegenkontenliste. Nun können Sie gegebenenfalls einen Filter zur Auswahl bestimmter Empfänger setzen (siehe auch Lektion Filtern). Wichtig ist, dass nur die markierten Datensätze exportiert werden. Markieren Sie also die gewünschten Empfänger (siehe auch Lektion Markieren im Kapitel Listenbedienung). Dann klicken Sie mit der rechten Maustaste in die Liste hinein. Es öffnet sich ein Pull-Down-Menü (Kontextmenü), in dem Sie auf den Menüpunkt "Exportieren" klicken, um die Exportdatei zu erstellen (siehe auch Lektion Exportieren). Diese Exportdatei wird dann als Serienbriefdatei in Word oder einer anderen Textverarbeitung verwendet.
  2. Beenden Sie ezBank und starten Sie Windows und dort Word 2000. Schreiben Sie Ihren Brieftext oder öffnen Sie ein bereits bestehendes Word-Dokument.
  3. Wählen Sie vom Menü "Extras" den Punkt "Seriendruck".
    Bei "Hauptdokument" klicken Sie auf "Erstellen", wählen vom Pull-Down-Menü den Punkt "Serienbriefe" und klicken auf "Aktives Fenster".
    Klicken Sie nun auf "Daten importieren" und wählen aus dem Pull-Down-Menü den Punkt "Datenquelle öffnen" und öffnen die in ezBank erzeugte Exportdatei.
    Klicken Sie auf "Hauptdokument bearbeiten". Nun wird in Word eine neue Symbolleiste für die Bearbeitung des Serienbriefs bereitgestellt. Klicken Sie darin auf "Seriendruckfeld einfügen" und vervollständigen Sie den Serienbrief mit den gewünschten Feldern aus ezBank.
  4. Mit Klick auf das ABC-Icon in der Symbolleiste erhalten Sie eine Vorschau des Seriendrucks.
  5. Wenn Sie Ihren Serienbrief fertig gestaltet haben, wählen Sie vom Hauptmenü "Datei" den Punkt "Speichern unter" und speichern Sie die Änderungen ab.
  6. Wählen Sie nun in der Symbolleiste für die Erstellung von Seriendrucken die Schaltfläche "Seriendruck..." und klicken Sie auf "Zusammenführen...".
  7. Wählen Sie nun vom Hauptmenü "Datei" den Punkt "Drucken", um den soeben erzeugten Text (einen Brief für jeden der Empfänger-Daten aus ezBank) auszudrucken.


ezBank 2.5.5 - Serienbriefe über eine RTF-Textverarbeitung

Serienbriefe über eine RTF-Textverarbeitung

Die zweite Möglichkeit, Serienbriefe aus ezBank zu erstellen, ist über die Serienbrieffunktion direkt aus der Gegenkontenliste. Die Vorlage für einen solchen Serienbrief muss im RTF-Format vorliegen und beinhaltet neben dem Brieftext verschiedene Platzhalter für die Empfängerdaten (Anrede, Anschrift, ...).
Der eigentliche Brief wird in der gewählten Textverarbeitung erstellt, beispielsweise die mitgelieferte kleine RTF-Textverarbeitung.

So erstellen Sie einen RTF-Serienbrief

  1. Starten Sie ezBank und öffnen Sie die Gegenkontenliste. Nun können Sie gegebenenfalls einen Filter zur Auswahl bestimmter Empfänger setzen (siehe auch Kapitel Filtermöglichkeiten). Wichtig ist, dass der Serienbrief nur für die markierten Datensätze erstellt wird. Markieren Sie also in der Liste nur die gewünschten Empfänger (siehe auch Lektion Markieren im Kapitel Listenbedienung).
  2. Klicken Sie auf die kleine Schaltfläche mit dem Word-Symbol unten in der Liste. Es öffnet sich der Dialog zur Auswahl der Serienbriefdatei.
  3. Hier wählen Sie die gewünschte Vorlagedatei (RTF-Textdatei) für den Serienbrief und bestätigen die Datei mit Klick auf die Schaltfläche Öffnen.
  4. Jetzt sehen Sie den Dialog "Serienbrief erstellen..." mit der gewählten Vorlagedatei und einigen Einstellungs-Möglichkeiten.
  5. Über die Schaltfläche '...' neben dem Feld "Serienbrief" können Sie die Auswahl jederzeit ändern, also eine andere Briefvorlage wählen. Durch die Schaltfläche mit dem Ordner-Symbol neben dem Feld "Serienbrief" ist es noch möglich, die Vorlagedatei in Ihrer RTF-Textverarbeitung zu öffnen und zu bearbeiten.
  6. Markieren Sie die Auswahl "Serienbriefe einzeln bei den Empfängern speichern", dann wird jeder einzene erstellte Brief gespeichert. Möchten Sie dies nicht, dann entfernen Sie das Häkchen bei dieser Auswahl.
  7. Mit Klick auf die Schaltfläche OK bestätigen Sie Ihre Eingaben. Dabei wird auf Basis der gewählten Serienbrief-Vorlagedatei für jeden gewählten Empfänger ein neues RTF-Dokument erstellt, automatisch mit den Empfängerdaten gefüllt und die fertigen Briefe sofort an den ausgewählten Drucker geschickt.


ezBank 2.5.5 - E-Mail versenden

E-Mail versenden

Eine E-Mail aus ezBank erstellen und versenden Sie über einen eigenen E-Mail-Dialog. Über den Hauptmenüpunkt "Einstellungen" - "Optionen" im Reiter "Kommunikation" - siehe Telefonie und E-Mail - können Sie dazu einstellen, dass der E-Mail-Versand über den internen E-Mail-Dialog (alter Dialog) erfolgen soll. Dann erscheint mit Klick auf die kleine Pfeil-Schaltfläche rechts neben der E-Mail-Adresse folgender Dialog:

Reiter 'Nachricht'
Hier geben Sie den oder die Empfänger ein, können eine fertige E-Mail aus einer Vorlagedatei wählen, geben Betreff und die Nachricht (E-Mail) ein bzw. ändern gegebenenfalls den vorgegebenen Text aus der Vorlage und wählen Merkmale zur Nachricht.

Empfänger: Hier wird die E-Mail-Adresse des gewählten Empfängers eingetragen. Natürlich können Sie den Empfänger hier aber noch ändern oder auch weitere Empfänger eintragen, wenn andere Personen eine Kopie der E-Mail erhalten sollen. Weitere E-Mail-Adressen werden durch Komma getrennt eingetragen.

Vorlagedatei: Sie können eine Vorlagedatei wählen. Dann wird der Inhalt dieser Datei als E-Mail übernommen. Dabei werden bereits Platzhalter in der Datei (z.B. die Anrede) mit den Daten der gewählten Adresse ersetzt.

Betreff: Hier geben Sie einen Betreff ein, also das Thema dieser E-Mail. Der Betreff kann auch aus der E-Mail-Vorlagedatei automatisch gefüllt werden, indem in der ersten Zeile der Vorlagedatei $Subject$ und dahinter der Text des Betreffs eingetragen wird. Außerdem können immer wieder zu verwendende Betreffs in der Auswahlliste abgelegt werden, so dass sie aus der Liste ausgewählt werden können.

E-Mail speichern: Hier können Sie wählen, ob die E-Mail beim Empfänger gespeichert werden soll, und wenn ja, ob als eigenes Dokument im Reiter 'Dokumente' (komplette E-Mail) oder als History-Eintrag (nur Betreff).

Dringlichkeit: Hier wählen Sie die Dringlichkeit 'Niedrig', 'Normal' oder 'Hoch'.

Lesebestätigung anfordern: Damit können Sie bei wichtigen Nachrichten eine Bestätigung anfordern, dass die Nachricht erhalten wurde. Dann sind Sie sicher, dass Ihre E-Mail auch angekommen ist.

Reiter 'Dateianhang'
Hier können Sie zur E-Mail beliebige Dateien auswählen, die dann mit der E-Mail als Anhang (sogenannte Attachments) mitgeschickt werden.

Einfach mit der Schaltfläche Neu beliebige Dateien auswählen. Mit Löschen kann eine versehentlich angehängte Datei wieder aus der Liste entfernt werden. Natürlich wird dabei NICHT die Datei selbst gelöscht.

Anlagen automatisch komprimieren: Dringend empfohlen wird natürlich, Dateianhänge zu komprimieren (zippen). Wenn Sie also Word-Dokumente oder Access-Datenbanken oder ähnliches verschicken, dann markieren Sie dieses Feld, damit die Anhänge komprimiert werden, bevor die E-Mail verschickt wird.
Versenden Sie als Anhang bereits eine gezippte Datei, dann allerdings ist es besser, dieses Kontrollkästchen NICHT zu markieren. Entfernen Sie also das Häkchen mit einem Klick darauf.

Reiter 'Einstellungen'
Bevor Sie E-Mails versenden können müssen einige Angaben zum Absender (also Sie) und zu Ihrem Mailserver (SMTP-Server) eingetragen werden. Deshalb wird beim ersten Aufruf des E-Mail-Programms dieser Reiter sofort geöffnet. Ihre E-Mail-Adresse sowie die Angaben zum Mailserver erhalten Sie von Ihrem Provider, also der Firma, über die Sie Ihre E-Mail-Adresse haben (z.B. T-Online).

Ihr Name: Hier geben Sie einfach Ihren kompletten Namen ein (Vorname Nachname).

EMail-Adresse: Hier geben Sie Ihre E-Mail-Adresse ein. Das ist die Adresse, die Sie von Ihrem Provider (z.B. T-Online) erhalten haben und mit der Sie sich bei Ihrem Provider anmelden müssen.
Die E-Mail-Adresse ist in der Regel im Format name@provider oder vorname.name@provider

Firma/Org.: Hier können Sie den Namen Ihrer Firma oder Organisation eintragen.

Rückantwort an: Hier geben Sie die E-Mail-Adresse ein, an der Sie eine Rückantwort erwarten. Das ist meistens dieselbe Adresse wie oben unter EMail-Adresse eingetragen, aber das muss nicht sein.
Auch diese E-Mail-Adresse ist in der Regel im Format name@provider oder vorname.name@provider

SMTP-Auth.: Hier wählen Sie, ob bei Ihrem SMTP-Server, also bei Ihrem Provider, eine Authentifizierung mit User oder Kontoname und Passwort notwendig ist. Wenn ja, dann markieren Sie dieses Kontrollkästchen und tragen in den beiden nebenstehenden Feldern User und Passwort ein. Diese Daten erhalten Sie auch von Ihrem Provider.

Immer zuerst eine Vorlagedatei wählen: Hier können Sie wählen, ob bei einer neuen E-Mail sofort das Fenster zum Auswählen einer Vorlagedatei geöffnet werden soll. Verwenden Sie nie oder nur selten eine Vorlagedatei, dann entfernen Sie besser das Häkchen aus diesem Kontrollkästchen.

Betreff-Automatik: Wenn dieses Kontrollkästchen markiert ist, dann wird der eingegebene Betreff nach einer Rückfrage zur Bestätigung automatisch immer in der Auswahlliste eingetragen, wenn der Betreff dort noch nicht vorhanden ist. Verwenden Sie bei jeder E-Mail einen individuellen Text als Betreff, dann ist dies störend und sollte abgeschaltet bleiben.


ezBank 2.5.5 - Filtern/Drucken/Berichte

Filtern/Drucken/Berichte

Filtermöglichkeiten

Drucklisten

Berichte

Weiter zum Kapitel Datenexport ...


ezBank 2.5.5 - Filtermöglichkeiten

Filtermöglichkeiten

Filter helfen aus der gesamten Datenmenge bestimmte Daten zu finden und in einer bestimmten Form anzuzeigen. Es gibt daher in den folgenden Funktionen die Möglichkeit einen Filter zu setzen:
  • Listen (Bildschirm)
  • Drucklisten (siehe Lektion Drucklisten)
  • Berichte (siehe Lektion Berichte)

::: Die Filterliste :::

::: Filter in Listen :::

::: Erstellen einer Filterabfrage :::


ezBank 2.5.5 - Die Filterliste

Die Filterliste

Die Benutzung eines gesetzten Filters geschieht als erstes über das Fenster "Filterliste", das eine Auswahl an Filtermöglichkeiten in einer Liste zeigt.

Um einen Filter anwenden zu können, doppelklicken Sie auf den gewünschten Filter oder markieren Sie diesen mit einem Mausklick und klicken dann auf die Schaltfläche Filter anwenden. Nun versucht die Anwendung, diese Filterabfrage auszuführen. Manche Abfragen sind bereits vollständig definiert und werden daher gleich durchgeführt, wie z.B. der Filter "Heute geänderte oder neu angelegte Gegenkonten" oder "Personen mit Geburtstag in diesem Monat".
Andere Filter müssen noch mit Daten vervollständigt werden. Dazu öffnet sich, nachdem Sie auf die Schaltfläche Filter anwenden geklickt haben, das Fenster "Filterkriterien". Hier tippen Sie nun die entsprechenden Daten zur Filterbedingung ein. Beispielsweise muss die Filterabfrage "Suche nach einem bestimmten Namen" durch irgendwelche Namenseingaben vervollständigt werden, indem im Fenster "Filterkriterien" eines oder mehrere der Eingabefelder gefüllt werden. Klicken Sie auf die Schaltfläche OK des Fensters "Filterkriterien" wird die Abfrage mit den eingegebenen Daten komplettiert und ausgeführt.

In der Liste mit den Filterabfragen finden Sie den "Komfortfilter", den Sie mit der Schaltfläche Filter anwenden oder Doppelklick öffnen können. Der Komfortfilter ermöglicht es Ihnen über Eingabefelder eine Filterabfrage einfach und schnell selbst zu generieren. Sie können dabei alle Felder ausfüllen oder nur diejenigen, die für Ihren Filterwunsch relevant sind. Dann bestätigen Sie Ihre Eingabe mit Klick auf die Schaltfläche OK und die Filterabfrage wird durchgeführt.

Im Fenster "Filterliste" gibt es die Schaltfläche Ohne Filter. Hiermit können Sie entweder veranlassen, dass keine Filterabfrage durchgeführt wird, oder eine Filterabfrage rückgängig machen. Das Zurücknehmen einer Filterabfrage ist dann beispielsweise sinnvoll, wenn nach der Filterabfrage "Suche Gegenkonten in München" in der Gegenkontenliste nur Gegenkonten aus München angezeigt werden, Sie aber wieder alle Gegenkonten sehen möchten. Klicken Sie mit der rechten Maustaste in die Liste und wählen Sie in dem Menü, das sich dann öffnet, den Menüpunkt "Filter" aus. Im Fenster "Filterliste" klicken Sie auf die Schaltfläche Ohne Filter.

Mit die Schaltflächen Neu und Ändern im Fenster "Filterliste" ist es Ihnen möglich eine neue Filterabfrage zu erstellen bzw. eine bestehende Filterabfrage zu ändern. Allerdings basieren diese Funktionen auf einer SQL-Abfrage und sind daher vor allem Profis zu empfehlen. Weitere Informationen dazu finden Sie im Kapitel "Erstellen einer Filterabfrage". Wenn Sie unsere Hilfe benötigen oder wir für Sie einen spezielle Filter erstellen sollen, können Sie gerne unsere Hotline nutzen (siehe Kapitel Kontaktmöglichkeiten).


ezBank 2.5.5 - Filter in Listen

Filter in Listen

Die Listen-Funktion finden Sie im Hauptmenü "Zahlung" oder in der Symbolleiste über die entsprechenden Icons. Welche Filtermöglichkeiten in einer bestimmten Liste angeboten werden, ist von der jeweiligen Thematik abhängig. Haben Sie ein Listen-Fenster geöffnet, können Sie in der Statuszeile - rechts unten - einige nützliche Daten ablesen. Es wird dort angezeigt:
  • ob ein Filter benutzt wird und die Liste daher nur die Ergebnisse der Filterabfrage enthält
  • welche Filterabfrage genau benutzt wird
  • und wie viele Datensätze gerade durch die Liste angezeigt werden
Wenn Sie auf die Liste einen Filter anwenden wollen, klicken Sie entweder auf das Filter-Icon in der Symbolleiste oder klicken mit der rechten Maustaste in die Liste hinein und wählen in dem Menü, das sich dann öffnet, den Eintrag "Filtern..." aus. Es öffnet sich dann das Fenster "Filterliste", mit dem Sie wie vorher beschrieben verfahren können.


ezBank 2.5.5 - Erstellen einer Filterabfrage

Erstellen einer Filterabfrage

Wenn Sie eine Filterabfrage ändern wollen, markieren Sie eine der Filtermöglichkeiten im Fenster "Filterliste" und klicken auf die Schaltfläche Ändern. Es öffnet sich das Fenster "Filter bearbeiten". Wichtig: beim Ändern einer Abfrage wird die bisherige Abfrage überschrieben, auch wenn Sie die geänderte Abfrage mit einer anderen Bezeichnung abspeichern. Um eine neue Abfrage zu erstellen klicken Sie bitte in der Filterliste auf die Schaltfläche Neu. Damit lässt sich auch ein bereits bestehender Filter kopieren.
Hinweis: Zum Ändern einer der mitgelieferten Filterdefinitionen wird empfohlen, diesen Filter zu kopieren und nur den kopierten Filter zu ändern. Die Änderung eines mitgelieferten Filters wirkt sich nur bis zum nächsten Update aus, da dieser dann wieder geliefert und somit überschrieben wird.

Bedingung: Generell ist zu sagen, dass die Filterfunktion auf SQL-Abfragen basiert. Unter "Bedingung" finden Sie daher die SQL-Bedingungsanweisung, die Sie in Ihrem Sinne ändern können. Grundsätzlich können Sie hier alle Möglichkeiten nutzen, die SQL bietet.
Das Wichtigste zu einer SQL-Bedingung:
  1. Generell lautet die Schreibweise: Feld SQL-Operator Wert, Beispiel: "ORT = 'München'"
  2. Als SQL-Operatoren stehen zur Verfügung: '=' (exakt gleich), 'LIKE' (ungefähr gleich), '<>' (nicht gleich) und andere
  3. Ist das Feld ein Datum oder eine Zahl, dann wird der Wert nach dem SQL-Operator direkt angegeben, Beispiel: "BETRAG = 0"
  4. Ist das Feld ein Textfeld, dann muss der Wert in einfachen Hochkommata angegeben werden, Beispiel: "LAND = 'DE'"
    Außerdem können bei Textfeldern insbesondere in Verbindung mit dem SQL-Operator LIKE sogenannte Wildcards verwendet werden, Beispiel: "PLZ LIKE '7*'" oder "EMAIL LIKE '*@*'"

Ergebnisliste sofort sortieren nach: Damit kann ein Feld ausgewählt werden, nach dem beim Anwenden des Filters die Ergebnisliste sortiert angezeigt wird. Beim Entfernen des Filters wird automatisch die vorige Sortierung wiederhergestellt.

Feld hinzufügen:
Diese Funktion unterstützt Sie beim Schreiben einer Bedingung. Wählen Sie in der Liste der verfügbaren Felder einen Eintrag aus und klicken Sie dann auf diese Schaltfläche. Das gewählte Feld erscheint dann im Textfeld "Bedingungen" an der aktuellen Cursorposition. Denselben Effekt haben Sie mit einem Doppelklick auf eines der verfügbaren Felder.

Bedingung testen:
Wenn Sie eine Bedingung geschrieben haben, und dann auf diese Schaltfläche klicken, wird Ihnen entweder angezeigt, dass die Filterbedingung in Ordnung ist, oder es wird ein entsprechender Fehler angezeigt.

Filterkriterien: Definieren von Eingabefeldern

Oft macht es Sinn, zur Eingabe eines Filterkriteriums diesen Wert nicht direkt in der Filterabfrage zu definieren, sondern diesen Wert erst bei der Ausführung des Filters zu erfragen. Damit müssen Sie beispielsweise einen Filter zur Abfrage aller Personen in München nicht mit der Bedingung "ORT = 'München'" definieren, sondern bieten mit einer Bedingung wie "ORT = '[Eingabefeld für den Ort]'" die Möglichkeit, den gewünschten Ort erst bei Ausführung des Filters einzugeben. Damit können mit nur einer Filterdefinition Personen aller beliebigen Orte abgefragt werden.

Eine solche Bedingung mit der Definition eines Eingabefeldes kann auf zwei Arten erstellt werden, abhängig davon, ob eine Eingabe in dem Feld zwingend erforderlich ist (eher untypisch) oder ob die Eingabe auch weggelassen kann (der Regelfall).

Wenn eine Eingabe im Feld zwingend erforderlich ist sieht die Schreibweise so aus: Feldname SQL-Operator [?Bezeichnung:?]
Einfaches Beispiel zur Abfrage eines Namens: NAME = '[?Name:?]'
Dabei ist NAME der Feldname und das '='-Zeichen der SQL-Operator.
In einer Filterdefinition können auch mehrere Felder und auch feste SQL-Bedingungen gemischt werden. Angenommen, Sie benötigen einen Filter zur Suche bestimmter Personen nach Namen in einem bestimmten PLZ-Gebiet, aber nur in Deutschland. Dann benötigen Sie eine feste Bedingung für das Land (LAND = 'DE') und zwei Eingabefelder für das PLZ-Gebiet (PLZ = '[?PLZ-Gebiet:?]') und den Namen (NAME = '[?Name:?]'). Diese drei Bedingungen werden nach den Regeln der SQL-Abfrage über AND miteinander verbunden.
Das sieht dann so aus: LAND = 'DE' AND PLZ = '[?PLZ-Gebiet:?]' AND NAME = '[?Name:?]'

Dazu kann noch eine Formatierung des Feldes definiert werden. Eine Bedingung mit Formatierungsangabe sieht so aus: Feldname SQL-Operator [?Bezeichnung:|Formatierung?], wobei die Formatierung immer die 10-stellige Angabe eines Feldformats ist mit möglichen nachfolgenden Spezifikationen wie beispielsweise eine Längenangabe. Wird keine Formatierung angegeben, dann wird ein einfaches Text-Eingabefeld in maximaler Länge verwendet.
In unserem Beispiel zur Suche bestimmter Personen nach Namen in einem bestimmten PLZ-Gebiet könnte das Feld zur PLZ-Eingabe auf 5 Zeichen begrenzt werden. Dazu wird als Formatierung ein Textfeld in Länge 5 definiert, also: Feldformat = CTEXT_____ und Spezifikation = 5, zusammen CTEXT_____5.
Insgesamt sieht das dann so aus: LAND = 'DE' AND PLZ = '[?PLZ-Gebiet:|CTEXT_____5?]' AND NAME = '[?Name:?]'

Das Beispiel ist so noch nicht praxistauglich, weil Sie so nur nach ganz exakten Eingaben suchen können und immer beide Eingabefelder gefüllt werden müssen. Besser wäre die Suche auch nach PLZ-Bereichen - dazu muss die Eingabe von einer oder zwei Zahlen genügen - sowie nach Teilangaben des Namens. Dazu muss anstelle der SQL-Bedingung PLZ = '' die Bedingung PLZ LIKE '**' und anstelle von NAME = '' die Bedingung NAME LIKE '**' kommen.
Das sieht jetzt also insgesamt so aus: LAND = 'DE' AND PLZ LIKE '[?PLZ-Gebiet:|CTEXT_____5?]*' AND NAME LIKE '*[?Name:?]*'

Ergebnis: Wenn Sie nach Schuster im PLZ-Gebiet 7 suchen und dies so eingeben, dann wird diese Bedingung zusammengebaut: LAND = 'DE' AND PLZ LIKE '7*' AND NAME LIKE '*Schuster*'
Suchen Sie alle Personen im PLZ-Gebiet 7 und geben also im Namen nichts ein, dann wird die Bedingung so zusammengebaut: LAND = 'DE' AND PLZ LIKE '7*' AND NAME LIKE '**'

Eine alternative Schreibweise erlaubt die Angabe einer Standardbedingung oder eines Standardwertes, der verwendet wird, wenn im Eingabefeld NICHTS eingegeben wird. Dadurch ist eine Eingabe im Feld nicht zwingend erforderlich und der Filter kann flexibel mit allen definierten Eingabefeldern einzeln oder beliebig gemischt verwendet werden. Die alternative Schreibweise: [?Bezeichnung:|Formatierung|Feldname SQL-Operator ?[]? |Standardbedingung?]
Damit Sie dies besser lesen können, hier eine kleine Erklärung zur Schreibweise: die komplette Definition eines bestimmten Feldes mit Bezeichnung, Formatierung, SQL-Bedingung und Standardbedingung steht zwischen zwei Begrenzern [? und ?]
Die einzelnen Bestandteile sind jeweils durch einen senkrechten Strich | voneinander getrennt, also Bezeichnung|Formatierung|SQL-Bedingung|Standardbedingung.
Der im Eingabefeld eingegebene Wert wird durch die Angabe ?[]? repräsentiert. Die Formel ?[]? ist also der Platzhalter für den eigentlichen Wert einer SQL-Bedingung Feldname SQL-Operator ?[]?, also beispielsweise NAME = '?[]?'
Mit anderen Worten: zwischen den Begrenzern [? und ?] stehen jeweils durch einen Strich | getrennt die Bezeichnung des Feldes, die Formatierung des Feldes, die SQL-Bedingung bei Eingabe des Feldes (mit Feldname, SQL-Operator und Platzhalter ?[]?) sowie die Angabe einer Standardbedingung oder eines Standardwerts, falls im Eingabefeld NICHTS eingegeben wurde.

Zur Veranschaulichung wieder das bekannte Beispiel, nun mit alternativer Schreibweise:

  1. PLZ-Gebiet:
    [?Bezeichnung:|Formatierung|Feldname SQL-Operator ?[]? |Standardbedingung?]
    [?PLZ-Gebiet:|CTEXT_____5|PLZ LIKE '?[]?*'|?]
    Dabei ist PLZ-Gebiet die Bezeichnung, CTEXT_____5 die Formatierung mit Feldformat = CTEXT_____ und Längenangabe = 5, PLZ der Feldname, LIKE der SQL-Operator und '?[]?*' der Wert mit dem Platzhalter ?[]? für die Eingabe. Als Standardbedingung ist nach dem letzten | nichts angegeben; wird bei PLZ-Gebiet nichts eingegeben, dann erscheint auch nichts für diese Felddefinition in der SQL-Bedingung. Das Feld PLZ-Gebiet wird dann also völlig ignoriert.
  2. Name:
    [?Bezeichnung:|Formatierung|Feldname SQL-Operator ?[]? |Standardbedingung?]
    [?Name:|CTEXT_____|NAME LIKE '*?[]?*'|?]
    Dabei ist Name die Bezeichnung, CTEXT_____ die Formatierung mit Feldformat = CTEXT_____ ohne weitere Spezifikation, NAME der Feldname, LIKE der SQL-Operator und '*?[]?*' der Wert mit dem Platzhalter ?[]? für die Eingabe. Als Standardbedingung ist auch hier nach dem letzten | nichts angegeben, das Feld Name wird bei Nichteingabe also ebenfalls ignoriert.
Wird das Ganze nun zusammengebaut, dann müssen die einzelnen Bedingungen wieder nach den Regeln der SQL-Abfrage mit AND miteinander verbunden werden. Das sieht dann so aus:
LAND = 'DE'
[?PLZ-Gebiet:|CTEXT_____5| AND PLZ LIKE '?[]?*'|?]
[?Name:|CTEXT_____| AND NAME LIKE '*?[]?*'|?]
Das AND wird als Bestandteil der SQL-Bedingung nur verwendet, wenn im Eingabefeld etwas eingegeben wurde. Ansonsten trifft ja die (leere) Standardbedingung zu.

Nun noch ein Beispiel mit Verwendung der Standardbedingung: Der Filter soll nun erweitert werden, so dass wahlweise auch nach anderen Ländern gesucht werden kann. Dazu wird die bisherige feste Bedingung LAND = 'DE' so geändert, dass auch ein Land eingegeben werden kann. Wird aber nichts eingegeben, dann bleibt es bei der Suche nach Personen in Deutschland (= Standardbedingung).
Aus LAND = 'DE' wird also [?Land:|CTEXT_____2|LAND = '?[]?'|LAND = 'DE'?]
Das können Sie jetzt sicher bereits problemlos lesen: Land ist die Bezeichnung, CTEXT_____2 die Formatierung mit Feldformat = CTEXT_____ und Längenangabe = 2, LAND = '?[]?' die SQL-Abfrage mit Feldname LAND, SQL-Operator '=' und Wert '?[]?' mit dem Platzhalter ?[]? für die Eingabe. Als Standardbedingung ist nach dem letzten | LAND = 'DE' angegeben; wird also KEIN Land eingegeben, dann wird LAND = 'DE' als SQL-Bedingung verwendet.
Die fertige Filterdefinition mit den drei Eingabefeldern sieht nun so aus:
[?Land:|CTEXT_____2|LAND = '?[]?'|LAND = 'DE'?]
[?PLZ-Gebiet:|CTEXT_____5| AND PLZ LIKE '?[]?*'|?]
[?Name:|CTEXT_____| AND NAME LIKE '*?[]?*'|?]

Ergebnis: Wenn Sie nach Schuster im PLZ-Gebiet 7 suchen und dies so eingeben, dann wird diese Bedingung zusammengebaut: LAND = 'DE' AND PLZ LIKE '7*' AND NAME LIKE '*Schuster*'
Suchen Sie alle Personen im PLZ-Gebiet 7 und geben also im Namen nichts ein, dann wird die Bedingung so zusammengebaut: LAND = 'DE' AND PLZ LIKE '7*'

Drei letzte Beispiele sollen noch zeigen, dass auch mit nur einem definierten Eingabefeld in mehreren Tabellenfeldern gesucht werden kann. Dabei werden in der SQL-Abfrage mehrere SQL-Bedingungen verknüpft, die sich jeweils mit '*?[]?*' auf denselben eingegebenen Wert des Eingabefelds beziehen.
1. [?Name:|CTEXT_____|SUCHCODE LIKE '*?[]?*' OR NAME LIKE '*?[]?*' OR VORNAME LIKE '*?[]?*'|?]
2. [?Telefon:|CTEXT_____|TELEFON LIKE '*?[]?*' OR TELEFAX LIKE '*?[]?*' OR MOBIL LIKE '*?[]?*'|?]
3. [?Adressart:|ADRESSART_|AART1 = '?[]?' OR AART2 = '?[]?' OR AART3 = '?[]?'|?]

Folgende Formatierungsmöglichkeiten stehen zur Verfügung

Allgemeine Feldformate:
Formatierung | Bedeutung | Beispiele
CTEXT_____ | Erlaubt beliebige Texteingaben in beliebiger Länge. | [?Suchbegriff:|CTEXT_____|SUCHCODE LIKE '*?[]?*'|?]
CTEXT_____5 | Längenangabe: Erlaubt beliebige Texteingaben in maximaler Länge 5 Stellen. | [?PLZ-Gebiet:|CTEXT_____5| AND PLZ LIKE '?[]?*'|?]
CTEXT_____2;DE | Längenangabe und Vorgabewert: Gibt im Feld bereits einen Wert 'DE' vor. | [?Land:|CTEXT_____2;DE| AND LAND = '?[]?'|?]
CTEXT_____4;$Jahr$ | Längenangabe und Vorgabewert: Gibt im Feld bereits das aktuelle Jahr vor. | [?Jahr:|CTEXT_____4;$Jahr$| AND Year(DATUM) = ?[]?|?]
CINT______ | Erlaubt nur numerische Eingaben (Zahlen) in beliebiger Länge. | [?Schlüssel:|CINT______|KEY = ?[]?|?]
CINT______2 | Längenangabe: Erlaubt numerische Eingaben in maximaler Länge 2 Stellen. | [?Monat:|CINT______2| AND Month(DATUM) = ?[]?|?]
CDATE_____ | Erlaubt die Auswahl eines Datums in einem Datumsfeld. | [?Erledigt von:|CDATE_____| AND ERLEDIGT <= ?[]?|?]
CDATE_____;$Jahresanfang$ | Gibt dem Datumsfeld den 01.01. des aktuellen Jahres vor. | [?Erledigt von:|CDATE_____;$Jahresanfang$| AND ERLEDIGT >= ?[]?|?]
CDATE_____;$Jahresende$ | Gibt dem Datumsfeld den 31.12. des aktuellen Jahres vor. | [?Erledigt bis:|CDATE_____;$Jahresende$| AND ERLEDIGT <= ?[]?|?]
CHECKBOX__ | Erstellt eine Checkbox für Ja/Nein-Abfragen. | [?Merker:|CHECKBOX__| AND MERKER = ?[]?|?] [?Dauerauftrag?:|CHECKBOX__| AND NOT ISNULL(DAUERAUFTRAG) = ?[]?|?]
CLISTE____;Liste | Referenzdaten-Auswahlliste zu einem Zusatzfeld im Format 'Liste'. | [?MeineListe:|CLISTE____;MeineListe| AND FELD01 = '?[]?'|?]
Feldformate speziell für Zahlungen:
Formatierung | Bedeutung | Beispiele
CART______ | Auswahlliste zur Auswahl der Auftragsart. | [?Auftragsart:|CART______| AND ART = '?[]?'|?]
CKKEY_____ | Auswahlliste zur Auswahl eines Kontos. | [?Konto:|CKKEY_____| AND KKEY = ?[]?|?]
CGKEY_____ | Auswahlliste zur Auswahl eines Gegenkontos. | [?Gegenkonto:|CGKEY_____| AND GKEY = ?[]?|?]
CDA_______ | Auswahlliste zur Auswahl der Art des Dauerauftrags (Intervall). | [?Dauerauftrag:|CDA_______| AND DAUERAUFTRAG = '?[]?'|?]
CLISTE____;V-Zweck | Erstellt eine Auswahlliste mit Verwendungszweck-Vorlagen. | [?Verwendungszweck:|CLISTE____;V-Zweck| AND VERWENDUNG1 LIKE '*?[]?*'|?]
CLISTE____;Notiz-Z | Erstellt eine Auswahlliste mit Notiz-Vorlagen. | [?Kurznotiz:|CLISTE____;Notiz-Z| AND NOTIZ = '?[]?'|?]


ezBank 2.5.5 - Drucklisten

Drucklisten

Mit den Drucklisten bietet Ihnen ezBank 2.5.5 ein wertvolles Werkzeug, um Listen beliebigen Inhalts auf einem Drucker, PDF-Datei oder Fax ausgeben zu können. Dabei können Sie sowohl das Aussehen (Layout) wie auch den Inhalt einer gedruckten Liste selbst bestimmen. Für alle Rubriken liefert ezBank aber bereits fertig definierte Drucklisten mit.
Die Drucklistenfunktion ist für die einzelnen Themen/Rubriken (hier nur "Zahlungsaufträge") jeweils spezialisiert. Daher finden Sie die Drucklistenfunktion "Drucken" im Hauptmenü "Zahlung".
Eine allgemeine Funktion mit sämtlichen verfügbaren Drucklisten finden Sie zudem noch im Hauptmenü "Datei" - "Drucken".

Drucklisten stimmen in ihrer Funktion mit Berichten überein. Allerdings sind sie technisch sehr einfach aufgebaut und lassen daher - im Gegensatz zu den Berichten - keine beliebige Art von Datenkombination zu. Sie lassen sich auch nicht beliebig gestalten, wie es bei Berichten (allerdings nur mit HTML-Kenntnissen) möglich ist. Dafür sind Drucklistendefinitionen sehr einfach zu verändern oder neu zu erstellen.

::: Allgemeine Einstellungen für alle Drucklisten vornehmen :::

::: Drucklisten und Filter :::

::: Eine Druckliste erstellen :::

::: Eine Drucklistendefinition ändern :::

::: Eine neue Drucklistendefinition erstellen :::


ezBank 2.5.5 - Allgemeine Einstellungen für alle Drucklisten vornehmen

Allgemeine Einstellungen für alle Drucklisten vornehmen

Die Schriftart, Schriftgröße, das Papierformat usw. können Sie für alle Drucklisten selbst bestimmen. Dazu gehen Sie auf den Hauptmenüpunkt "Einstellungen" und klicken auf den Menüpunkt "Drucklisten allgemein". Es öffnet sich das Fenster "Allgemeine Drucklisten-Einstellungen", mit dem Sie nun das Layout Ihrer Drucklisten definieren können.
Siehe dazu auch die Lektion Drucklisten allgemein im Kapitel Einstellungen.

Als zweite Möglichkeit können Sie für jede Drucklistenabfrage ein individuelles Layout definieren.

Dazu klicken Sie im Untermenü "Drucken" auf den Untermenüpunkt "Alle Drucklisten". Wählen Sie im Fenster "Druckliste" die betreffende Drucklistenabfrage aus und klicken auf die Schaltfläche Ändern. Im Reiter "Eigenschaften" des Fensters "Druckliste bearbeiten" klicken Sie auf die Schaltfläche Druckerdefinition. Nun können Sie das Layout der Druckliste neu definieren, bzw. eine fertige Druckerdefinition dieser Druckliste zuordnen.


ezBank 2.5.5 - Drucklisten und Filter

Drucklisten und Filter

Sie können bei jeder Drucklistendefinition einen Filter vorgeben, der dann bei Auswahl dieser Druckliste angewandt wird. Somit lassen sich die Drucklistenabfragen konkretisieren bzw. durch den Filter bestimmte Datenmengen aus dem Bestand heraus filtern (siehe dazu auch das Kapitel Filtermöglichkeiten).
Ob eine Filterabfrage dazwischen geschaltet ist, wenn ja welche, oder ob es keine Filterabfrage gibt, hängt von der Einstellung ab.

So ändern oder kontrollieren Sie die Einstellung

  1. Die Drucklistenfunktion finden Sie im Hauptmenü "Zahlung" im Menüpunkt "Drucken" als Untermenüpunkt "Alle Drucklisten". Es öffnet sich das Fenster "Druckliste wählen".
  2. Markieren Sie eine Drucklistenabfrage in der Liste und klicken auf die Schaltfläche Ändern. Es öffnet sich das Fenster "Druckliste bearbeiten", in dem Sie dann auf den Reiter "Filterbedingung" klicken.
  3. Hier befindet sich ein aufklappbares Listenfeld, in das Sie eine Filterabfrage hineinwählen können. Diejenige Filterabfrage, die in diesem Feld steht, wird im folgenden so lange auf die betreffende Druckliste angewandt, bis Sie der Druckliste wieder eine neue Filterabfrage zuweisen. Wenn das Listenfeld leer ist, wird die Drucklistenabfrage ohne vorhergehende Filterabfrage ausgeführt.


ezBank 2.5.5 - Eine Druckliste erstellen

Eine Druckliste erstellen

So geht das:
  1. Bevor Sie eine Druckliste erstellen, sollten Sie das gewünschte Ausgabegerät (Drucker bzw. Fax) bereits eingeschaltet haben.
  2. Die Drucklistenfunktion finden Sie im Hauptmenü "Zahlung" im Menüpunkt "Drucken". Es öffnet sich ein Untermenü mit allen in dieser Rubrik definierten Drucklistenabfragen.
  3. Klicken Sie nun auf diejenige Drucklistenabfrage, die Sie ausgeführt haben möchten. Es erfolgt dann
    - entweder gleich der Druckvorgang.
    - oder es öffnet sich der definierte Filter. Hier können Sie dann Filterkriterien eingeben.
Ob die Drucklistenabfrage dann unmittelbar als Druckauftrag an den Drucker geht oder erst der Drucker ausgewählt werden muss, bevor der Ausdruck erfolgt, hängt von der Einstellung "Ohne Druckerdialog sofort drucken" ab (siehe Lektion Drucklisten allgemein im Kapitel Einstellungen).


ezBank 2.5.5 - Eine Drucklistendefinition ändern

Eine Drucklistendefinition ändern

So geht das:
  1. Die Drucklistenfunktion finden Sie im Hauptmenü "Zahlung" im Menüpunkt "Drucken" als Untermenüpunkt "Alle Drucklisten". Es öffnet sich das Fenster "Druckliste wählen".
  2. Markieren Sie die zu ändernde Drucklistendefinition und klicken Sie auf die Schaltfläche Ändern. Nun öffnet sich das Fenster "Druckliste bearbeiten".
  3. Ändern Sie die Bezeichnung der Druckliste, wenn Sie möchten.
  4. Wenn die Druckliste eine Summenzeile enthalten soll, aktivieren Sie das Kontrollkästchen "Mit Summenzeile".
  5. Überprüfen Sie nun, ob die gewählten Felder der Haupttabelle Ihren Vorstellungen entsprechen. Sie können nun aus den verfügbaren Feldern neue Felder zu den gewählten Feldern hinzufügen oder Felder aus der Liste der gewählten Felder entfernen. Dies geht mit Markieren des entsprechenden Feldes und mit Klick auf die Schaltfläche ">" oder "<". Wenn Sie die Überschrift oder die Feldgröße verändern wollen, klicken Sie zweimal darauf und es öffnet sich ein Fenster, in dem Sie nun die Änderung vornehmen können. Bestimmen Sie, nach welchem Feld die Druckliste sortiert sein soll.
  6. Als nächstes können Sie die Felder der Untertabelle bearbeiten. Mit ihr verfahren Sie genau wie mit der Haupttabelle.
  7. Im Reiter "Filterbedingung" können Sie eine Filterabfrage wählen, die der Drucklistenabfrage vorangestellt wird, damit diese konkretisiert wird.


ezBank 2.5.5 - Eine neue Drucklistendefinition erstellen

Eine neue Drucklistendefinition erstellen

So geht das:
  1. Die Drucklistenfunktion finden Sie im Hauptmenü "Zahlung" im Menüpunkt "Drucken" als Untermenüpunkt "Alle Drucklisten". Es öffnet sich das Fenster "Druckliste wählen".
  2. Klicken Sie auf die Schaltfläche Neu. Nun öffnet sich das Fenster "Neue Druckliste".
  3. Geben Sie als erstes eine zutreffende Bezeichnung in das Eingabefeld "Bezeichnung" ein.
  4. Wenn die Druckliste eine Summenzeile enthalten soll, aktivieren Sie das Kontrollkästchen "Mit Summenzeile".
  5. Wählen Sie nun eine Haupttabelle aus. Abhängig von der aktuellen Rubrik (hier nur "Zahlungsaufträge") werden die zur Verfügung stehenden Tabellen angezeigt.
  6. Es erscheinen die verfügbaren Felder, die zu der ausgewählten Haupttabelle gehören. Sie entscheiden nun, welche Felder Sie mit Markieren und Klick auf die Schaltfläche ">" übernehmen wollen. Wenn Sie die Überschrift oder die Feldgröße verändern wollen, klicken Sie zweimal darauf und es öffnet sich ein Fenster, in dem Sie nun die Änderung vornehmen können. Bestimmen Sie, nach welchem Feld Sie die Druckliste sortieren wollen.
  7. Als nächstes können Sie eine Untertabelle auswählen. Mit ihr verfahren Sie so, wie mit der Haupttabelle. Welche Untertabellen zur Verfügung stehen ist abhängig von der gewählten Haupttabelle.
  8. Mit Klick auf die Schaltfläche Druckerdefinition öffnet sich ein Fenster, in dem Sie das Layout der Druckliste neu definieren, bzw. eine fertige Druckerdefinition dieser Druckliste zuordnen können.
  9. Im Reiter "Filterbedingung" können Sie eine der für die aktuelle Rubrik zur Verfügung stehenden Filterabfragen wählen, die der Drucklistenabfrage vorangestellt wird, damit diese konkretisiert wird.


ezBank 2.5.5 - Berichte

Berichte

Mit Berichten haben Sie - ähnlich wie mit den Drucklisten - eine Möglichkeit, um einen Überblick über beliebige Sachverhalte zu bekommen.
Es gibt zu allen Rubriken - hier nur "Zahlungsaufträge" - spezifische Berichte. Diese Berichte, die einen Überblick über eine bestimmte Rubrik geben sollen, finden Sie im Hauptmenü "Zahlung" als Menüpunkt "Berichte".
Sie können aber auch zu einem einzelnen Datensatz einen Bericht erstellen. Diese Berichtfunktion finden Sie, wenn Sie die entsprechende Liste geöffnet haben. Markieren Sie einen Listeneintrag per Mausklick und wählen Sie dann den Menüpunkt "Berichte" über den Hauptmenüpunkt "Bearbeiten" oder alternativ aus dem Pull-Down-Menü mit Klick der rechten Maustaste (Kontextmenü).

Da die Berichte durch die Verwendung von SQL-Abfragen sehr flexibel sind, ist beinahe jede beliebige Kombination von Daten möglich. Berichte sind damit sozusagen eine technisch ausgereiftere Version der Drucklisten. Doch können Sie sich jederzeit an unsere Programmierer wenden, wenn Sie einen Bericht benötigen, der so noch nicht in ezBank vorliegt. Für die technisch versierteren Anwender bietet die Berichtsfunktion komfortable Zugangsmöglichkeiten für die Erstellung neuer Berichte.

ezBank unterstützt verschiedene Arten von Berichte - HTML-Dateien, Word-Dokumente, Excel-Tabellen - die Sie jeweils nach Ihren Vorstellungen gestalten können. Beispielsweise könnten Sie Ihren Briefkopf in die Datei einfügen oder diese farblich umgestalten.
Ein weiterer Vorteil von Berichten ist, dass diese nicht wie Drucklisten gleich als Druckauftrag an den Drucker gesendet werden, sondern über den Browser bzw. Word oder Excel angezeigt werden. Auf diese Weise haben Sie eine komfortable Vorschau der Datenübersicht, die Sie über die vom Browser bereitgestellten Funktionen sogar weiterbearbeiten können.

::: Berichte und Filter :::

::: Einen Bericht erstellen :::

::: Eine Berichtsdefinition ändern :::

::: Eine neue Berichtsdefinition erstellen :::


ezBank 2.5.5 - Berichte und Filter

Berichte und Filter

Generell ist zu sagen, dass vor jedem Bericht eine Filterabfrage gesetzt werden kann. So lassen sich die Inhalte eines Berichts konkretisieren bzw. durch den Filter bestimmte Datenmengen aus dem Bestand heraus filtern (siehe dazu auch das Kapitel Filtermöglichkeiten).
Ob eine Filterabfrage dazwischen geschaltet ist, wenn ja welche, oder ob es keine Filterabfrage gibt, hängt von der Einstellung ab.

So ändern oder kontrollieren Sie die Einstellung

  1. Die Berichtsfunktion finden Sie im Hauptmenü "Zahlung" als Menüpunkt "Berichte" oder bei einer geöffneten Liste oder eines Datensatzes im Hauptmenüpunkt "Bearbeiten" bzw. alternativ aus dem Pull-Down-Menü mit Klick der rechten Maustaste (Kontextmenü). Es öffnet sich das Fenster "Bericht wählen".
  2. Markieren Sie einen Bericht in der Liste und klicken auf die Schaltfläche Ändern. Es öffnet sich das Fenster "Bericht bearbeiten".
  3. Hier befindet sich eine Auswahlliste mit allen hier möglichen Filtern, von denen Sie eine auswählen können. Alternativ kann eine Filterbedingung auch frei eingegeben werden. Der gewählte Filter bzw. die Filterbedingung wird dann beim Erstellen diesen Berichts verwendet. Ist die Filterbedingung leer, dann wird der Bericht ohne vorhergehende Filterabfrage ausgeführt.


ezBank 2.5.5 - Einen Bericht erstellen

Einen Bericht erstellen

So geht das:
  1. Die Berichtsfunktion finden Sie im Hauptmenü "Zahlung" als Menüpunkt "Berichte" oder bei einer geöffneten Liste oder eines Datensatzes im Hauptmenüpunkt "Bearbeiten" bzw. im Kontextmenü (rechte Mausklick). Es öffnet sich das Fenster "Bericht wählen".
  2. Markieren Sie einen Bericht in der Liste und klicken auf die Schaltfläche Erstellen.
  3. Wenn ein Filter für diesen Bericht eingestellt wurde (siehe Lektion Berichte und Filter), öffnet sich das Fenster "Filterkriterien". Hier können Sie nun eingeben inwiefern Sie den Bericht differenzieren möchten. Mit Klick auf die Schaltfläche OK des Fensters "Filterkriterien" bestätigen Sie Ihre Eingabe. Nun wird der Bericht automatisch erstellt. Es öffnet sich der Browser und der Bericht wird angezeigt.
  4. Wenn kein Filter für diesen Bericht eingestellt wurde, öffnet sich der Browser sofort nachdem Sie auf die Schaltfläche Erstellen des Fensters "Bericht wählen" geklickt haben und zeigt den Bericht an.

Der Bericht wird aber nicht angezeigt!
Welche Anwendung (Programm) zum Öffnen eines Berichtes verwendet wird hängt von Ihrem System ab:
In Windows wird jede Datei-Endung (z.B. .doc oder .html) mit einem bestimmten Programm verknüpft, welches dann verwendet wird, wenn eine solche Datei angezeigt, bearbeitet oder geöffnet werden soll. Das können Sie leicht selbst feststellen, indem Sie im Explorer auf eine bestimmte Datei doppelklicken: auf einer html-Datei (Bericht) sollte ein Web-Browser starten, z.B. der Internet-Explorer oder Netscape oder Opera, je nach Einstellung in Ihrem System.

So erstellen bzw. korrigieren Sie eine solche Verknüpfung

  1. Öffnen Sie den Windows-Explorer.
  2. Gehen Sie in einen Ordner mit einem Bericht (html-Datei).
  3. Markieren Sie eine Datei durch einen einzelnen Mausklick auf diese.
  4. Halten Sie die Umschalttaste gedrückt und klicken Sie nun mit der RECHTEN Maustaste auf den markierten Dateinamen.
  5. Klicken Sie in dem erschienenen Menü auf den Eintrag 'Öffnen mit...'.
  6. Wählen Sie nun das Programm, mit dem ein Bericht geöffnet werden soll, z.B. den Internet-Explorer (iexplore).
  7. Zur dauerhaften Verknüpfung setzen Sie das Häkchen bei: 'Diesen Dateityp immer mit diesem Programm öffnen'.
  8. Klicken Sie zur Bestätigung auf die Schaltfläche OK.
  9. Fertig. Ab jetzt startet beim Öffnen eines Berichts immer das gewählte Programm.


ezBank 2.5.5 - Eine Berichtsdefinition ändern

Eine Berichtsdefinition ändern

So geht das:
  1. Die Berichtsfunktion finden Sie im Hauptmenü "Zahlung" als Menüpunkt "Berichte" oder bei einer geöffneten Liste oder eines Datensatzes im Hauptmenüpunkt "Bearbeiten" bzw. im Kontextmenü. Es öffnet sich das Fenster "Bericht wählen".
  2. Markieren Sie denjenigen Bericht in der Liste, den Sie ändern möchten, und klicken auf die Schaltfläche Ändern. Es öffnet sich das Fenster "Bericht bearbeiten"
  3. Im Eingabefeld "Bezeichnung" können Sie nun einen neuen Berichtsnamen eingeben.
  4. Mit Klick auf das Ordner-Icon neben dem Eingabefeld "Vorlagedatei" öffnet sich der Editor mit dem Quellcode. Sie können nun den Quellcode ändern.
  5. In der Auswahlliste "Filterbedingung" können Sie bei Bedarf eine Filterabfrage auswählen oder eine Filterbedingung frei eingeben. Damit haben Sie ein Werkzeug, mit dessen Hilfe Sie den Inhalt des Berichts an Ihren Bedarf anpassen können. Siehe Lektion Berichte und Filter
  6. Bei einem HTML-Bericht können Sie im Reiter "Einstellungen" noch Anpassungen zur Darstellung vornehmen:
    - Im Eingabefeld "Schriftart" können Sie die Schriftart definieren.
    - In den folgenden tabellenartig gegliederten Eingabefeldern können Sie den Bericht gestalten, ohne dass Sie im Quellcode arbeiten müssen. Dazu ist zu sagen, dass die Elemente (Bericht, Titel, Schrift 3, Schrift 4, Schrift 5), die Sie gestalten können, im Quellcode innerhalb von CSS als Klassen definiert sind, sogenannte CSS-Style-Sheets. Am besten können Sie das am Beispiel des Berichts "Gegenkontenliste" erkennen, da dieser Bericht alle Elemente beinhaltet.
    Elementname in ezBank | Elementname als Klasse im Quellcode | Bedeutung für den Bericht
    Bericht | Body | Alles, was nicht anders definiert ist, erscheint in der dort festgelegten Schriftgröße, Schrifttyp, Ausrichtung, Schriftfarbe und Hintergrundfarbe.
    Titel | Report | Überschrift des Berichts. Im Beispiel: "Gegenkontenliste".
    Schrift 3 | Block | Überschrift der einzelnen Blöcke. Allerdings sind die wenigsten Berichte in Blöcke gegliedert, deshalb kommt diese Klasse sehr wenig zum Einsatz.
    Schrift 4 | Titel | Überschriftzeile in der Tabelle.
    Schrift 5 | Daten | Daten in der Tabelle.
  7. Bestätigen Sie nun Ihre Eingaben mit Klick auf die Schaltfläche OK des Fensters "Bericht bearbeiten". Es öffnet sich das Fenster "Bericht wählen", in dessen Liste der veränderte Bericht erscheint. Mit Klick auf die Schaltfläche Erstellen öffnet sich die entsprechende verknüpfte Anwendung (Browser, Word, Excel) und der Bericht wird angezeigt.


ezBank 2.5.5 - Eine neue Berichtsdefinition erstellen

Eine neue Berichtsdefinition erstellen

Das Erstellen eines neuen Berichts erfordert technisches Know-How. Deshalb können Sie sich jederzeit an unsere Programmierer wenden, wenn Sie einen Bericht benötigen, der so noch nicht in ezBank vorliegt. Dennoch bietet ezBank für technisch versierte Anwender komfortable Zugangsmöglichkeiten für die Erstellung neuer Berichte.

So geht das:

  1. Die Berichtsfunktion finden Sie im Hauptmenü "Zahlung" als Menüpunkt "Berichte" oder bei einer geöffneten Liste oder eines Datensatzes im Hauptmenüpunkt "Bearbeiten" bzw. im Kontextmenü. Es öffnet sich das Fenster "Bericht wählen".
  2. Klicken auf die Schaltfläche Neu. Es öffnet sich das Fenster "Bericht bearbeiten".
  3. Im Eingabefeld "Bezeichnung" können Sie nun einen neuen Berichtsnamen eingeben.
  4. Nun wählen Sie eine Vorlagedatei. Dies geht über das Icon mit den drei Punkten '...' neben dem Eingabefeld "Vorlagedatei".
  5. Im folgenden fahren Sie fort wie unter "Eine Berichtsdefinition ändern" beschrieben.


ezBank 2.5.5 - Datenexport

Datenexport

ezBank 2.5.5 bietet Ihnen mit der Exportieren-Funktion eine komfortable Möglichkeit, bestimmte Datensatzgruppen in verschiedene andere Dateiformate zu überführen. Sie können somit flexibel mit Ihren Daten umgehen und diese auch mit anderen Programmen verwenden, zum Beispiel für Serienbriefe über Word oder einer anderen Textverarbeitung. Siehe dazu auch Lektion Serienbriefe über den Export.

Dabei kann die Exportieren-Funktion je nach Verwendungszweck auf zwei verschiedene Arten angewandt werden.

Exportieren kompletter Tabellen

Exportieren ausgewählter Datensätze

Weiter zum Kapitel Datensicherung ...


ezBank 2.5.5 - Exportieren kompletter Tabellen

Exportieren kompletter Tabellen

Eine allgemeine Funktion mit sämtlichen verfügbaren Exportdefinitionen finden Sie im Hauptmenü "Datei" - "Exportieren". Damit können Sie komplette Listen in ein anderes Dateiformat exportieren, um beispielsweise mit diesen Daten auf einem anderen Rechner mit einer anderen Anwendung arbeiten zu können.

Im Fenster "Exportdefinitionen" ist eine Liste mit den möglichen Datensatzgruppen, die Sie exportieren können. Markieren Sie die Exportdefinition, die Sie zum Exportieren verwenden möchten, und klicken Sie auf die Schaltfläche OK.

"Exportdefinitionen" sind vordefinierte Listen, die Sie aus den in ezBank 2.5.5 enthaltenen Tabellen und den darin verfügbaren Feldern selbst zusammenstellen können. Dies bedeutet beispielsweise, dass Sie eine eigene Adressliste nur mit den zum Exportieren relevanten Adressdaten anlegen können. Vor allem wenn öfters die gleichen Daten exportiert werden sollen, kann diese durch eine einmalige Definition immer wieder leicht wiederholt werden.
Eine "Exportdefinition" wird über eine sogenannte SQL-Abfrage bedient. Für das Erzeugen einfacher SQL-Abfragen steht eine unterstützende Eingabemaske zur Verfügung. Falls Sie sich jedoch in SQL-Abfragen auskennen, können Sie die Abfrage direkt in das SQL-Feld der Eingabemaske schreiben.

Die "Exportdefinitionen" finden Sie unter dem Hauptmenüpunkt "Datei" in der Funktion "Exportieren".

Eine neue Exportdefinition erstellen

Das Erstellen einer Exportliste wird hier an einem Beispiel erklärt:
Für einen Newsletter soll eine Gegenkontenliste mit E-Mail-Adresse, Vorname, Name und Briefanrede erstellt werden. Dabei sollen natürlich nur Adressen mit einer eingetragenen E-Mail-Adresse exportiert werden.

So geht das:

  1. Klicken Sie im Hauptmenü "Datei" auf die Funktion "Exportieren". Es öffnet sich das Fenster mit den "Exportdefinitionen".
  2. Im Fenster "Exportdefinitionen" klicken Sie auf die Schaltfläche Neu. Sie kopieren nicht und es öffnet sich das Fenster "Neue Exportdefinition".
  3. Im Fenster "Neue Exportdefinition" geben Sie in das Feld "Bezeichnung" eine passende Bezeichnung ein. Für unser Beispiel würde die Bezeichnung "Adressen mit eingetragener E-Mail-Adresse" passen.
  4. Dann wählen Sie im Feld "Haupttabelle" die Tabelle "GEGENKONTEN" aus. Es ist sinnvoll die Adressen nach der E-Mail-Adresse zu sortieren. Deshalb wählen Sie "EMAIL" in das Feld "sortieren nach".
  5. Nun wählen Sie die gewünschten Felder der Liste aus. Dazu markieren Sie das entsprechende Feld im Feld "Felder - verfügbar" und transferieren es per Klick auf die Schaltfläche '>' in das Feld "Gewählte Felder". Für unsere Beispielliste sind das die Felder "EMAIL" (für die E-Mail-Adresse), "VORNAME" und "NAME" (für den Namen) sowie "BANREDE" (für die Briefanrede).
  6. Jetzt wird die Filterabfrage gesetzt. Es sollen ja nur Adressen mit einer eingetragenen E-Mail-Adresse exportiert werden. Dies erreichen Sie, indem Sie in das Feld "Filterbedingung" folgende Filterabfrage schreiben: EMAIL LIKE "*@*". Mehr dazu finden Sie unter "Filtermöglichkeiten"
  7. Nun können Sie überprüfen, ob die Liste richtig definiert wurde. Klicken Sie dazu auf die Schaltfläche Prüfen. Wenn alles stimmt, bestätigen Sie Ihre Eingaben mit Klick auf die Schaltfläche OK des Fensters "Exportdefinitionen".


ezBank 2.5.5 - Exportieren ausgewählter Datensätze

Exportieren ausgewählter Datensätze

Sie haben auch in jeder Liste die Möglichkeit, die ausgewählten - also markierten - Datensätze zu exportieren. Die Vorteile, die sich hier anbieten sind, dass Sie die Datensätze direkt einsehen können, und dass Sie diese durch Filtern (siehe Kapitel Filtermöglichkeiten) und Markieren (siehe Kapitel Listenbedienung) auf eine für Sie interessante Gruppe (z.B. alle Personen, die im aktuellen Monat Geburtstag haben) einschränken können.

So geht das:

  1. Filtern Sie aus der Gesamtliste die gewünschte Gruppe (siehe Kapitel Filtermöglichkeiten)
  2. Markieren Sie entweder alle oder aber die gewünschten Datensätze (siehe Lektion Markieren)
  3. Öffnen Sie das Export-Fenster mit "Bearbeiten" (oder aus dem Kontextmenü "Bearbeiten" mit Klick mit der rechten Maustaste) und "Exportieren"
  4. Wählen Sie die Felder, die exportiert werden sollen (z.B. Anrede und Anschrift für Serienbriefe)
  5. Wählen Sie das Dateiformat, wohin exportiert werden soll
  6. Starten Sie den Export mit Klick auf OK
Hinweis: Über die Schaltflächen Alle wählen und Keine wählen wird die Liste mit den Feldnamen entweder komplett markiert oder komplett demarkiert. Die Schaltfläche Auswahl invertieren kehrt die Auswahl um: es werden also markierte Felder demarkiert und demarkierte Felder werden markiert.

Die so erstellte Datei mit den exportierten Adressen können Sie beispielsweise in Word zum Erstellen eines Serienbriefes nutzen (siehe auch Lektion Serienbriefe über den Export).


ezBank 2.5.5 - Datensicherung

Datensicherung

Die "Datensicherung" umfasst zwei Funktionalitäten:
Einmal können Sie mit Hilfe der Datensicherung eine komprimierte Backup-Datei (Standard zip-Datei) erstellen, aus der bei einem Datenverlust der ursprüngliche Datenbasiszustand wiederhergestellt werden kann.
Sie können aber auch Datenbanken und wahlweise andere Dateien auf ein beliebiges anderes Laufwerk in einen beliebigen anderen Ordner kopieren. Damit können die Daten z.B. auf ein Notebook transferiert werden, damit Sie mit dem Notebook unterwegs oder über das Wochenende arbeiten können.

Datensicherung

Die Datensicherung

Die Datenwiederherstellung

Weiter zum Kapitel Kontaktmöglichkeiten ...


ezBank 2.5.5 - Die Datensicherung

Die Datensicherung

Zum besseren Verständnis werden hier zuerst einige Begriffe erklärt:
Datensicherungsauftrag: Ein Datensicherungsauftrag beinhaltet einen oder auch mehrere Datensicherungssätze. Das bedeutet, dass mit der Durchführung nur eines Datensicherungsauftrags gleich mehrere Datensicherungssätze bearbeitet werden können. Somit können Sie Ihre Datensicherungssätze sinnvoll in Datensicherungsaufträgen gliedern und bei der Durchführung Zeit sparen.
Datensicherungssatz: Ein Datensicherungssatz ist Bestandteil eines Datensicherungsauftrags. Ein Datensicherungssatz beschreibt einen bestimmten Sicherungsjob mit einer bestimmten Datenquelle und dem Sicherungsziel.
Datenquelle: Eine Datenquelle bezeichnet die Ordner mit Dateien und gegebenenfalls Unterordner, die gesichert werden sollen. Die Datenquelle wird also durch eine genaue Pfadangabe benannt.
Sicherungsziel: Das Sicherungsziel ist ein bestimmter Ordner, der die komprimierte Backup-Datei bzw. die zu sichernden Dateien als Kopien beinhalten soll. Das Sicherungsziel wird ebenfalls durch eine Pfadangabe genau benannt.

Datensicherungsauftrag

::: Mitgelieferte Datensicherungsaufträge :::

::: Erstellen eines Datensicherungsauftrags :::

::: Datensicherungs-Optionen :::

::: Durchführen einer Datensicherung :::


ezBank 2.5.5 - Mitgelieferte Datensicherungsaufträge

Mitgelieferte Datensicherungsaufträge

Zu Ihrer Arbeitsunterstützung und als Beispiele liefert ezBank 2.5.5 bereits einige definierte Datensicherungsaufträge mit Datensicherungssätzen mit. Die Quelldateien der Datensicherungssätze sind Ordner oder Datenbanken - sogenannte "Karteien" - im Programminstallationsverzeichnis und/oder im Installationsverzeichnis der Datenbanken. Als Sicherungsziele werden verschiedene Beispiele genannt. Dabei steht das Laufwerk F: beispielhaft für die Sicherungsziele Server, Notebook oder Memory-Stick. Sicherungen auf die Festplatte des Rechners können ohne Änderung verwendet werden, da diese Laufwerke bekannt sind und die Sicherungsordner entweder schon mitgeliefert sind oder bei der ersten Durchführung des Datensicherungsauftrags angelegt werden.

Es gibt folgende mitgelieferte Datensicherungsaufträge

Datentransfer auf Server/Notebook/Memorystick:
Dieser Datensicherungsauftrag beinhaltet beispielhaft mehrere Datensicherungssätze, mit denen zum einen die Datenbasis (die Kartei) und die Vorlagen sowie die erstellten Dokumente, Briefe und E-Mails durch Kopieren auf das Laufwerk F: gesichert werden.

Komplettsicherung mit allen Ordnern:
Dieser Datensicherungsauftrag beinhaltet ebenfalls beispielhaft mehrere Datensicherungssätze, mit denen für Datenbasis, Vorlagen, Dokumente, Briefe und E-Mails jeweils eine komprimierte Backup-Datei erstellt wird, die durch Kopieren auf das Laufwerk C: in den Ordner Datensicherung\ezBank und Unterordner gesichert werden.

Schnellsicherung auf Festplatte:
Diese Datensicherungsaufträge erstellen jeweils eine komprimierte Backup-Datei, die nur die Datenbasis (Kartei) enthält, und stellt diese in den Ordner "Backup" im "Ausführen in"-Ordner.


ezBank 2.5.5 - Erstellen eines Datensicherungsauftrags

Erstellen eines Datensicherungsauftrags

  1. Bevor Sie einen Datensicherungsauftrag erstellen, schließen Sie alle offenen Fenster des Programms.
  2. Die Datensicherungsfunktion finden Sie im Hauptmenüpunkt "Datei". Klicken Sie auf den Untermenüpunkt "Daten sichern" des Menüpunkts "Datensicherung". Es öffnet sich der Dialog "Datensicherung starten...". Dieser Dialog beinhaltet eine Liste mit allen bereits vorhandenen Datensicherungsaufträgen.
  3. Klicken Sie auf die Schaltfläche Neueingabe des Dialogs "Datensicherung starten...". Es öffnet sich der Dialog "Details zum Datensicherungsauftrag".
  4. Zuerst geben Sie in das Eingabefeld "Name" eine passende Bezeichnung für den neuen Datensicherungsauftrag ein.
  5. Mit einem Doppelklick ins Feld "Ziel" oder mit Klick auf die Ordner-Schaltfläche neben dem Feld "Ziel" erscheint der Dialog "Ziel-Ordner wählen", womit Sie den Pfad (Laufwerk und gegebenfalls den Ordner) des Datensicherungs-Ziels wählen.

Automatische Datensicherungssätze
Klicken Sie im noch geöffneten Dialog "Details zum Datensicherungsauftrag" auf die Schaltfläche Neueingabe. Bei einem neuen Datensicherungsauftrag, der noch keine Datensicherungssätze enthält, haben Sie nun die Möglichkeit, aus drei Vorschlägen automatisch Datensicherungssätze zu erstellen. Dabei gibt es folgende Wahlmöglichkeiten:

  • Vorschlag für eine Komplettsicherung: Dabei werden fünf Datensicherungssätze erstellt zur Sicherung der Datenbasis, des Vorlagenordners und der Ordner für Dokumente, Briefe und E-Mails, jeweils zusammen gepackt (komprimiert) in fünf Backup-Dateien (zip-Dateien).
  • Vorschlag für eine Datenbanksicherung: Dabei wird nur ein einzelner Datensicherungssatz erstellt zur Sicherung der Datenbasis, ebenfalls zusammen gepackt (komprimiert) in eine Backup-Datei (zip-Datei).
  • Vorschlag für eine komplette Kopie: Dabei werden fünf Datensicherungssätze erstellt zur Sicherung der Datenbasis, des Vorlagenordners und der Ordner für Dokumente, Briefe und E-Mails. Hier aber NICHT gepackt sondern als exakte Kopie der Ordner auf das gewählte Datensicherungs-Ziel.
  • Datensicherungssatz selbst anlegen: Damit werden KEINE Datensicherungssätze automatisch erstellt sondern Sie können völlig eigene Datensicherungssätze definieren.

Erstellen eines eigenen Datensicherungssatzes
Natürlich können auch eigene Datensicherungssätze erstellt werden:

  1. Klicken Sie im geöffneten Dialog "Details zum Datensicherungsauftrag" auf die Schaltfläche Neueingabe. Bei einem neuen Datensicherungsauftrag ohne Datensicherungssätze wählen Sie aus dem Vorschlags-Menü den Punkt "Datensicherungssatz selbst anlegen", sonst ist dies nicht mehr nötig. Es öffnet sich der Dialog "Datensicherungssatz", mit dessen Hilfe Sie den ersten Datensicherungssatz zu diesem Auftrag erstellen können.
  2. Geben Sie in das Eingabefeld "Name" eine passende Bezeichnung für diesen Datensicherungssatz ein.
  3. Geben Sie in das Eingabefeld "Quelle" den Pfad des Quell-Ordners ein. Sie können das Quellverzeichnis aber auch mit Hilfe des Dialogs "Quell-Ordner wählen" auswählen, indem Sie auf die Ordner-Schaltfläche neben dem Eingabefeld "Quelle" klicken.
  4. In das Eingabefeld "Dateien" geben Sie nun ein, welche Dateien Sie vom Quellverzeichnis gesichert haben möchten.
    Beispiel: *.* sichert alles, *.mdb sichert nur die Datenbanken, *.doc sichert alle Word-Dokumente
  5. Wählen Sie nun die gewünschten Optionen: Mit "Dateien komprimieren (zip)" wird bei der Durchführung der Datensicherung eine komprimierte Backup-Datei (zip-Datei) erstellt, ansonsten werden die angegebenen Dateien nur kopiert. Mit "immer ALLE Dateien sichern" werden alle Dateien des Quell-Ordners gesichert, ansonsten werden nur die Dateien gesichert, die sich im Vergleich zum Ziel-Ordner geändert haben. Mit "alle Unterordner mit sichern" wird der Quell-Ordner mitsamt aller Unterordner gesichert, sonst nur der Quell-Ordner.
  6. Geben Sie in das Eingabefeld "Ziel" den Pfad des Ziel-Ordners ein. Sie können das Zielverzeichnis aber auch mit Hilfe des Dialogs "Ziel-Ordner wählen" auswählen, indem Sie auf die Ordner-Schaltfläche neben dem Eingabefeld "Ziel" klicken.
    Der Platzhalter "[Ziel]" steht für das im Datensicherungsauftrag definierte Zielverzeichnis. Damit muss bei einer etwaigen Änderung des Zielverzeichnisses nicht jeder Datensicherungssatz einzeln geändert werden - es genügt die Änderung im Datensicherungsauftrag, dies wirkt sich über den Platzhalter "[Ziel]" dann automatisch auf alle so definierten Datensicherungssätze aus.
    Der Ziel-Ordner muss übrigens noch nicht vorhanden sein. Er wird gegebenenfalls bei der Durchführung der Datensicherung automatisch angelegt.
  7. Zuletzt kann noch eine FTP-Verbindung angegeben werden. Dann wird die erstellte Datensicherungsdatei auch auf den dort angegebenen FTP-Server transferiert.
  8. Bestätigen Sie nun Ihre Eingaben mit Klick auf die Schaltfläche OK des Dialogs "Datensicherungssatz". Damit wird der eben definierte Datensicherungssatz gespeichert und dem Datensicherungsauftrag zugeordnet.
    Nun können Sie beliebig weitere Datensicherungssätze wie beschrieben erstellen und diesem Auftrag zuordnen.
  9. Abschließend speichern Sie den kompletten Datensicherungsauftrag mit Klick auf die Schaltfläche OK.


ezBank 2.5.5 - Datensicherungs-Optionen

Datensicherungs-Optionen

"Dateien komprimieren (zip)"

Aktivieren Sie diese Option, dann wird eine Backup-Datei erstellt, die auch für eine spätere Datenwiederherstellung genutzt werden kann.
Die Backup-Datei wird automatisch komprimiert (zip-Datei), wobei alle Dateien und gegebenenfalls Ordner des Quell-Ordners in eine einzige Datei zusammengepackt werden. Der Name dieser Backup-Datei setzt sich aus dem Datum und der Uhrzeit der Datensicherung zusammen.
Eine so erstellte Backup-Datei wird nie überschrieben, somit sind fortlaufende Datensicherungen möglich.

Wird diese Option nicht aktiviert, dann wird keine Backup-Datei erstellt, die Dateien und gegebenenfalls Ordner des Quell-Ordners werden vielmehr einzeln in den Ziel-Ordner kopiert. Dabei werden also eventuell zuvor in denselben Ziel-Ordner kopierte Dateien überschrieben.
Eine solche Kopie (auch Datentransfer genannt) kann nicht nur zum Zweck der Datensicherung genutzt werden. Der Datentransfer ermöglicht auch, Daten für die ortsunabhängige Arbeit auf ein Notebook zu kopieren. Damit können Sie dann mit dem Notebook unterwegs oder über das Wochenende daheim arbeiten. Danach können die Daten über einen Datentransfer vom Notebook wieder auf den Bürorechner oder den Server transferiert werden.
Hinweis: Dabei wird KEIN Datenabgleich zwischen beiden Rechnern durchgeführt, die Dateien werden nur kopiert. Das heißt, wenn auf dem Zielrechner zwischenzeitlich gearbeitet wurde, dann gehen die Änderungen verloren, wenn der Datentransfer durchgeführt wird.

"immer ALLE Dateien sichern"

Aktivieren Sie diese Option, dann werden immer alle Dateien des Quell-Ordners gesichert, auch wenn diese bereits so gesichert vorliegen und sich nicht geändert haben.
Hinweis: Beim Sichern in eine zip-Datei werden IMMER alle Dateien gesichert. Diese Option wird dabei also automatisch eingeschaltet und läßt sich nicht mehr abschalten.

Wird diese Option nicht aktiviert, dann werden nur die Dateien gesichert, die sich gegenüber dem Ziel-Ordner geändert haben. Sind im Ziel-Ordner noch keine Dateien vorhanden, dann werden natürlich ebenfalls alle Dateien gesichert.

"alle Unterordner mit sichern"

Aktivieren Sie diese Option, dann werden nicht nur alle Dateien des Quell-Ordners gesichert, sondern auch alle im Quell-Ordner enthaltenen Ordner, Unterordner und darin enthaltenen Dateien.
Es ist dabei unerheblich, ob dabei eine Backup-Datei erstellt wird oder die Dateien mit Ordnern nur kopiert werden. In beiden Fällen werden mit dieser Option auch alle Ordner mit in die Backup-Datei "gezippt" oder eben in den Ziel-Ordner kopiert.

Wird diese Option nicht aktiviert, dann werden nur die direkt im Quell-Ordner enthaltenen Dateien gesichert, keine Dateien von etwaigen Unterordnern.


ezBank 2.5.5 - Durchführen einer Datensicherung

Durchführen einer Datensicherung

  1. Bevor Sie eine Datensicherung durchführen, schließen Sie alle offenen Fenster des Programms.
  2. Die Datensicherungsfunktion finden Sie im Hauptmenüpunkt "Datei". Klicken Sie auf den Untermenüpunkt "Daten sichern" des Menüpunkts "Datensicherung". Es öffnet sich der Dialog "Datensicherung starten...". Dieser Dialog beinhaltet eine Liste mit allen bereits vorhandenen Datensicherungsaufträgen.
  3. Markieren Sie den gewünschten Datensicherungsauftrag und klicken zur Durchführung des Datensicherungsauftrags auf die Schaltfläche Starten der Datensicherung.
  4. Die Datensicherung wird nun automatisch durchgeführt. Dabei wird für jeden Datensicherungssatz mit Option "Dateien komprimieren (zip)" eine Backup-Datei erstellt und ein entsprechender Eintrag zur Daten-Wiederherstellung erzeugt.
  5. Nach Fertigstellung des kompletten Datensicherungsauftrags wird das Datum der Sicherung eingetragen.


ezBank 2.5.5 - Die Datenwiederherstellung

Die Datenwiederherstellung

Natürlich können verlorengegangene Dateien mittels einer Datenwiederherstellung aus einer Backup-Datei wieder in das Programm bzw. den entsprechenden Ordner wiederhergestellt werden.
Dabei ist zu beachten, dass mit jeder Durchführung einer Datensicherung eine Backup-Datei erzeugt wird, und zwar immer im Zielordner des ersten Datensicherungssatzes eines Datensicherungsauftrags.

Hinweis: Die Datenwiederherstellung sichert wieder diejenigen Daten zurück, die in der Backup-Datei stehen, die für die Datenrücksicherung benutzt wird. Daten, die seit der Erstellung dieser Backup-Datei verändert wurden, gehen dadurch zwangsläufig verloren.

::: Durchführen einer Datenwiederherstellung :::


ezBank 2.5.5 - Durchführen einer Datenwiederherstellung

Durchführen einer Datenwiederherstellung

  1. Bevor Sie eine Datenwiederherstellung durchführen, schließen Sie alle offenen Fenster des Programms.
  2. Die Datenwiederherstellungsfunktion finden Sie im Hauptmenüpunkt "Datei". Klicken Sie auf den Untermenüpunkt "Daten wiederherstellen" des Menüpunkts "Datensicherung". Es öffnet sich der Dialog "Datenwiederherstellung starten". Dieser Dialog beinhaltet eine Liste aller Backup-Dateien, die bei der Durchführung eines Datensicherungsauftrags erstellt wurden.
    Hinweis: Es kann sein, dass die Meldung erscheint: "In diesem Ordner existieren keine Wiederherstellungssätze". Schließen Sie in diesem Fall diesen Hinweis mit Klick auf die Schaltfläche OK und klicken Sie dann auf die Schaltfläche Backup-Ordner. Wählen Sie in dem nun geöffneten Dialog "Backup - Ordner wählen" den Ordner aus, in dem Ihre Datensicherung (und damit auch die Backup-Datei) gespeichert ist. Nun erscheint in der Liste alle Backup-Dateien, die in diesem Ordner vorhanden sind. Der Name einer Backup-Datei besteht aus Datum (jjjj,mm,tt) und Uhrzeit (hhmmss). Daran können Sie die aktuellste Datei erkennen. Diese ist auch bereits markiert.
  3. Markieren Sie nun den gewünschten Datenwiederherstellungssatz in der Liste und klicken Sie zur Durchführung auf die Schaltfläche Starten der Wiederherstellung.
  4. Als nächstes öffnet sich der Dialog "Wiederherstellungs-Optionen". Hier ist standardgemäß die Option "Hinweis, falls Datei bereits existiert" aktiviert. Dies bedeutet, dass Sie bei Dateien mit identischen Namen gefragt werden, ob die Datei im Zielordner durch die gesicherte Datei ersetzt werden soll. Diese Aktion ist die sicherste von allen, da sie für jede Datei eine Kontrolle bietet, kann aber insbesondere bei vielen Dateien auch lästig sein. Aktivieren Sie die Option "Dateien immer überschreiben", werden alle Dateien im Zielordner von gesicherten Dateien mit identischem Namen ohne Hinweis überschrieben. Die Option "Dateien niemals überschreiben" bewirkt, dass Dateien mit identischem Namen nicht überschrieben werden.
  5. Klicken Sie schließlich auf die Schaltfläche OK des Dialogs "Wiederherstellungs-Optionen", um die Datenwiederherstellung zu starten.


ezBank 2.5.5 - Kontaktmöglichkeiten

Kontaktmöglichkeiten

In diesem Kapitel finden Sie Kontaktmöglichkeiten und alles, was Sie an Hilfe und technischer Unterstützung zu ezBank 2.5.5 erhalten können.

Unsere Anschrift

ezSoftware
Erich Schuster
Hauptstrasse 18
CH-8253 Diessenhofen

Telefon-Hotline: +41-76-6117058

E-Mail: hilfe@ezSoftware.info
Internet: www.ezSoftware.info

Software-Support zu ezBank per Fernwartung

Technische Unterstützung im Internet

Preise und Bestellmöglichkeiten


ezBank 2.5.5 - Software-Support zu ezBank per Fernwartung

Software-Support zu ezBank per Fernwartung

Sie möchten, dass Ihnen möglichst schnell telefonisch per Fernwartung geholfen wird? So können Sie unseren Software-Support zu ezBank 2.5.5 über die Telefon-Hotline nutzen:
  1. Über vorher gekaufte 60 Hotline-Minuten: Online-Bestellschein - Nicht verbrauchte Hotline-Minuten werden für späteren Support aufbewahrt.


ezBank 2.5.5 - Technische Unterstützung im Internet

Technische Unterstützung im Internet

Hier finden Sie Hilfe und technische Unterstützung zu ezBank 2.5.5 im Internet:
  • FAQ - Ihre Fragen / unsere Antworten
    Hier im FAQ-Bereich (FAQ = Frequently Asked Questions) finden Sie häufig gestellte Fragen und unsere Antworten dazu. Vielleicht wurde Ihre Frage bereits gestellt und ist hier beantwortet.

  • Anfrage/Kontakt
    Andere Anfragen nicht technischer Art - z.B. Werbeanfragen, Anfragen zu individueller Entwicklung und ähnliches - die weder im FAQ-Bereich noch in unserem Forum beantwortet sind, können Sie hier über unser Kontaktformular stellen.

  • Fragen zum Preis und Bestellung
    Alle Preise und Bestellmöglichkeiten finden Sie auf diesem Bestellschein. Dort können Sie per Bankeinzug oder am besten per Vorkasse (mit 5% Skonto) bestellen. Der Preis wird durch das Bestellformular automatisch entsprechend Ihren Angaben errechnet und ausgewiesen.
    In jedem Fall erhalten Sie eine Rechnung per E-Mail zugeschickt.


ezBank 2.5.5 - Preise und Bestellmöglichkeiten

Preise und Bestellmöglichkeiten

Kaufen: Bestellung per Internet

Online-Bestellschein
Alle Preise und Bestellmöglichkeiten finden Sie auf diesem Bestellschein. Dort können Sie per Bankeinzug oder am besten per Vorkasse (mit 5% Skonto) bestellen. Der Preis wird durch das Bestellformular automatisch entsprechend Ihren Angaben errechnet und ausgewiesen.
In jedem Fall erhalten Sie eine Rechnung per E-Mail zugeschickt.


Anrede: Herr
Name: Schuster
Vorname: Erich
Strasse: Dr.-Atzinger-Str. 1a
PLZOrt: 94036 Passau
Telefon: 0700 - 39 76 38 92
Telefax: 0751 - 76 46 25 70
EMail: schuster@ezSoftware.de
Geburtstag: 06.06.1963
Beruf: EDV-Berater
Konto: 8980294
BLZ: 600 501 01


FELDER:ANREDE;NAME;VORNAME;STRASSE;LAND;PLZ;WOHNORT;TELEFON;EMAIL;GEBURTSTAG
Firma;Autohaus Car and More GmbH;;Hanns-Klemm-Str. 25;DE;71034;Böblingen;07031 - 66 08 -0;info@carandmore.de;
Frau;Fuhs;Isabell;Teckstr. 4;DE;71101;Schönaich;07031 - 28 69 63;fuhs@comsia.de;24.01.1978
Herr Doktor;Hansen;Rolf;Bahnhofstr. 14;DE;71101;Schönaich;07031 - 75 09 57;;
Herr Doktor;Hutt;Robert;Entenbachweg 22;DE;71044;Sindelfingen;07031 - 65 76 11;;
Herr;Schuster;Erich;Herdlauchring 47;DE;71101;Schönaich;07031 - 28 69 63;schuster@ezSoftware.de;06.06.1963
Firma;TÜV Stuttgart;;Schwabstr. 5;DE;70366;Stuttgart;0711 - 6 57 -0;tuev@stuttgart.de;
Firma;ezSoftware e.K.;;Federburgstr. 15;DE;88214;Ravensburg;0700 - 39 76 38 92;info@ezSoftware.de;